Previous 1 2 Next 23 Replies Latest reply: Jul 21, 2011 10:32 AM by sillyvalley
Eric D. Level 2 Level 2
expertise.macosx
Mac OS X

Over the past few days, I've noticed that the "Download All Free Updates" won't work in iTunes to get the latest versions of my Apps.  Usually, I can download them all individually without an issue but sometimes one gets "stuck" and even though it downloads, it still shows that an update is available.  When I click the "Download All Free Updates" button (or text), it does show activitiy with the iTunes store but the downloads never start.  Also, if I select "Check for available downloads", nothing happens either.  This is happening on both the new 10.4 version and the previous version.

 

Any ideas?


iMac 3.06 GHz 24, Mac OS X (10.7), 4 Gigs RAM
  • Jeff Tanders Level 1 Level 1

    I'm having the same problem...

  • adamrc Level 1 Level 1

    I'm having the same problem as well.

  • Under the Clouds Level 1 Level 1

    I just noticed this problem tonight, after downloading Lion.  I had 6 iphone/ipad updates, but when I pressed the "Download All" button, nothing happens.  Tried it several times.  I was able to download each update by clicking on it individually.  Clearly, Apple has a bug that needs to be fixed.

  • sidlinger Level 1 Level 1

    Me, too. I have several Macs, all on 10.6.8, and this started happening to me on all of them a few days ago.

     

    Upgrading to iTunes 10.4 did not fix it.

     

    Deauthorizing all my computers and then re-authorizing one did not fix it.

     

    -Bruce

  • joe619 Level 1 Level 1
    expertise.macappstore
    Mac App Store

    Same problem here as well.  I tried signing out and signing back into my account in itunes, but it still did NOT solve the problem. 

  • caryblack Level 1 Level 1

    +1, I can download each of them individually, or directly to my iPad/iPhone, but cannot grab them all in iTunes.

  • rbrian Scotland Level 2 Level 2

    Same here, with all the latest updates, Lion, iTunes 10.4.  Give it a couple of days, and no doubt there'll be 10.4.1. which will fix it.  In the meantime, as caryblack says, downloading each individually works.

  • Camty_Cai Level 1 Level 1

    Same problem. Maybe this is apple server problem. Nothing we can do. Just keep click one by one temporarily.

  • dhsundwall Level 1 Level 1

    I'm not so sure this an iTunes or a server problem.  I noticed this exact problem for me last night before 10.4 was released.  And updating didn't change anything.

     

    I seem to recall a similar problem a few months ago when I updated a specific app.  It turned that the app update was causing everyone problems and once it was deleted, the problem was gone.

     

    So it may not be an iTunes specific problem, although it is lame that for all the scrutiny apps are supposed to get that they can't screen for update-crashing apps.

     

    I'm not sure how to go about testing to see which of my recently updated apps may be causing this.

  • william77046 Level 1 Level 1

    I'm having the same problem, like with others if I download the updates individually they are sucessfull. 

  • sillyvalley Level 1 Level 1

    It's got to be the latest iTunes update.  I received the notification this morning, accepted the update, and this started happen to me immediately.  My last successful "Download All Free Updates" was but last night!

  • joe619 Level 1 Level 1
    expertise.macappstore
    Mac App Store

    It's NOT the update, as I started having this problem yesterday before applying the update.  I hoped that the update would clear things up, but it did NOT. 

  • Kevenly Level 1 Level 1

    I have been having this same issue and it started around three days ago running Snow Leopard and the latest iTunes release at that time!  I have now installed Lion and the latest iTunes and it is STILL not working.  It connects to the iTunes store, and it even gives me the warning if anything is "over 17 content" but after that nothing happens.  Likewise check for available downloads also does not work and exhibits the same behavior, i.e. it connects to the iTunes store, going through all the normal processes but then there is just dead nothing.

  • Louis Trapani Level 1 Level 1

    The same issue here for the last few days. It's not Lion, as I haven't updated yet, though I have updated iTunes to the latest and the issue is still there.

Previous 1 2 Next