Previous 1 2 3 4 Next 52 Replies Latest reply: Jun 28, 2015 7:32 PM by lyanneag Go to original post
  • skybullet Level 1 Level 1 (0 points)

    Here's how I have fixed the problem with the help of a Mac expert over the phone (Mac Book Pro 5.5 Intel based processor) :

     

    http://support.apple.com/kb/ht3964

     

    and

     

    http://support.apple.com/kb/ht1379

     

    Good luck!

  • rasmus cph Level 1 Level 1 (0 points)

    For the Lion users:

    There seems to be multiple issues with the airport-driver in Lion. I had the same problem with the "no hardware installed" when I clicked on the airport icon. Replacing the Lion-airport-driver with the latest Snow-Leopard-driver, solved the problem on my macbook pro 13" (early 2011). Another thread explains how you how to do that:

     

    https://discussions.apple.com/thread/3194446?start=45&tstart=0

     

    it is quite easy - you simply drag on file and drop it on another and the replacement is done automaticly.

  • Tony850 Level 1 Level 1 (0 points)

    So as I had run into this problem in good timing (the semester just began) WIFI: No hardware installed decided to bless me with its unwanted troubles. Now I tried every solution that everyone has posted. Reset this and that, flick on/off this and that. Even tried for  giggles changing the firmware to SL. NOTHING WORKED!!

     

    Then I for fun decided to tear apart and hunt for the problem in the hardware.

     

    http://www.ifixit.com/Guide/Installing-MacBook-Pro-13-Inch-Unibody-Mid-2010-AirP ort-Card/6024/1

     

    I followed those instructions and took apart the display to get the airport chip. I got to it with no problems at all. the black clutch was a bit tricky. But I digress. I took the airport chip out. blasted it some compressed air, cleaned the connectors( i used one of those rubbing alcohol pad and LET DRY). Put the everything back together. I left everything torn apart for a good 20 minutes.

     

    Boot it up.

     

    Saw the WIFI symbol up top and Bada Bing it asked me to install the "new airport card" to get it functioning. So far its working like a charm no problems. NO MORE WIFI No Hardware installed !!!!!!!!!!!!!!

  • Tony850 Level 1 Level 1 (0 points)

    well after two runs at this attempt, the card goes back to No Hardware installed after I close the lid.

  • zpig Level 1 Level 1 (0 points)

    MAN! i have the same, if not similiar problem! My Macbbok pro is only 4 months old and i used it the other day, closed it, left it closed, but not off, for like 15 min then opened it back up to see that my airport didn't work....with the message no hardware installed.... Has anyone found a cure for this madness yet!?!??

     

    any help is appreciated! thanks.

  • zpig Level 1 Level 1 (0 points)

    it is a 15" 2 Ghz 7i core 4 Gb DDR3 if this helps

  • ramgarge Level 1 Level 1 (0 points)

    Zpig,  I suggest you to take it to apple store. Your MBP is still under warranty. They will run hardware test to find if card is failed. I think that Lion is causing hardware failure, apple is still ignoring problem caused by Lion.

  • GCarr Level 1 Level 1 (0 points)

    I too suffered the very frustrating “Wifi- No Hardware Installed” for the past month after upgrading to Lion (mid 2009 MBP running 10.7.2). I finally resigned myself to replacing the wifi card. Prior to ordering a new card, I took a last stab. Lo and behold, it has consistently worked for three days now.

     

    Here’s what I tried that didn’t work

    Ran Hardware Test (everything checked as okay), reinstalled Lion, Reset PRAM and SMC,  deleted wireless locations, reset routers and tried 5 different locations and routers, restarted a thousand different times checking and unchecking the “reopen windows when logging back in” box. Basically I tried everything in the support community


    What finally worked? I tried these last three together so I’m not sure which did the trick but I would try the easy Bluetooth remedy first.


    1) Downgraded my WiFi drivers to the 10.6.4- there seems to be a problem with both Atheros and Broadcom chipset drivers- see directions here- http://thoughts.maayank.com/2011/08/wireless-problems-with-macbook-air-and.html


    2) Turned on Bluetooth (I’ve always had it turned off)


    3) Ordered a cheap USB Wifi stick (perhaps my Mac was shamed into finally working)


    On an editorial note, I was fairly ****** with Apple never acknowledging they had a problem. Google “wifi no hardware found, mac” and you’ll get 8 million hits. Clearly there’s a problem. My family has 5 macs plus a few ipads, iphones, etc. Not that they’ll ever notice but I recently purchased a new phone. The choice came down to a iPhone or Droid. I went with the latter.

  • Y_NO Level 1 Level 1 (10 points)

    I too am having the same problem.  I stumbled upon the following solution from a blog.  It worked for me:

     

    Just UNCHECK that "Re-open windows when logging back in" button when you log out or shut down and then restart.

     

    http://macnerd-presents.blogspot.com/2011/08/os-x-lion-wifi-no-hardware-installe d.html

  • joafromblaricum Level 1 Level 1 (0 points)

    My just 4 months old late 2011 15" high end mbp started this wifi: hardware not installed about a week ago. Initially i could get it back up by restarting. Later that night it happened again, no fix mentioned here worked. Next day after a timemachine restore i got wifi again by deleting and adding the wifi connection in the preferences. After waking from sleep the problem returned. Now when i delete wifi i don't even have the option to re-add it.

    So I took the laptop back to the store. After a week (today) i was emailed that the airport card was replaced and that everything was tested and working.

    Happy that it didn't took more time i went back to the store, only to find my mbp behaving exacly the same as before the repair... Guy in the store updated something and now i had wifi again, even after rebooting.

    As a final check i put the mbp to sleep. After waking the connection was gone and there was no way to get wifi again.

    Now i still have to wait for them to find the solution, guy in the store thought it might be motherboard related or something.

    I really hope they can fix this soon, because this is not what i expect from a €2000+ machine after only four months.

    And i'm sorry to say, but this really undermines my trust in Apple products. For now, it just doesn't work.

  • GCarr Level 1 Level 1 (0 points)

    I had the same issue. I tried everyhing on this and every other board and finally succumbed to replacing the wireless card. Just like you, it only worked for a day so I took it back. It seems the wireless card wasn't at fault. There was a problem with the logic board.

     

    Off it went to Apple for a new logic board and two days later it came back working. It's been a month and everything has been fine since. Here's the part they replaced:

     

    Apple replaced part# 620-4719 (Display Panel or Assembly), and 605-2050 (Main Logic Board 2.53GHz). Apple paperwork is with the computer. Computer is ready for pickup

  • joafromblaricum Level 1 Level 1 (0 points)

    This is a follow-up on my previous post.

     

    After replacing my wifi/airportcard, they now replaced the connecting flexcable. Problem solved!

    But when I got home I noticed the right screen hinge now makes a clicking sound when I open or close the display.

    Today I went back to the store, hoping there was a quick fix. I was happy they called the repair centre immediately to pick up the laptop and check it while I went into town to shop for some other stuff I needed.

    After 20 minutes they called and said they had to replace the whole display. They were so kind to let me take the laptop back home until the new display arrives and then they will reassemble it in an hour or so.

     

    Hopefully better news soon.

  • supalex06 Level 1 Level 1 (0 points)

    strange

  • joafromblaricum Level 1 Level 1 (0 points)

    And better news it is!

     

    The display arrived today so I brought my mbp back to the store. A couple of hours later they called that I could pick it up again. Thumbs up for the fast service!

     

    Now back to enjoying my great computing device...

  • Darth Level 3 Level 3 (630 points)

    I had this problem show up today out of nowhere on a late 2011 MBP running 10.7.4. Tried many suggested solutions - sleeping and waking, shutting down and restarting, unchecking the reopen windows box in the shutdown dialog, unchecking the show Wi-Fi status in menu bar box and trying to turn wi-fi on. Right now, things are working again after resetting the SMC. Off to my local Apple store for a checkup tomorrow morning.