Previous 1 2 3 4 Next 45 Replies Latest reply: Apr 3, 2014 2:23 AM by tikilab Go to original post
  • simonbarber Level 1 Level 1

    Still experiencing this, even after the upgrade to 10.7.1. Surprised that something so disruptive hasn't been fixed. Perhaps it only affects a small number of us? Either way, I've reported it via the popup. Hope you have too.

  • dinofromvancouver Level 1 Level 1

    Hey All, So I was able to fix the issue.

    I spent a few hours on the line with a number of people at Apple support, eventually had to send the script and computation history to apple engineers, they called me back today with a solution.

     

    The problem is caused by a corrupt video file, in my case it was an mp4 file. And because the file was on the desktop, each time I restarted, or opened a finder window that opened to the desktop folder, the error would pop up.

     

    I deleted the file and the problem seems to have been fixed.

    Next time you have it pop up while navigating finder, check the folder that you just navigated from or to. Check for video files. The easy way to tell which one it is, is from the thumbnail. In my case, regular file thumbnails show the first frame of the video in question. Whereas the corrupted file shows a default video logo image (Like Quicktime logo, or likely whatever your default video player is).

     

    Hope that helps,

    Cheers.

    TheDabblingDilettante.com

  • 4ll3N Level 1 Level 1

    @dinofromvancouver Thanks for the info, i was able to fix my issue as well!!!!

     

    I had a "bad", ie non playable in Quicktime, video on my desktop. I deleted the file and so far no more error messages regarding VTDecoder*.

  • simonbarber Level 1 Level 1

    Thanks for your efforts, this seems to work for me too!

  • henrycsbc Level 1 Level 1

    I don't think that deleting the file is acceptable. For me, I can use another video player to open it - it is not a broken file. Changing the permissions of the file, I feel, would be a better solution?

  • simonbarber Level 1 Level 1

    I simply put the offending file in a folder so that I don't see it unless I navigate into that folder. This allowed me to keep the file and avoid the error. Hope that helps.

  • henrycsbc Level 1 Level 1

    It works if you just option click the file and go to "get info" - then just change which program it opens with. In my case, using VLC solves the problem.

  • nyteraine Level 1 Level 1

    Just changing mine to VLC did not solve the problem, but also changing the extension to something instead of .mp4 at least made the error message stop. This is sort of ridiculous; a piece of the OS shouldn't crash completely if it runs into an incompatible/broken file.

  • TheActualCustomer Level 1 Level 1

    In my case the file was corrupt and so it was ok to be removed.

     

    It's quite annoying to get an error all the time, but I guess they are trying to show previews etc and not fixing all the non-critical bugs.

  • Writingaway Level 1 Level 1

    This worked for me also.  I have a lot of files on my desktop and so when I read the solution, I was not sure where to start looking.  I did find it eventually on my desktop and it was a dvd video file with only the audio, but no video ts files.  What was interesting was I had not attempted to open this folder, but I still got the VTDecoderXPCService quit unexpectedly error message when using the mac.  So in my case it was the fact that the corrupt file was on the desktop that triggered the error message as I went about my daily business on the computer.  So glad to have found it as this error popped up every 10 minutes and I was about to roll back lion.

  • brandomduke Level 1 Level 1

    Everytime I try to play videos in iPhoto that I imported from my iPhone I get the same problem and, at the same time, the videos look all pixelated in contrast to how I see them in my iPhone.

  • Zaimejs Level 1 Level 1

    Thanks! This fixed it!

  • gmeijer Level 1 Level 1

    Thanks dinofromvancouver

     

    It fixed my problem.

  • Michael Paine Level 2 Level 2

    In Finder I listed all movies, sorted by date and realised an aborted video conversion had left a (corrupted) MP4 file. Trashed (and emptied) that file and the problem went away. It must have something to do with Quickview scanning files for possible display with Quicktime.

     

    No good that a corrupt video file can do this.

  • h p Level 1 Level 1

    Nice; i have a thousand video's on mij computer. Now i have to find out which one is causing this error?

    I have found a workaround: disregard the message; i move the error to another work space and leave it un touched there.

     

    I don't have time anymore to try find a fix.