Previous 1 2 3 4 Next 45 Replies Latest reply: Apr 3, 2014 2:23 AM by tikilab Go to original post
  • bigboy99 Level 1 (0 points)

    FaceTime also uses this process.

  • xhunter Level 1 (30 points)

    I've been having this problem with VTDecoderXPCService for some time now. However, instead of it crashing when I open Finder, it crashes every time it is running and I open Calculator (what?). I have tried removing any .m4v or .mp4 files I have on my desktop, but this has been unsuccessful. Any tips?

  • Michael Paine Level 2 (335 points)

    It possibly has something to do with spotlight indexing files anywhere on the hard disk (and the associated quickview). The corrupt video file is not necessarily on the desktop. Try searching for files elsewhere.

  • xhunter Level 1 (30 points)

    Any tips on finding this corrupt file? I don't want to go through every single video/audio file on my computer...

  • Michael Paine Level 2 (335 points)

    Only my tip of 21st March - use Finder to list all movies (or MP4 and M4V files), sort by date and check the more recent ones. Select each file in turn and press the spacebar to try to open it in Quickview.

  • JoshuaDevine Level 1 (0 points)

    I had this issue, but another forum pointed me to the issue almost immediately.  It is an issue with a corrupt MP4/M4V video file.  I had this happen while experimenting with handbrake so it was easy to identify the culprit.  If you don't know which one it is may I suggest copying the entire error message into TextEdit and then use the Find tool to search out a file name.  I would try searching for MP4 or M4V to start and get more imaginitive if nothing comes up.  I didn't get a chance to see if the filename comes up as I knew right away which file was the issue.

  • precipi Level 1 (0 points)

    @dinofromvancouver Thank you so much. it worked to me. corrupt .mp4 in desktop cause this.

    But I think this is something Apple should patch....

  • LASERmanPL Level 1 (0 points)

    Thanks a lot

  • AlanGP Level 1 (0 points)

    This fault tends to occur for me when I download a YouTube Video using MacX Video Convertor Pro. I have had this behaviour for about 18 months and always assumed it was the programme. However, several versions of MacX Video Convertor later it is still happening and I understand from this thread that it is an OS problem.

     

    the question is what are Apple doing about it? I am on my fourth OSX version since purchasing the Mac and it is still an issue.

     

    I have far too many video files to go through each one in turn and most of my converted files (mp4) have a generic Quicktime icon - they cannot all be corrupt. Although a minor issue it is very irritating!!

     

    AlanGP

  • rogerinlondon Level 1 (0 points)

    For what it is worth, I tried out TVMobili and started to get this error message after having attempted to index a lot of movies. After unistalling TVMobili completely, it has never popped up again. Hope it can help someone as it is a really annoying thing....

  • Michael Paine Level 2 (335 points)

    This Apple update might help

    http://support.apple.com/kb/HT5806

  • Mijkol Level 1 (0 points)

    I have jst been experiencing the same issue even with me using VLC as my video player - best option I have found it to remove Quicktime payer altogether and this has fixed up this isse immediately

  • fjullian Level 1 (5 points)

    Having the same problem but with a file generated on a website, i have a lot of video files and never had this problem just started when viewing a video file on a website.

     

    The problem is that the file is not corrupted because it opens with another computer.

     

    Will apple do something with this or they are expecting the problem to fix it self?

  • mg11361 Level 1 (0 points)

    This happens to me also but when there is a movie in a websire (fr example, product video on 6PM).  No downloaded files. Keeps opening contstantly even after I quit allt he browsers.  Don't know how to make vlc the defaut viewer in any browser .

  • Heggli Level 1 (0 points)

    I found a solution that helped me!

     

    In my case i downloaded some mp4 files from a client, with h.264 codec.

    VTDecoderXPCService went mad!

     

    But i transferred the files to an external drive, then they worked properly, no VTDecoder problems, and i could open them in a fileconvert program so i could get it to a suitable format!