Previous 1 2 3 Next 501 Replies Latest reply: Jan 26, 2015 4:29 AM by nikitok
Vance Jackson Level 1 Level 1

After installing Lion, I have found I am unable to search network drives (Windows network) like I used with Snow Leopard. Any suggestions?

iMac, Mac OS X (10.7)
  • atwoodrepro Level 1 Level 1

    Same issue here. Here is a screenshot of "results" within a network drive.



  • tomfromnewtown Level 1 Level 1

    Unfortunately I'm also having the same problem.  The network drives appear in the finder but no search results.  Does anyone have any ideas on why this may be happening?

  • Franco Borgo Level 1 Level 1
    Mac OS X

    I have many network drive and they all work.


    Maybe you can check a few things


    1. In system's preferences -> spotlight -> Privacy

         check to be sure your network drive is not in it.


    2. In activity Monitor

         Check if mdworker and/or mds are running (could be a longer name - see link below)

         It seems Lion need to re-index everything

         if they are running it mean the indexing is not over yet.


    if they are not running

         an easy way to force sportlight to re-index is:

         1. In system's preferences -> spotlight -> Privacy add the drive you want to re-index

         2. Quit System's preferences

         3. Logout of your sessions

         4. Login again :-)

         5. In system's preferences -> spotlight -> Privacy remove the drive you want to re-index

         6. Wait.. a faily long time. You should see mdworker and/or mds running


    Hope this help.


    Process info

  • tomfromnewtown Level 1 Level 1

    thanks Franco.  When I tried to add an exception for the drive in spotlight, I selected the drived from the 'shared' list in the dialog, unfortunately the CHOOSE button remains grayed out.


    Also, I checked the processes - mdworker is running but us using between 0 to 0.1%.  I've had the mac on for a couple of days now so would expect that indexing would be completed by now.


    In snow leopard, a search on a network drive in the "shared" area of the finder would show that the drive was being searched through the grayed out spinning asterisk but in lion there is no indication at all that a search is occurring.

  • Franco Borgo Level 1 Level 1
    Mac OS X



    What protocol are you using to access the drive (AFP, SMB?)

    Some people have problems with network drive, it could be related.

  • tomfromnewtown Level 1 Level 1

    They are both appearing as SMB drives.


    One is a QNAP NAS and the other is a USB drive connected to a Netgear router (WNDR3700 v1).  I've had no problems whatsover accessing the files and data, its just the searching that is a problem.

  • Franco Borgo Level 1 Level 1
    Mac OS X

    I just found this


    but since you have the same problem on both drive, I doubt it will solve your problem.


    could it be Firewall related or Little snitch type of control ?


    You could also find the Command-line way to re-index the drive.

  • MalcontentsUnite Level 1 Level 1

    I'm having the same issue with the Finder in Lion not returning any results in a search over an SMB share even though there are clearly matching files present. I'm able to search an AFP share on my Lion Mac Mini with no problem.


    The SMB share doesn't appear in the Spotlight Privacy settings. I tried running a manual reindex on it with mdutil but was told that indexing is disabled. So maybe a bug of some sort?

  • Franco Borgo Level 1 Level 1
    Mac OS X

    Nice work, we are getting closer.


    Could you start indexing on this particuliar drive

    for this thread


    there is this command

    sudo mdutil -i on /Volume/network_volume

  • tomfromnewtown Level 1 Level 1

    Funnily enough I did update the QNAP firmware 2 days ago but it didn't fix the issue.  I've also disabled Little Snitch and Virusbarrier v6, still no joy.


    When I tried running the mdutil command I got the following error:

    Error: invalid path `/Volume/mediashare'  -  where mediashare is what is showing in the shared heading in the finder.


    Have I entered the command incorrectly?


    I've also tried accessing my Windows 7 share and am getting 'Connection: failed'.  When I click on Connect As... it now just shows 'Connecting'.


    Update: a reboot fixed the Wondows 7 connection issues but not the other problem.


    Message was edited by: tomfromnewtown

  • tomfromnewtown Level 1 Level 1

    Ok, was able to check the status of indexing.  It is confirmed as being enabled on all drives.  I also used Onyx to rebuild the spotlight index.


    Problem still exists.  Funnily enough, if I do a search within a network share folder for a folder name, the results appear, but only at the top level of that folder ie. the search will not look within folders on the drive.


    Will try calling Apple support today to determine next steps.

  • Franco Borgo Level 1 Level 1
    Mac OS X

    I have tried the mdutil command and it worked fine on my network drive but the is an "s" at volume. It migght just be a transcript error when you wrote this message.


    I can't wait ot heard the solution from Apple. I do not have SMB share but I help a lot of people and I will probably hace this problem one day :-)

  • Fugu Agency Level 1 Level 1

    How did you get on Tomfromnewtown?


    I'm having the same problem. Can search locally on the HD but not network drive connected via SMB. Really not good.


    Tried all of the above; forced re-index, Terminal command etc., to no avail.


    Anyone else found a solution?

  • The WW1 Ace Level 1 Level 1

    Seeing the same problem. Some searches bring up a few files living in one specific subdirectory of the share, but otherwise search is useless on SMB shares.

Previous 1 2 3 Next