Skip navigation

Unable to search network drives with Lion...

189505 Views 492 Replies Latest reply: Apr 7, 2014 3:20 AM by DrNicolaus RSS
  • UmpaEG Calculating status...
    Currently Being Moderated
    Aug 23, 2012 2:34 AM (in response to LostAccount)

    Well yes your quite correct, although I feel your splitting hairs, the point I was trying to make is the fact that search is broken, and Mountain Lion does not fix this unlike what Mojo66 claims. 

     

    The thread originally was about Lion, so the link does pertain to the spirit of the thread.

     

    The Free App 'Easy Find" works a treat for me every time and I recomend people install and use that as a get you going solution, as you know were on 10.8 and its still not fixed, and I don't know if Apple are even working on a fix, I think they must be aware of the problem after this amount of time.

  • eretria Calculating status...
    Currently Being Moderated
    Aug 23, 2012 4:54 AM (in response to LostAccount)

    sudo mdutil -i on /Volumes/<name>

     

    does not work for me.  The command succeeds, I get a message that indexing is enabled, but there is no spotlight indexing icon as reported...

     

    I am running SL.

  • Rick Fernandez1 Level 1 Level 1 (55 points)
    Currently Being Moderated
    Aug 23, 2012 7:57 AM (in response to eretria)

    I have to add that in addition to this not staying active after reboot/log out, it also just doesn't work at all. The command completes, but spotlight continues NOT to search my NAS. Simply doesn't show up, even though it's listed in the /Volumes folder.

  • UmpaEG Level 1 Level 1 (25 points)
    Currently Being Moderated
    Aug 23, 2012 9:46 AM (in response to Rick Fernandez1)

    I use Easy Find now, I have found this kludge to be hit amd miss. I get the same results as eretria, although after a while mine does find files on the nas.

  • LostAccount Level 1 Level 1 (80 points)
    Currently Being Moderated
    Aug 23, 2012 2:49 PM (in response to eretria)

    Remember, after using the said command, sudo mdutil -i on you SHOULD NOT change the name of the volume you ran this command against because it is stored locally and refers back to it.

     

    Also, you should click the spotlight icon and you should observer the "Indexing (name of drive)" and the barber pole indicating the index.

     

    You can also that your drive is indexing by running this command:

    lsof | grep /Volumes/

     

    If you repeat the lsof command every now and again you will find that mdworker is accessing the volume that is being indexed.

     

    PS I never expoerienced this issue in Snow Leopard at all and I was connected to about 100 different remote servers and search always worked there. I don't know what Apple changed in 10.7 and 10.8 (if it was or is affected)

     

    Hope this helps.

  • andybc Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 23, 2012 3:18 PM (in response to UmpaEG)

    I just downloaded the 10.8.1 update and I can't believe my eyes--I actually can Finder search all my drives--external, and two smb-networked computers (both root and subdirectories).

  • Looter Level 1 Level 1 (55 points)
    Currently Being Moderated
    Aug 23, 2012 3:57 PM (in response to andybc)

    Wow, can a few others verify? Might almost be enough to convince me to upgrade to ML (and eventually upgrade a few machines that have been sunset at Lion).

  • UmpaEG Level 1 Level 1 (25 points)
    Currently Being Moderated
    Aug 23, 2012 4:24 PM (in response to Looter)

    I see no real change. I can search a mounted share but not the nas as a whole, and if I knew my file was on a perticular share I would not need to search for it..

     

    More work needed.

  • eretria Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 23, 2012 4:38 PM (in response to LostAccount)

    The process that "LostAccount" is reporting does not work for me.

     

    After sudo mdutil -i on /Volumes/Data, the barber pole does not appear on the spotlight menu item, and "lsof | grep /Volumes/" does not list mdworker.

     

    Too bad.. :-(

     

    I would be very interested in knowing if other people can report if 10.8.1 works in this case.  For me, too, if it does, that's a good enough justification for me to buy it.

     

    Thanks...

  • Hans Luijten Level 1 Level 1 (10 points)
    Currently Being Moderated
    Aug 23, 2012 7:13 PM (in response to andybc)

    Just updated to 10.8.1 as well ... Spotlight is still NOT searching my NAS, or mounted NAS Volumes.

    Maybe I'm missing somthing here?

     

    Also mdutil fails as well:

     

    sudo mdutil -i on /Volumes/<server>/<share>/

    /Volumes/<server>/<share>:

    Error: unable to perform operation.  (-400)

              Error: unknown indexing state.

  • LostAccount Level 1 Level 1 (80 points)
    Currently Being Moderated
    Aug 23, 2012 7:14 PM (in response to eretria)

    I wonder if it is already indexed?

     

    Try the following:

    In Finder:

    Finder>Preferences>Advanced

    When performing a search:

    Searcht the Current Folder

     

    Screen Shot 2012-08-24 at 4.08.37 AM.png

     

    Connect to your NAS

     

    In the Finder window displaying the content of your NAS search, don't use the spotlight icon use the Finder window to search.

     

    Screen Shot 2012-08-24 at 4.13.39 AM.png

  • Hans Luijten Level 1 Level 1 (10 points)
    Currently Being Moderated
    Aug 23, 2012 8:50 PM (in response to LostAccount)

    I tried exactly that ... and my settings do match yours ... no dice.

    Immediately shows "0 items" and does not even attempt a search (unlike EasyFind and ForkLift).

  • LostAccount Level 1 Level 1 (80 points)
    Currently Being Moderated
    Aug 23, 2012 9:24 PM (in response to Hans Luijten)

    Your issue is peculiar alright

     

    I am not sure which device you have but considering how little specifics I have other than the issue you report, I wonder if this article is relative or not. http://support.apple.com/kb/HT4700 (Connecting to legacy AFP services)

     

    Also, if possible, I would connect that device directly to your mac to ***** whether you can search when it's connected directly.

     

    Also, you should perhaps try an FTP server or other SMB/AFP connection types to see if they work. It would be a good idea to isolate the issue by testing against other configurations.

     

    As an FYI, I updated to 10.8.1 which yielded a restart and I continue to have no issues. My setup is a bunch of hard drives attached to a USB hub which is in turn connected to the USB port of an airport extreme which is extending an Airport Express's network.

     

    I mounted my "Music" drive and searched for "abc". In a matter of seconds I got my results up on screen.

     

    Please submit any further information here or contact AppleCare. If you purchased Mountain Lion remember that it enjoys 90 days of technical support from the date of purchase you purchased Mountain Lion on.

     

    For the time being, you may want to try:

    sudo mdutil -i off (the path to your NAS drive)

    You can leave a space after the word 'off ' and then drag and drop the NAS drive icon into the terminal window to complete the path for you.

     

    Then run:

    sudo mdutil -i on (the path to your NAS drive)

     

    I will be happy to help in anyway I can and I hope this helps.

     

    Kind Regards

  • andybc Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 23, 2012 9:44 PM (in response to UmpaEG)

    Before 10.8.1 I could not use finder search, and now I can. The Spotlight search is another beast altogether--one I do not usually use. It is true that I can't just use a single search for everything on my network. But, for me, I know what computer and drive certain types of files are kept, so the ability to use Finder Search and a nifty app called Alfred (works like a powerful Spotlight Search) do seem to work just fine now. Also, as my network does not have a central NAS, I don't know if the .1 upgrade works for searches there.

  • UmpaEG Level 1 Level 1 (25 points)
    Currently Being Moderated
    Aug 24, 2012 1:58 AM (in response to andybc)

    Do you mean your hitting cmd/F and then entering your data in the search tab at the top of the finder window ?

1 ... 25 26 27 28 29 ... 33 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (25)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.