Previous 1 26 27 28 29 30 Next 501 Replies Latest reply: Jan 26, 2015 4:29 AM by nikitok Go to original post
  • LostAccount Level 1 Level 1 (100 points)

    Do you mean your hitting cmd/F

    That's an option yes…

  • UmpaEG Level 1 Level 1 (25 points)

    Its an option, but is it what andybc is doing ?

     

    Is there any other way to search just using the finder ?

  • LostAccount Level 1 Level 1 (100 points)

    No that's about the only way I use to search network drives.

     

    To search your built in drive, the easiest is to just to go the spotlight icon and type.

  • UmpaEG Level 1 Level 1 (25 points)

    Yeah thats what I do too, I'm doing some tests at the moment.  What I do is make sure the NAS has a mounted share (little arrow next to it in sidebar) > cmd/F click on 'shared' then do a search for files known to be on the drives.  I'll let you know what happens.

  • LostAccount Level 1 Level 1 (100 points)

    Correct…

     

    You can click the little triangle so that the volumes appear and then double click them all to mount them.

     

    Then you can simply do a command-F and search the shared as you mentioned.

     

    It will find on all shared volumes. Works fine for me.

  • andybc Level 1 Level 1 (0 points)

    UmpaEG wrote:

     

    Its an option, but is it what andybc is doing ?

     

    Is there any other way to search just using the finder ?

    Just to be clear : my normal setup is three smb-networked computers (2 PCs, one iMAC, with an external drive), each with three drives. When I boot the MAC, the other computers show up as "shared." I can use Finder to look at and/or search the drives, directories, and subdirectories. Command-f works on a drive level to seach an entire drive, but not an entire shared computer. If I boot up another computer on my network, Wifi (I've also got a PC acting as an entertainment center, and Macbook Pro), these too are searchable with Finder in the same manner,

     

    I also have a MAC app called Alfred that works similarly to Spotlight, but can be customized to add drives from networked computers. In this case, I can search my entire iMAC and the networked computer drives selected with one search, without digging down through Finder.

     

    None of the above options were available to me before 10.8.1. As do others in this thread, I used Find Any File to search drives other than the iMac.

  • ydk2 Level 1 Level 1 (0 points)

    Look in too AppStore is there Apple add new product OS X Server, heh next standard system function go to another comercial OS extention.

  • macobs30 Level 1 Level 1 (5 points)

    Hello All,

     

    It seems Apple recognized the issue: Look at this list from the new Lion (not ML) update 10.7.5.:

     

    ***

    The 10.7.5 update also includes fixes that:

    • Resolve an issue where icons in Launchpad may get rearranged after a restart
    • Improve Wi-Fi reliability for iMac (Late 2009 and newer)
    • Resolve an issue using Spotlight to search an SMB server
    • Improve compatibility connecting to Active Directory servers

    ***

     

    I am installing the update as I am typing this.

     

    Let's see.

  • UmpaEG Level 1 Level 1 (25 points)

    well, I'm on ML now and many of the issues still persist, there is as you will already know by now a new update for ML and I don't think it addresses the issues.

  • The WW1 Ace Level 1 Level 1 (0 points)

    It looks like 10.8.2 is taking some steps towards making this work. After I installed 10.8.2 the first time I tested the finder search box against an SMB share (Windows 7 Home Premium) it worked, but after that it stopped working again. This was right after the 10.8.2 reboot.

     

    More testing shows that this seems to be working only sometimes on a fresh connect. I.e. unmount the SMB share, use Command-K to connect to the server again, and in the new finder window that pops up do the search. Once you've succeeded in one search, you need to unmount and remount the share to get the search to work again. This seems to work most of the time, though not consistently. However, this is better than any behavior I've seen since I installes 10.7.

     

    Obviously we can't say that this is fixed, but at least it's a step in the right direction.

  • two freckles Level 1 Level 1 (0 points)

    I really don't get it how is it possible that such basic and fundamental thing as searching is still not working ? Where should I report it so they finally do they job properly, maybe they are not aware about this problem ?

  • ChazThePhoenix Level 1 Level 1 (10 points)

    Do you really think they don't know and you and you alone will have to report this?  I don't mean to be rude, but please read thru and see -its been reported... Many times. 

  • two freckles Level 1 Level 1 (0 points)

    I wish I had such power And no offence taken, but honestly I don't know what to think about it anymore. Searching is like one of most important engines in MacOS, spotlight is build in to many apps including mail etc. (where Apple is so proud about those features). Such issue should be fixed within days and now here we are. Apple has time to deploy new system but can't repair such basic issue? Thats totally unprofessial from my point of view.

     

    I'm mad because pretty soon I want to replace my machine at work and if seraching is still not working under Lion I'll be forced to go with some PC.

     

    So maybe Apple needs to hear more voices from a John Doe like me to put their highest priority about this matter (this is why I asked where to report it)?

  • pepa_u Level 1 Level 1 (0 points)

    Well, actually, things went even worse with 10.7.5! Now Spotlight works only partly even on the local disk, because it is not able to index it in a reasonable time! Plus, they screwed up Time Machine.

     

    https://discussions.apple.com/message/19731431?ac_cid=op123456#19731431

    https://discussions.apple.com/thread/4324046

     

    Everything we discuss here was reported many times...

  • LostAccount Level 1 Level 1 (100 points)

    Hello Pepa_u et all

     

    If you are still facing issues, I would like to volunteer this information.

     

    Re spotlight index to your local drive

    1) Go to the spotlight system preferences and add your internal drive to the privacy tab

    2) Now remove it from the privacy tab

    -The two steps above causes spotlight to reindex your internal drive, which can help with time machine backups as well because backups rely on the index

     

    Re spotlight index to your shared drives (hanging off extremes, SMB, FTP, AFP…)

    1) Go to the spotlight system preferences and add your internal drive to the privacy tab

    2) Now remove it from the privacy tab

    3) Open terminal and type the command in step 2

    4) sudo mdutil -i on path-to-volume (when it comes to the path-to-volume, simply mount your drive, add a space after the command noted here in step 2 followed by dragging and dropping your mounted drive to the terminal window)

    3) You need to type in your administrator password, as you type there is no feedback. Press enter after typing your password of course.

     

     

    In both cases above, if you click on the spotlight icon, you should see indexing going on. Please note, there may be a few seconds delay before you see the index progress bar appear.

     

    If it does not index, repeat steps 1 and 2 for either scenario.

     

    Small caveat:

    Since the index is stored locally on your computer's local volume, the drive you are indexing, especially with network drives, the 'server' or remote volume MUST remount with exactly the same name each time or it won't pair up the server/remote volume with the local index.

     

    PS, yes this has absolutely been reported to Apple. If anyone here is still having issues and you believe your issue is better looked at outside this thread I recommend creating a new post with your specific situation. Highlight specific details regarding your OS version, hardware and symptoms and if reproducible, point those out as well.

     

    I hope this helps.

Previous 1 26 27 28 29 30 Next