Previous 1 2 3 4 5 Next 66 Replies Latest reply: Jan 8, 2014 6:18 AM by Pinksteady Go to original post
  • JoeLion Level 1 (0 points)

    well, maybe it's a "one line code change" thing, but I would be careful when assuming how easy any change to a critical funtion (sleeping/waking) of a huge operating system would be.

     

    We really have no way of knowing if the change in Lion was a business decision, or a technical one. It could have been a business decision, where, for example one of the OS X managers likes to use his macbook with the lid shut, and got tired of waking it back up after shutting it and told an engineer to "flip a switch" to make it happen. Or maybe some of the new graphics subsystems or libraries in Lion require the video card to remain active for some reason (i'm just making stuff up here) and implementing the old Snow Leopard behavior would have required a lot more work and they decided to drop it. Who knows....

  • O.M Level 1 (0 points)

    Well my mac book pro doesn't go to sleep when I close it and neither when I press "sleep". But everytime I close it without turn in it off starts to get hot and the light doesn't flash as is supposed to. I just wanna know if it's a problem with the battery or what?

  • chfn Level 1 (0 points)

    I have the same problem since updating to Mountain Lion only, on my MBPro 2010.... Please let me know when a correction will be available (best would be an optional set-up).

  • deriesCZ Level 1 (0 points)

    Hi guys, the same problem here. I talked to tech support and here is one recommendation from them - report this bug as a feedback here: http://www.apple.com/feedback/  ... if there will be more reports, hope they put it as any "option" in Preferences. But they told we need to report this in feedback form. I reported it as a Mac OSX bug, so here: http://www.apple.com/feedback/macosx.html

  • Marty2000 Level 1 (0 points)

    This "NoSleep" is exactly the opposite of the issue we have here. Our MBP will NOT sleep, when we close the lid in osx 10.7, because the external monitor IS connected (and power is connected too).

  • Marty2000 Level 1 (0 points)

    If your Mac does not go to sleep at all (independend of an external monitor) you have a complete different issue, which is discussed in several other discussions, like: https://discussions.apple.com/thread/1070629?start=0&tstart=0

    Apple advice to this is here: http://support.apple.com/kb/HT1776?viewlocale=en_US&locale=en_US

    But it seems there is no help, if the sleeping issue only occurs when the external monitor is connected.

    I found out, that it will work, if either the external monitor or the power supply is disconnected for the moment when closing the lid.

  • Marty2000 Level 1 (0 points)

    jk10003 wrote:

     

    ...

    sudo nvram boot-args="iog=0x0"

    ...

    One snag was that I had to run it with the external monitor disabled, but it worked great!

     

    Yeepee, it finally worked. My MPB (late 2008) with OSX 10.7.4 is sleeping again, when closing the lid, even so the external monitor (and power) is connected.

    The trick came from jk10003 above AND the comment of having the external monitor "disabled" when doing so AND doing a reboot. Only after typing the command in terminal again (confirming this with my password), while having my external monitor DISCONNECTED, and rebooting again, I have the "normal" behaviour again. :-)

  • nunox Level 1 (10 points)

    Hello

    Finally fixed it!! After reading so many pages including this thead, I went into print and scan features unchecked the "share printer over network option"! It worked!!!

  • admgtz Level 1 (0 points)

    thank you so much! I've been looking for a fix for this for over a year, and this is the only way that’s worked.

  • nunox Level 1 (10 points)

    I'm so glad it worked for you as well!! I never been so happy just looking at my Macbook on sleep mode! Lol.

  • nunox Level 1 (10 points)

    One quick note, uncheck the printer sharing option, need to umpluged the power cord and remove external monitor : (, but sleeping like a baby!!!

  • Domenic.O Level 1 (0 points)

    There are several reason why your laptop may be staying on, when I shut my lip the laptop would continue to run but if you disconcerted the power cable it would then go to sleep. If you enter "System Preferences" this click on the "Sharing" button you will see all types of sharing options. If you have any of the "Sharing" options ticked (The ones with sharing at then end of the word) you will find that your computer does not sleep, untick these and your computer when you close the lip should sleep

  • shaunmwood Level 1 (0 points)

    I have been suffering with this for ages and not wanting to "insert code" or "turn off sharing" as others have suggested i hadnt found a solution until tonight.

     

    I just happened to shut the lid with no power cable connected.

    Both my MBP and my external monitor went to sleep.

     

    so i tried again with the power in and this time my External monitor stayed on and the desktop transferred to there.

     

    I cannot recall if this was the case before Mountain Lion but i find it really easy to just pull out the power cable before shutting the lid, certainly much easier than disconnecting the external monitor.

     

    Hope this helps. (sorry if this has already been suggested)

  • skyspy2 Level 1 (0 points)

    My Macbook pro wouldn't go to sleep. So I started playing with some of the sharing settings. File Sharing had no effect, but when I turned off Internet Sharing it was snooz time.

  • PC Pete Level 1 (0 points)

    This is really confusing.

     

    As a first-time Mac user (Macbook Pro 2012), I found that no matter what I did, I couldn't get the laptop to stay awake when the lid was closed. No preference for it - that confused the **** outta me! - and nothing I could see or find in the online documentation regarding sleeping.

     

    The responses to that enquiry led me to believe that everyone's Macbook automatically went into sleep mode when the lid was closed. In fact, there are third-party apps that specifically disable this functionality (unfortunately they break each time a new OS update is released, but still...).

     

    So finding this thread, where everyone posting seems to assume that it's normal for the exact opposite thing to happen, is really making me scratch my head!

     

    Could someone clarify this for me please? Is the Macbook Pro supposed to always sleep when the lid is closed (which is what mine does, as well as around a dozen other Apple expert users), or is it supposed to stay awake, and you have to do something to make it sleep when the lid is closed (which is what this thread's users seem to find)?

     

    Thanks for any clarification!

    -Pete

     

    N.B. Really? The word h.e.l.l. is censored? My apologies. I wasn't aware this was a fundamentalist religious site.