Previous 1 5 6 7 8 9 Next 133 Replies Latest reply: May 24, 2015 9:23 AM by ponni1269 Go to original post Branched to a new discussion.
  • surf1der Level 1 (0 points)

    Downgrading to snow leopard solved the problem for me.  Lion has been a big fat turd in my opinion.  And now just a year later they are releasing mountain lion.  Lion is the osx version of windows vista.

  • Aismaiil Level 1 (0 points)

    Then hopefully Mountain lion will be the equivalent of Windows 7. I use Windows 7 on my desktop and as far as i'm concerned Windows 7 has been great so far and everything that was wrong with Vista was fixed!

  • Myrdinn63 Level 1 (0 points)

    Thank you Harpo. Removing all stored networks with their keychains and manually adding my prefered network worked out well for me (iMac 21.5 medio 2010 with 10.7.4 just installed with a lot, really a lot of bugs).
    At least until now...

  • garymansell Level 1 (0 points)

    I can confirm that both mine and my partners Macbook Airs (June 2011 models) updated to Mountain Lion 10.8.2 still exhibit this problem!!


    I have to say that this is pretty outrageously poor behaviour from Apple on this issue - this issue has persisted for over a year and two Major releases of Apple's Mac OSX - I know that Apple are aware of it as I had an Apple Support consultant contact me to go through capturing a load of logs and information that he was compiling for some Apple specialists to look into in the US.


    They must be aware of the issue and what causes it by now - it seems to me that it is due to the OS not waking from sleep/hibernation properly, I can't understand why there is not a fix!!!





  • jwmartin83 Level 1 (10 points)

    Looking back on this, this issue kept creeping up because we had two routers in our house broadcasting the same SSID, but each with different network security settings (one had an encryption setting to AES/TKIP, and the other was AES only).  I ended up changing the configuration on my network so the routers have matching wireless encryption settings of AES only, and the issue has been resolved for me for a few months now.


    Hope this helps those out there using multiple access points and are having issues reconnecting after sleep.

  • garymansell Level 1 (0 points)

    Ok I think I have finally solved this most frustrating of issues.


    Basically a nearby router that my macbook can see is incorrectly configured with the wrong country code (or someone has imported a foreign router).

    When the macbook wakes it looks for any wireless signal to understand what country it is in and then only listens on the wireless channels for the country detected.


    I have about 10 wireless networks around me and one of them is set for Country "TW" - I am in Country Code "GB"


    Most of the times the first network I see is the GB one and my laptop looks for my wireless network on the GB wireless channels and connects OK.


    Sometimes, my laptop detects this rogue TW router first and only listens on wireless channels that are correct for TW - it hence can't see my wireless network as it is configured on channel 48 which is not part of the TW approved set of channels:


    Here is a snippet from my syslog:


    Nov  9 18:18:11 GarysMacBook kernel[0] <Debug>: en0: 802.11d country code set to 'TW'.

    Nov  9 18:18:11 GarysMacBook kernel[0] <Debug>: en0: Supported channels 1 2 3 4 5 6 7 8 9 10 11 56 60 64 100 104 108 112 116 120 124 128 132 136 140 149 153 157 161 165



    Hence, the options are find the neighbour with the rogue router and get it fixed/binned, or choose a channel that can be seen by both the rogue router country and your own country.


    The GB channels are:


    Nov  4 14:01:23 GarysMacBook kernel[0] <Debug>: en0: 802.11d country code set to 'GB'.

    Nov  4 14:01:23 GarysMacBook kernel[0] <Debug>: en0: Supported channels 1 2 3 4 5 6 7 8 9 10 11 12 13 36 40 44 48 52 56 60 64 100 104 108 112 116 120 124 128 132 136 140


    Unfortunately for me, my Netgear WNDR3700v2 (N600) router only allows me to chose channels 36, 40, 44 or 48 - None of which are visible if my laptop detects the country as TW !!!!


    I need to find the neighbour with the rogue router, I guess...


    Oh well, at least I know what causes the problem...


    BTW - I could do with the forum thankyou points, so please be generous...





  • garymansell Level 1 (0 points)

    I meant to add - look in the file /var/log/system.log and search for this line to see what country's your machines are picking up:


    system.log:Nov  9 11:36:57 GarysMacBook kernel[0]: en0: 802.11d country code set to 'GB'.





  • budsimrin Level 1 (10 points)

    I want to add a slight addition to Harpo's method, which is simple and works for me so far though I'll want to monitor this for a few more days before I am sure.


    In Harpo's last step he simply says to add the network and password back. I found that instruction to be insufficient because there are several ways to do this and only Aismail's method worked for me. Aismail said NOT to use the Advanced tab to enter the prefered network (using the + sign). I did it that way at first and I simply could not get wifi to find my preferred network automatically after stopping and starting wifi. So, I used the - sign to erase it on the Advanced tab and then used the Network Name drop-down menu (in Network Preferences) to have it find my network and request my WEP password. After that, I have been able to turn wifi off and on repeatedly and it automatically reconnects. I also noticed that the Advanced tab got filled in for me. I haven't rebooted yet but I am hopeful...

  • Aismaiil Level 1 (0 points)

    I honestly haven't had this problem almost since my post, and now I'm using mountain lion on the 13insh MBPr and no problems whatsoever! It might've been a bug ...

  • Elreq Level 1 (0 points)

    So i have read all 8 pages and am now confused:) Which is the working solution to this. I dont need it retyped, you could just tell me which posts to do to get this to work. This has been a frustration of mine for quite a while. Im happy to have found this thread. Now hopefully i can resolve this. It is quite frustrating that the tablets and iphones i have do not have any problems just my macbook.

  • dizm Level 1 (0 points)

    I think the problem just goes away if you stay up to date with Lion. I have 10.7.5 and don't have the problem any more.

  • Aismaiil Level 1 (0 points)

    I second that, though I'm on 10.8.2.

  • Elreq Level 1 (0 points)

    So what do I do in the case that I am completely uptodate on when I check for new software updates and it says I am fully up to date. with 10.6.8

  • budsimrin Level 1 (10 points)

    I would follow the steps so carefully documented by Harpo Marx. But, before proceeding, read my caution (due to Aismaiil)that there are 2 ways to do one of his steps and only one of those 2 ways works. I haven't had any further problems since doing this. And... let the rest of us know if this solves the problem. Just because this fix has worked for a lot of us doesn't mean there couldn't be some other underlying cause for you. I hope this helps.

  • vallejogreg Level 1 (0 points)

    Change Sleep to "Never" or at least 2 hours in Energy saver prefs.  Or, Uncheck "wake for network access" in net work prefs AND uncheck  ITunesFIle Sharing in Itunes sharing prefs.


    Problem is with Sleep when networked to devices over wifi.  You can also buy the latest Apple Extreme or Airport router if you want to pay to fix problem

Previous 1 5 6 7 8 9 Next