Previous 1 2 3 4 Next 132 Replies Latest reply: Apr 17, 2014 9:49 PM by Wout Mertens Go to original post Branched to a new discussion.
  • AshleyTarver Level 1 Level 1 (5 points)

    You've tried all the usual ways to try and recreate the problem and you couldn't?

  • marc.45 Level 1 Level 1 (0 points)

    I have had 3 different Macbooks since Tiger and they have all done this with every OS since Tiger. Including my brand new Macbook Air and Lion. Fix it already Apple.

  • Blue_ Level 1 Level 1 (0 points)

    Seems deleting plist files as instructed by Avrahqedivra did the trick.

    Thank you.

  • bjgbjg Level 1 Level 1 (0 points)

    That solved the problem for me for a short while, then it reoccurred.

     

    I have discovered why: I need the network I want to connect to to be TOP in the list of preferred networks. Otherwise, after sleep,it has trouble connecting to it. it will connect eventually, if I choose the network manually.

     

    I think deleting the plist only solved the problem because it got rid of my other networks. Once I had more than 1, the problem reoccurred because the desired network was not at the top.

  • shaunz49 Level 1 Level 1 (0 points)

    This download fixed my issue.

     

    OS X Lion Update 10.7.1 (Client)

  • sdonze Level 1 Level 1 (0 points)

    Hi guys,

     

    I'm having the problem too and figured out it usually happens when the MobileMe sync agent is running at the moment I put my Mac to sleep. So to reconnect the Wifi I just kill the FileSyncAgent process and that fixes the problem

  • DMacLamb Level 1 Level 1 (0 points)

    yes same problem with my new Airbook running 10.7. Come on Apple, get back to making decent computers and OS and less focus on the latest iPhone/Pad etc...

  • PittFoo Level 1 Level 1 (0 points)

    Same problem here... None of the solutions solved the problem... Even the apple update that said to fix it...

  • anders102 Level 1 Level 1 (0 points)

    Well I have had the same problem on my MacBook with OS X Lion and it virtually drove me crazy. I tried all solutions suggested here as well as in other forums but without success. Even tweaking the router proved useless.

    However, I found out what caused the problem for me...TOTALLY weird and no wonder its so hard to detect and fix.

    I realised I had problems mon-fri frequently more or less every 5 mins or so....nothing on weekends. My disconnections are caused by a website... I work as an investor and I have a Swedish website up 24/7 that updates itself with financial data once every second minute or similar. On weekends (after closing in US/Can friday evening swedish time) it does not update more than once per day. So..... having this website up, alone or together with other windows it crashes the network mon to fri every 5-10 mins but not on weekends!

    I have several computers and tried this on an iMac with Snow Leopard.....same thing!

    Does not solve the problem but I can avoid it by not using this specific website. I would suspect many websites with the same type of functionality would cause this.

    Try it out yourself....the site I have problems with is www.di.se  (a Financial Times type of site but swedish).

    Active in a window =>crash. Then try with a non-updating website => total stability for me.

    This was detected in OS X 10.7.2 and OS X 10.6.7 using Chrome as browser.

    I will try it out in Safari and Firefox on monday when the site is starting to refresh itself again.

    GLTA

  • hubertfromcharlottenlund Level 1 Level 1 (0 points)

    Actually this seems to be a good tip: my prefs file contained a setting saying

    <key>AutoLogin</key>

    <false/>

     

    I have changed the <false/> to <true/> and now my Macbook Air autoconnects again to my preferred network. I though have to check this with my other preferred networks (in particular at work).

     

    It seems that at some point the software who is working on the prefs file, changes all AutoLogin values to false; maybe when connecting to a new, unknown network. At least that seem to have happened with me. First, when I unpacked the MacBook Air and connected it to my home network, auto connect worked. Later at some point (with adding new preferred networks) auto connect stopped working for the new networks as well as my home network.

     

    Surprisingly, there does not seem to be a possibility for setting the AutoLogin value through the GUI.

  • hubertfromcharlottenlund Level 1 Level 1 (0 points)

    Ok, this is not a threaded discussion. So here is the missing context. I am talking about the prefs file com.apple.airport.preferences.plist in /Library/Preferences/SystemConfiguration.

  • db0967 Level 1 Level 1 (0 points)

    I had the same problem with a 2010 MBP. I tried all the things here, Keychain, plists etc and still it wouldn't reconnect after sleep. My wireless network SSID was hidden, so I changed it and made visible and now my MBP reconnects after sleep. Fingers crossed, 2 days later and it's working fine.

  • Crilodan Level 1 Level 1 (0 points)

    worked here too.

  • shadowfixer Level 1 Level 1 (0 points)

    I have been having problems with wifi as mentioned above. I went through the network setup to day and have something that seems to work for me.

     

    On the network page I removed everything but wireless from the net work connections and unchecked the ask to join new networks box. Show status in menu bar is checked.

     

    On the advanced page:

    Wi-fi tab ask to join new networks is the only box checked.

    TCIP tab IPv4 configure using dchp- Configure IPv6 automatically.

    Proxies tab nothing is checked.

    Hardware tab configure automatically.

     

    Now when it wakes up I watch the wi-fi icon go through the connect routine and I have a connection. Before it would wake up and show that it was connected but I would have to turn the wi-fi off and on again to reconnect.

  • mattiek-mj Level 1 Level 1 (0 points)

    I deleted my plist file as Avrahqedivra suggested, also deleted my keychains as daniel8811 suggested too. Restarted, all works great. Thanks for the help!

Previous 1 2 3 4 Next