Previous 1 3 4 5 6 7 Next 133 Replies Latest reply: May 24, 2015 9:23 AM by ponni1269 Go to original post Branched to a new discussion.
  • lenny491 Level 1 (15 points)

    I agree with you 100%! This problem is just ridiculous! But I'm sure that it has to do with Bluetooth peripherals. When I wake my iMac with the power buttom WiFi works perfectly. It connects to my network every time all the time!

  • Tgara Level 4 (3,540 points)

    Well, I got a very nice phone call out of the blue from Apple about this issue.  I had just put a meatloaf in the oven when the phone rang.  Seriously!


    The person on the phone was very nice and said they saw my posts about the wifi issues and wanted to run some diagnostics on my machine.  I was emailed a script which collected some data, and I emailed the results back to hiim.  I was also offered a slot to help test the "seed" for 10.7.4, which is supposed to include fixes to these wifi problems.  I declined the offer because my machine is working fine on Ethernet for now.  So it would appear that the Apple engineers are working on this problem as we speak.  No firm date on a fix, but they are aware of it and are working to get it addressed.

  • wifiguru Level 2 (240 points)

    Try picking 5 hz channels if you can like ch. 52,56,60,64. I seem to have better luck with connecting on wake from sleep using these channels. These channels are also cleaner and less noisy than the usual 2.4/5 Ghz channels.

  • fromlos angeles Level 1 (0 points)

    great to know they are really working hard on this issue!


    btw, I tried something that resolved my issue. Since nothing really worked out to resolve the wifi connection issue, I thought there might be something wrong with my wireless router.



    I logged into router settings and under 'LAN SETTINGS' changed Lease time for IP address from 'forever' to 'One Week' (or to anything other than 'forever'). Strange but it worked!

  • LegendMaker Level 1 (115 points)

    Wow I wish they'd call me because this problem is really starting to irritate me. You'd think it shouldn't be a big deal to just re-select my network every time I want to use it, but I need my computer to answer emails while asleep, and run backups, and so forth, which it can't do without the wireless, and my ethernet access is used by an HP PC with a bad wireless card.


    Again, for me this is not a Lion problem. It's a problem I had on 3 iMacs (iMac G4 which stopped working altogether a few months ago, iMac Intel Core 2 Duo, and now a 2011 3.4 GHz iMac Intel Core i7 27-inch) and never on the MacBook Pro I bought in 2009. However the G4 (this is the one with the adustable screen mounted on top of a half-sphere) was working fine until some upgrade or another. I'm going to say that my problems began with Tiger (10.4), as I don't think I had issues with Jaguar or Panther. And it was not on the first install, but sometime afterward.


    But my new iMac with Lion was working fine until just about a week or two ago, and all that we've had were upgrades. Including a firmware upgrade to the Time Capsule, now that I think about it... In fact, this may be when the problem started again.


    BTW: I tried the plist deletion and re-setting my network list and all that, didn't make any difference.

  • LegendMaker Level 1 (115 points)

    Does this article help us at all?

    It seems to be written back about the time I started having my problems.

    I'm about to test it out.

  • Nocker Level 1 (0 points)

    Ok. and we'll say if it works, I too am irritated. Apple .. Tic .. Tac ..

  • kmacn60 Level 1 (0 points)

    I thought I fixed the problem on my Macbook (after installing Lion and having to manually log onto my router) by turning bluetooth off, but my son did some reconfiguring on our router for a printer issue and the problem is back no matter if bluetooth is off or on.

    I called Apple support and was told that a fix is days away. (She said it like it might be a few days to a week.)


    They are aware of it and have been working on it. Let's hope the end is near!!

  • LegendMaker Level 1 (115 points)

    I don't want to jinx it but I *may* have fixed my own problem this way:


    System Preferences


    Selected Wi-Fi and clicked Advanced button

    Deleted my network name which is WPA2 Personal with the "-" button.

    Used "+" button to re-add the same as a WPA2 Personal network again.

    Left "Remember networks this computer has joined" as checked.

    Clicked OK, then Apply, then left System Preferences.

    Fixed permissions with Disk Utility, and rebooted.


    I did this yesterday, and so far my Wi-Fi connection has not disconnected after heavy sleep. If I don't come back to this thread within the next 2 days, that means it worked.

  • ve1bz Level 1 (0 points)

    Legend, you rock.  I tried what you suggested and it seems to have fixed my problem as well.  Thanks for posting.

  • royfrombc Level 1 (0 points)


    After trying various suggestions including LegendMakers, which may have helped, I finally set my network prefrences as above and the wi-fi now connects when waking up.

    NOTE: The Network Name (wired10) is my router name, select your network/router name from the drop down.



    Oops screen shot will not open


    Message was edited by: royfrombc

  • LegendMaker Level 1 (115 points)

    Well, my solution worked all day yesterday, but alas, this morning it woke from sleep and my Wi-Fi network would not automatically re-connect again. :-(


    My computer is timed to shut itself down at 1 am, and start back up at 6 am, so when I got to it at 7 am I woke it from sleep and there was no network... But I wonder if that might have been caused by something else... Not sure... I might stop using the auto shut-down / start-up for a while.


    As an experiment, this morning I repeated the procedure of removing my network and re-establishing it, but this time I chose "Any (Personal)" as my network security. I'm not sure that would make any difference because I don't know if the security protocol is causing the problem.


    But the computer slept for several hours today and did not lose network connection upon waking. So I'll await several more days before celebrating.

  • royfrombc Level 1 (0 points)

    Network shot.png

    Hoping this screen shot opens.

    This is how I configured my network and now works fine.

    Note: Network Name is my routers name, insert your own network/router name.

    good luck.

  • Aismaiil Level 1 (0 points)

    The solution most ppl are giving saying to delete the connection and re-add basically solves it temporarily but doesn't really tackle the root of the problem! it'll happen again i'm sure. I did that 2 months after lion came out, and it wasn't that annoying it just didnt connect maybe once out of every 20 times I put it to sleep, and never had a problem again after I deleted and re-added the connection and resetting the location and the preferences, until 3 weeks ago, and now it doesn't connect 2 out of 5 times I wake the laptop up. I can't just wake it up using the on/off button like with the iMac cuz with the macbookpro it'll just wake up once u open the screen. But the suggestion about the problems being linked to the bluetooth might be on the right track imo. My latest attempt at tackling this issue was System preferences>Network, under the list of connection types on the left i clicked the drop down list next to the - sign, then Set service order, and I dragged Wi-Fi to the top of the list above Bluetooth DUN. So far it's worked. Until it stops again i'll let u know...

  • LegendMaker Level 1 (115 points)

    Aismaiil - that's an interesting nook, I never saw that area before. I haven't had my problem recur since I removed my network and re-added it as security = Any (Personal), however I'll try this too because it does seem like a possible point of failure. The one difference (for me) between my iMacs and the MacBook Pro is that my iMacs use bluetooth peripherals all the time, and my laptop doesn't use bluetooth-anything.

Previous 1 3 4 5 6 7 Next