Previous 1 4 5 6 7 8 9 Next 133 Replies Latest reply: May 24, 2015 9:23 AM by ponni1269 Go to original post Branched to a new discussion.
  • LegendMaker Level 1 Level 1 (115 points)

    Well this morning I woke it from sleep by wiggling the mouse (which btw is USB not bluetooth, only my solar-powered Logitech keyboard is bluetooth) and I watched the airport turn on but it would not auto-connect to my network, as set. I did remove my network and re-added it as security = Any (Personal) yesterday; as I had re-added it as security = WAP2 Personal a few days earlier. These seemed to have reduced the problem to once-a-day (strange) but have not eliminated the problem.

     

    Aismaiil - Since yesterday morning my Service Order is set at Wi-Fi, then Ethernet, then Firewire, then Bluetooth DUN, then Bluetooth PAN. So apparently this made no difference.

     

    However I did make an interesting observation.

     

    While the network was still not connected, I selected Sleep from the Apple menu and waited for everything to power down. When it was completely quiet, I used the POWER BUTTON to wake the computer instead of anything else. When the computer woke this time, the network was automatically reconnected.

     

    Somebody else in this thread pointed out that this manner of waking the computer from sleep seems to work also.

     

    I'll have to see if that will work every time.

     

    Not a cause-solver by any means, but a circumvention of the problem if one can get into the habit.

  • Aismaiil Level 1 Level 1 (0 points)

    Yeah well I wasn't sure if it had anything to do with it or not, but today I was sure it had nothing to do with it. I even tried putting it back to sleep from the Apple menu and waking it up using the power button, it still didn't work, and i mentioned before that usually it takes me it 10 to 15 seconds for it to reconnect on its own even after it says it couldn't connect, well that didn't happen either. I tried deleting the connection and readding it as security = Any (Personal), didn't work, tried deleting the location and readding it, didn't work either. Took me an hour and didn't know what to do. I saw in the network preferences it said "personal IP assign, will not be able to connect" or something like that. I didn't do anything to the IP address, i just put it to sleep n waked it back up a few hours later!! my desktop was working fine and my iphone was connected fine, dunno what happened to the macbookpro. Basically, the problem was solved by turning wifi off, deleting all the services on the side, going into "advanced" and deleting every single connection I ever saved at home and anywhere else, deleting the location, as if I never used wifi yet! I readded a new location, a new wifi service, reconnected to the wifi network by searching for available connections (not by adding it from advanced, so i didn't choose the security, the computer automatically read it's WPA2) and going into the TCP/IP settings and renewing DHCP the lease, as if i restarted everything all over again!! Big and long hassle, but no idea how long it'll last this time!!

     

    Side note: I never had this problem concerning the personal IP assigned. the only thing i know i did differently was yesterday I added the open DNS server into my DNS settings, just for extra internet security! dunno if that caused it or not...

  • LegendMaker Level 1 Level 1 (115 points)

    Well I'm throwing in the towel. Every single solution posted in this thread ultimately did NOT work for me, except temporarily. Every morning it's right back to the same problem, it will not automatically log back into the network, and all my emails get backed up, and Time Machine fails.

     

    This is very irritating. How long will it take Apple to fix this problem? I've had it on iMacs for several years, across at least three different operating systems, and three different iMacs, and never once on my MacBook Pro.

     

    The one thing that consistently works for me is taking it out of sleep USING THE POWER BUTTON. If I do that every time, it always logs into the network, no problem. If I jiggle the mouse (which is not cordless), the screen wakes, and the disk wakes, but not the network login.

  • r.a.russell Level 1 Level 1 (0 points)

    Encountered problem after upgrading to 10.7.3 on my 27-inch Mid 2010 iMac with an AirPort Extreme router.  If I wake by pushing a key on the wireless keyboard, it tries to find my Wi-Fi connection but ends up with none.  I turn off Wi-Fi and turn it back on and after one or two tries it finds my network.  I just tried using the power button to wake from sleep, and it found the network without having to do anything else.  Strangely when I click the Wi-Fi menu strength indicator, a grayed-out "Looking for Networks ..." shows the in-progress wheel spinning.  For now, I'll continue using the power button.

  • ricardo.leitao Level 1 Level 1 (0 points)

    As my problem is associated with a Macbook Air I have no way to push the power button as the computer awakes when opened.

     

    However, most of you have notice the problem occurs when you wake up the computer from a wireless keyboard and that might be just the problem (the bluetooth)!

     

    An apple engenieer has been evaluating the error reports produced in my computer and has asked me to turn off the bluetooth port. In all my last 10 wake-ups the issues was not reproducible. Please do that test too. Use a USB keyboard for a while and shut down your bluetooth transmitor. Let us know what you find.

  • DrVenture Level 2 Level 2 (180 points)

    OOh looky. Update for iMac WiFi...

     

     

    http://support.apple.com/kb/DL1501

  • ricardo.leitao Level 1 Level 1 (0 points)

    Jealouse!

    (nothing for the Air yet)

  • r.a.russell Level 1 Level 1 (0 points)

    My post of two days ago has been remedied by Apple's just released iMac Wi-Fi Update.  Now it finds the network when I wake my iMac using the keyboard.

  • OregonArtee Level 1 Level 1 (0 points)

    Ditto here.  Software update fixed the problem.  Mid 2011 iMac running Lion, Actiontec wireless router.  I can finally let the computer go to sleep again.

  • yukselp Level 1 Level 1 (0 points)

    Unfortunately update didn't worked for me.

  • dizm Level 1 Level 1 (0 points)

    I think I've found an easy workaround to "sometimes won't re-connect wifi after sleep".

     

    I wake up by pressing the power button.

     

    Previously I was waking up by hitting spacebar.

     

    I have a 2010 iMac with the latest Lion and all updates.  Don't use time-machine.  Don't have wired connection.  Do use a bluetooth mouse.

     

    Apple, I hope you're listening, as this might be a clue.  I also have a 2011 Air, which does not have this problem -unless I have bluetooth enabled.

  • Marcelo NS Level 1 Level 1 (40 points)

    The power button weak up is a nice solution for iMAC however does not apply for MBA.

    This issue has been around already for almost 1 year. You sould contribute leaveing a feedback to Apple to encourage them to solve it.

     

    Feedback link bellow:

     

    http://www.apple.com/feedback/macbookair.html

  • db86 Level 1 Level 1 (0 points)

    Hi,

     

    It seems I have a different problem with 10.7.3. After I updated (about 2 weeks or so ago) my MacBook Air (2011) didn't reconnect to my Wlan (after sleep mode). Strangely, I can't even manually, always when I enter the password it tells me "connection establishment failed". Even more strangely, connecting to my other, or any different Wlan works without problems. I have installed the 10.7.3 combo update but still no progress. May it be related to the password itself? It is quite long and complicated other then the one of the Wlan I still can connect to. I deleted the Wlan in the System Settings and set it up new, somehow it was set up again but didn't connect. Now, after deleting again I can't even set it up and tells me also the message mentioned above. When I try to set it up with the assistant it keeps telling me the password is incorrect, and trust me, I spent some minutes to type it in veeery carefully. Shutting down computer didn't help, opening windows after shut down is also disabled as well as the option that Wlans are memorized or connected automatically.

    Ah yes, and not to forget, it can't be the router since all my other Apple devices (iPhone, Ipad) can connect without problem. This also applies for all other devices at my home, like all MacBook Pros with 10.7.3 of my family members. Still I did shut the router down and restarted, but didn't help at all.

     

    Hope someone out there is able to help me while Mac keeps frustrating me..

     

    Thanks.

  • Andy.S Level 1 Level 1 (0 points)

    Just thought id add to the list, first Macbook and could be the last the way things are going.

  • Aismaiil Level 1 Level 1 (0 points)

    I don't remember who mentioned this before, but for me the problem is solved. All I did was reset my internet router to factory settings, at the same time reset the entire network settings section on my MBP, including deleting the wifi profile and all the connections i've connected to over the past and any settings, as if the router and the mac have just been taken out of the box. When I readded my wifi connection, I chose "any (personal" as the security as someone here previously suggested, and every once in a while i just go into the settings and renew the DHCP lease in the TCP/IP section. I haven't have a problem in over 2 months since my last post i think! I hope this helps.

     

    Oh and andy, i dont think this is a good enough reason to move on from the mac, i still prefer it a million times more than windows, erros have so many more problems and errors and security issues and ... the list goes on! I've had my mac for 2 years now and i just love it!

Previous 1 4 5 6 7 8 9 Next