Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Problem deleting files - Lion prompts for password

Since upgrading to Lion, OS X has started promting for a password when deleting files and folders on my main 'Macintish HD'. I have tried restoring disk permissions, but it made no difference and the Sharing & Permissions are set to Read & Write.


Creating and deleting files on other disks does not require a password.


When Lion requests a password when deleting files, it deletes the file/folder, but does not place it in the Trash.


Has anyone found a suitable fix for this?

Posted on

Reply
Question marked as Solved
Answer:
Answer:

A fix for this has now been found. The reason why this is happening is because the .Trash folder has changed ownership to root. The fix simply requires ownership of the being put back to you. Open Terminal and run the following command:


sudo chown yourusername .Trash


This should resolve the problem without having to create new user profiles etc.

Posted on

Page content loaded

Jul 22, 2011 8:49 AM in response to AJSpinDrift In response to AJSpinDrift

I have the same problem and worse: if I create a folder on my desktop, even though permissions seem fine (I've repaired so many times! And also reinstalled Lion a couple of different ways), I get prompted to authorise if I try and move anything into the folder. MobileMe sync is broken because, I assume, of the same permissions problem. Anyone got any ideas? I did suffer the Preview problem, but deleting a file in the Containers folder solved that (Preview simply created a new one - I couldn't see any difference in the permissions there). I get MobileMe Sync errors, and I can't logout of MobileMe to stop that happening because I get a Keychain Error (can't save to the keychain, and on the permissions on login.keychain it's showing two "everyone" users). My MacBook Pro is unuseable now unless I dig out my old installation disks (Snow Leopard). I thought maybe I'd done something wrong, but seeing the other posts (not as many as I anticipated, though), I figure it's not just me.

Jul 22, 2011 8:49 AM

Reply Helpful
Question marked as Solved

Aug 1, 2011 9:40 AM in response to GTMA In response to GTMA

A fix for this has now been found. The reason why this is happening is because the .Trash folder has changed ownership to root. The fix simply requires ownership of the being put back to you. Open Terminal and run the following command:


sudo chown yourusername .Trash


This should resolve the problem without having to create new user profiles etc.

Aug 1, 2011 9:40 AM

Reply Helpful

Aug 4, 2011 10:15 AM in response to AJSpinDrift In response to AJSpinDrift

I had this issue too, but my file permissions were correct on my .Trash folder.

After a chat with a very helpful Apple Support rep the fix was to reset the permissions on the whole home folder.


Check the permissions on one of your offending files (Get Info) and if you see there are 2x 'everyone' permissions and one is set to 'custom' then you will have the same issue as me. If you change the 'custom' permission to something else you will find it will now delete.


I downloaded a small app called BatChmod and used this to batch process the permissions of my whole home folder. I suppose you could use chmod if you like ;-)


See pic below for the settings, and once run, log out and back in again.


Enjoy all your un-authenticated delete and move goodness!



User uploaded file

Aug 4, 2011 10:15 AM

Reply Helpful

Aug 26, 2011 5:59 AM in response to AJSpinDrift In response to AJSpinDrift

when i tried


sudo chown username .Trash


I get the response, "xxxusername is not in the sudoers file. This incident will be reported."


Now, my xxusername I've created is not an administrator's account. There is another account on my mac that is the admin account. It is generally not used, and I've done it this way because I've heard it safer to keep your main account - the one you use everyday - as the standard account. Whats the fix for this? This didn't happen in Leopard 10.5 , or Snow 10.6, for things like the trash...

Aug 26, 2011 5:59 AM

Reply Helpful

Aug 28, 2011 4:05 AM in response to AJSpinDrift In response to AJSpinDrift

OSX has two permissions engines, POSIX type as you see in finder uner Permissions, and ACL type which is a higher level and more detailed form of security.


The issues are usually related to ACL entries existing on your home folder or subfolders and contents.


The way to resolve is to remove ACL entries resetting them to defaul.


Open terminal.app, enter this command:


sudo chmod -R -N ~


press enter key.

Aug 28, 2011 4:05 AM

Reply Helpful (1)

Sep 9, 2011 3:27 AM in response to AJSpinDrift In response to AJSpinDrift

I Found a Solution,

Open your Home folder,

then get info,

in the bottom click on the lock bottun and enter your password, click on + and select your name,

then in the privilege select read/write,

then click on the perefrence icon beside +, apply all enclosed folder.....

it's work for me. all privilage in mine.

========================

http://Forums.mac4me.ir

Sep 9, 2011 3:27 AM

Reply Helpful

Sep 9, 2011 6:47 AM in response to MSiLight In response to MSiLight

MSiLight wrote:


I Found a Solution,

Open your Home folder,

then get info,

in the bottom click on the lock bottun and enter your password, click on + and select your name,

then in the privilege select read/write,

then click on the perefrence icon beside +, apply all enclosed folder.....

Not a good idea- see


Mac OS X 10.5: Renaming or saving after using "Apply to enclosed items" on a Home folder


The home folder carries a hidden "everyone deny delete" ACL (a special permission) which doesn't show up in Get Info, but which can get propagated to all your enclosed files and folders when you use "Apply to enclosed items". This can cause a number of permissions issues. The above support article was written for Leopard, and I recall, the "everyone deny delete" ACL does not get propagated this way in Snow Leopard. However on preliminary testing, it does seem to get propagated and cause problems in Lion. An immediate manifestation on my test account was this TextEdit message:

User uploaded file


A less serious side affect of using "Apply to enclosed items" on a home folder is that your previously private subfolders - Documents, Pictures, etc - will now be readable by all other user accounts.


Bottom line: Only use "Apply to enclosed items" on folders that you have created yourself, not on folders that were created by the system.

Sep 9, 2011 6:47 AM

Reply Helpful

Sep 22, 2011 6:59 AM in response to jsd2 In response to jsd2

As a matter a fact, when trying to troubleshoot a Permissions issue, I did a "Get Info" on my User Account folder and then an "Apply to all enclosed items" and it messed up my system BIG TIME... Many applications were suddenly unable to write to their preference folder and such.


I spent HOURS trying to fix the problem, which is still not completely resolved. I ended up creating a new user account and moving all my files over to it.


Now the problem there is I cannot move or delete any of the file I moved without being prompted for a password even though "Get Info" says I am able to "Read/Write"


My next step is to try BatchMod on the files in the User folder, and/or the suggestion above on the .Trash permissions. However, I don't think its a Trash permissions issue since new files that I create in the User Account oflders don't prompt me for a password when trying to move or delete.

Sep 22, 2011 6:59 AM

Reply Helpful

Oct 18, 2011 4:57 PM in response to Tony Barone In response to Tony Barone

Try this out, worked for me, and it's easy as taking candy from a kid. Not that I did that. Anyway:


STEP 1. Make your hidden and system files visible:

Open Terminal.app and type: defaults write com.apple.Finder AppleShowAllFiles YES


STEP 2. In your home folder, look for the ".Trash" folder.


STEP 3. Right click and select "Get Info".


STEP 4. Look at the bottom of the recent opened window for Sharing & Permissions.


*** STEP 5. THE PROBLEM ***

  • You should see that there's two users: system and everyone.
  • System is NOT you, there should have your user too.


STEP 6. Click the + (plus) sign and add your user (assuming you're the admin).


STEP 7. Set Read & Write permissions for you.


STEP 8. Click the lockpad again to lock it (duh :S).


STEP 9. Make your hidden and system files INvisible again:

Open Terminal.app and type: defaults write com.apple.Finder AppleShowAllFiles NO




That worked for me. Cya!

Oct 18, 2011 4:57 PM

Reply Helpful

Oct 21, 2011 10:23 PM in response to AJSpinDrift In response to AJSpinDrift

I am sorry to say but none of this works for me, the sudo chown cammand is useless, it still keeps asking for my pw when I want to put trash in the trash can. Now when I quit Adobe photoshop it says that I do not have permission to save the preferences, I dont know why its doing that now. I am also having problems with windows opening back up to where they were when quiting out of photoshop and I have tried everything for that as well and for some reason it does not open the window to the home url that I have set but instead it opens 3 or 4 previously opened windows to where I visited last. I did the update and it took care of everything, but then all of a sudden it started to ask for my pw to put into trash and then when I tried to save one file over another it wanted pw and then it said I had no permission to do so. Then Safari went right back to what it was doing before. I am VERY Annoyed by this! I am needing help.


I have tried verything that was posted here and nothing seemed to work...

Oct 21, 2011 10:23 PM

Reply Helpful

Oct 22, 2011 4:01 AM in response to Jon Leslie In response to Jon Leslie

Hi Jon: the problem I had was not confined to .Trash but to pretty much everything. Once I'd sorted it (a very long way around) I discovered that the problem recurred - preferences weren't sticking (a bit like your problem), and even dropbox folders were affected. So I followed leece's hint above, and downloaded BatChmod, and applied the settings that leece recommends, and IT WORKED. PERFECTLY. Something is screwing up settings. It's not to do with e.g. synching to external hard drives (which I do) because my dropbox folder is untouched by those. So I don't know what the cause is, but leece's solution is quick, easy, reliable, and works. Try it.


Leece - thank YOU!

Oct 22, 2011 4:01 AM

Reply Helpful
User profile for user: AJSpinDrift

Question: Problem deleting files - Lion prompts for password