Previous 1 2 3 4 Next 89 Replies Latest reply: Aug 30, 2015 5:29 PM by trudyfromcordova Go to original post
  • FabeRox Level 1 (0 points)

    Glad that it works for you Zeichensprecher and thanks for your advice. Unfortunately, it doesn't work for me. I have a mobile me account and a microsoft exchange 2010 account. No matter where I move the mails to (including inbox) – removing attachments remains impossible for emails sent since installing lion. I have also tried attaching file in various ways, including drag and drop or via the paper-clip button.


    So far the best advice for new readers following this thread appears to be:

    1) Try to move the the affected mail to another folder and see whether the remove attachment commands is available again.

    2) If that doesn't help, use you email provider's web interface for sending emails with attachments you might want to remove later on and let those mails sync back to

  • Syncopator Level 1 (115 points)

    Jamooche wrote:


    I'm new to the Mac as of Lion and find it very difficult to manage the attachments in Mail.  PDFs are displayed inline in the email message and the only way I can figure out how to save them is to right click on the PDF.  I am having the same problem with photos too.  I can also double click them and they open in Preview. 


    When you click the "Remove Attachments" in the drop down, where do they go?


    It also took me forever to figure out how to add the address book icon to the New Message window! 

    "the only way i can figure out how to save them is to right-click on the PDF."


    sounds like mission accomplished. no? you can also drag them to your desktop, to your dock, or to a folder in the finder, desktop, or dock. does that help?


    "When you click the "Remove Attachments" in the drop down, where do they go?"


    as far as i know, they're deleted. isn't that the goal of "removing"?

  • tinoberlin Level 1 (10 points)

    There still does not seem to be a solution to the problem. I have tried to copy mail from/to various folders. It did not help. I can remove attachments from incoming mail but not from outgoing mail. Is it a new feature, a bug, did Apple simply overlook the possibility that people do not wish to keep copies of attached files in their mail as they have these files elsewhere on their harddrive? The only solution to the problem is to delete the mail. Do we have to send attachments in mails separate from the email explaining the attachment? Really annoying ... my Mail folder in Library will get huge very quickly.

  • tinoberlin Level 1 (10 points)

    Manually editing the .emlx file of the Email works, Mail recognizes the file without the attachment. So it should not be a problem to allow Mail to remove the attachment as it was in the previous versions of the app.

  • Jamooche Level 1 (0 points)

    Thanks.  The main problem I was having was that I wasn't clicking on "detais" (or even seeing the item to click) on the top right of the email message.  Keeping that turned on gives you the full hearder, quick look, and info on the attachment. 

  • tinoberlin Level 1 (10 points)

    As I have also noticed from reading other threads, Mail allows to remove attachments from incoming mail, but not from sent mail. The exception is MS Office files that can be remove also from sent mail. Very strange ...

  • keven-77 Level 1 (0 points)

    It's a bit of a pain but I've found that rebuilding the mailbox seems to do the trick to make the attachment icon appear and therefore allow you to remove attachments. Hopefully this gets fixed with an update.

  • tinoberlin Level 1 (10 points)

    Rebuilding the mailbox by deleting the Envelope Index file? Hm ... unfortunately this didn't help here.

  • tinoberlin Level 1 (10 points)

    Alright, editing the .emlx file in the directory /Users/Username/Library/Mail/V2/Mailboxes using TextEdit seems to be the only way to remove attachments from any email. You open the email, delete everything below your message, save it, close Mail, re-launch Mail, and the attachment has gone.

  • Adam Nohejl Level 1 (45 points)

    I am a Mail plug-in developer and several users have already reported this problem to me. It does not seem to depend on account settings and happens with some incoming messages as well. It is a specific message structure that triggers the problem, and the same messages are handled OK on Mac OS X Snow Leopard. Moving to another folder  helps because Mail changes the internal structure of the message (structuring of the mime parts, header order, etc.), but it may not help always.


    The problem can be replicated reliably by saving a message as raw source, converting it to the mbox format (by prefixing it with a From line) and then importing it on a different computer.


    I have reported the problem to Apple (it is also present in the current developer preview of 10.7.2):



    The more reports Apple gets the more likely they are to fix it. So please report the problem too if you have experienced it. You can do so even without a developer account:



    (In that case, I recommend saving a message from which attachments cannot be removed as raw source, uploading it to a web server and including a link in the bug report. Feel free to reuse the text fo my bug report.)

  • 750 H2C Level 1 (5 points)

    Hi all. I experience exactly the same problem as FabeRox and tinoberlin, and have done so since Mail 5 appeared. I have filed a bug report similar to Adam Nohejl's.


    For me, moving messages to different mailboxes doesn't work. Editing the message in TextEdit works, but it's not something I'm prepared to do for each message (with attachment) I send.


    I had hoped that Apple would have addressed and solved this issue in Mail 5.1, but no luck. I'll just have to watch my Sent box grow out of proportions until Apple fix the problem.

  • cfibanez1 Level 1 (0 points)

    Same problem here. Rebuilding the mailbox (last command in the Mailbox dropdown menu) has worked for me.

  • Jamie123 Level 1 (0 points)

    I found an answer on


    1. Open up Apple Mail and create a new Smart Folder. You can do this by clicking the + sign in the bottom left corner of your Mail window, or by going to the Mailbox menu and choosing New Smart Mailbox.
    2. From there, make sure to specify that this Smart Mailbox's rules apply to all. (This should be the default.)
    3. Now all you have to do is set one simple rule: "Contains Attachments". You may also want to specify that the smart mailbox should include messages from your junk and trash folders, just so you're covering all your bases. When you're done, just click OK and Mail will create the smart mailbox.
    4. If Mail doesn't do it for you automatically, select the new smart mailbox you just created and watch the messages roll in. There will be a little indicator next to the mailbox in the sidebar to let you know Mail is still working. When it's done and all the messages with attachments have appeared, press Command+A to select every one of them (or go to the Edit menu and choose Select All).
    5. Go to the Message menu and choose the Remove Attachments option. (It should be toward the bottom.) It may take awhile for Mail to perform this task on every message if you have many, but go grab some lunch and check back in about an hour. By then, you should have attachment-free mailboxes.
  • Tonden Level 1 (70 points)

    Doesn't work for me. All the messages where I cannot remove attachments don't show up in this Smart Mailbox so I cannot remove anything from them.

    We anyway want to remove attachments from selected Sent messages only, so selecting all doesn't make sense for me.

  • SheboyganDave Level 1 (0 points)

    Hey! Thanks very much to all of you that contributed suggestions to the removing attachments problem (in sent items using mail 5.1.) Here's hoping that Apple will notice, and see it as a Lion bug that needs fixing.


    Does anyone else miss the option to save a screen shot in Preview (version 5.5.1) (Lion) as a GIF, or is it just me? I, for one, would like to have that option when less memory would be good, and when great quality isn't necessary (just in case these words might be noticed by someone Apple).


    Thanks again.

Previous 1 2 3 4 Next