Previous 1 2 Next 28 Replies Latest reply: Mar 16, 2012 12:58 AM by Dan Frakes
spettinger Level 1 Level 1 (0 points)

I am unable to share files other macs on my home network.

 

I receive an error message that the server will not allow additional users to log on.

 

I can connect to windows machines and can use mac screen sharing.


Mac OS X (10.7)
  • Steve Holton Level 4 Level 4 (1,025 points)

    Are you trying to connect from the Finder Sidebar, Cmd-K, .....??

     

    I have found the one of my Lion Macs cannot connect to the other Lion 0ac via the Finder Sidebar, but it can connect via cmd-K.

     

    In looking at the log of the target achine i,e, the one I;m trying to connect ot I find that the AFPFileServer has crashed. Perhaps this is the problem??

     

    It has been reported to Apple.

     

    Steve

  • spettinger Level 1 Level 1 (0 points)

    Trying to connect from sidebar.

     

    I have a newer laptop that the Apple file server also crashed on, but have two desktop imac that don't show any file server crashes.

     

    I've tried repairing permissions, turning off file sharing, restarting.

     

    I have one imac that I can connect to from my other 4 macs.

     

    When I try to use cmd-k or sidebar - I get following message:

     

    This file server will not allow any additional users to log on. Try to connect again later.

  • spettinger Level 1 Level 1 (0 points)

    I found a work Around -

     

     

    Turned on file sharing , went to Advanced Tab and

     

    turned on SMB (Windows Sharing),

     

    Turned OFF (Unchecked) AFP

     

    I can now connect to all Macs.

     

    It definetly looks like an AFP issue.

  • Joel M Miller Level 1 Level 1 (0 points)

    I have multiple machines with Lion installed (Mid 2010 MacBook Pro, 2.66 GHz Mac Mini & a late 2010 iMac) and several more runing Snow Leopard. I cannot make AFP connections to any Lion machine from any other machine, Lion or not. At the same time I can make Screen Sharing connections and several other types of connection to the Lion machines, and can make any type of connection (including AFP) from the Lion machines to the Snow Leopard machines.

     

    After I enter my password, attempted AFP connections to Lion invariably draw the "This file server will not allow any additional users to log on" alert.

     

    Yet the target Lion machine shows "Number of users connected 0". I don't know how to find the crash log, but no AFPFileServer process appears in the Activity Monitor's All Processes list on the 2 Lion machines I checked, so this might be the problem. I've tried repairing the file system & permissions, to no avail.

     

    => Spettinger's workaround - switching AFP off and SMB on - does indeed allow me to make file sharing connections to my Lion machines. Thanks spettinger!

     

    But, how can this be? There is nothing unusual about my configuration: its all recent Apple hardware & system software, with no 3rd-party protocols & no hacking. Why doesn't everyone who shares files have this exact problem?

  • RG24 Level 1 Level 1 (10 points)

    Make sure NO Home folders are being shared. Made that change and now all 4 macs file share fine with AFP.

  • Joel M Miller Level 1 Level 1 (0 points)

    Avoiding Home folders doesn't seem to help. And anyhow, one's home folder is usually exactly what one wants to access remotely.

  • Clive Webber1 Level 1 Level 1 (10 points)

     

    I am having the same problem and my home folder is not shared so that is not the cause. I've posted separately about this but there don't seem to be any new solutions out there. As it seems to be a fairly common problem, I suppose we just have to wait and hope Apple will fix this in the 10.7.1 update.

  • pbDixon Level 1 Level 1 (10 points)

    I had what seems to be the same problem, and I think I solved it: In /Library/Preferences/com.apple.AppleFileServer.plist there were two keys, maxConnections and maxGuests, that were set to 0. Looked like this:

     

    <key>maxConnections</key><integer>0</integer>

    <key>maxGuests</key><integer>0</integer>

     

    I changed the values to 10, and it seems to be working now.

  • spettinger Level 1 Level 1 (0 points)

    Thanks,

     

    That fixed it on the two machines I've done so far.

     

    Strange those values were set to 0, The computer I had that worked had the values at 10.

  • Clive Webber1 Level 1 Level 1 (10 points)

    I could find no keys like that in the preference files on either my MacBook Pro or my iMac. Trashing that preference file on the MacBook Pro did cure the problem though, well almost! I can now connect as a guest or registered user, but for some reason, I still can't connect using my Apple ID. Anyway, I can now connect my Macs in both directions so many thanks for pointing me towards the solution.

  • Joel M Miller Level 1 Level 1 (0 points)

    That's it. Good work, spettinger!

    (For anyone who sees no such keys, you may need to use a "programmer's" text editor like BBEdit.)

  • ajmanik Level 1 Level 1 (0 points)

    pbDixon -- THANK YOU!

  • yas2253 Level 1 Level 1 (0 points)

    Thanks pbDixon! Here's my variation on the problem, for others' reference:

    I initially had no success when I changed the plist key settings from 0 to 10 as you instructed. But then I tried also removing my home folder from the Shared Folders box, and then Apple filesharing started working again! For me, both steps were necessary to get things back on track. Hooray!

    Note 1: even though I removed my home folder from being shared, it still shows up and is accessible (along with all its subfolders) anyway when I am connected from my other mac.

    Note 2: I am now able to make/maintain network connections to shared items with both AFP and SMB enabled. Before pbDixon's fix, I could share files via SMB only. If I tried to turn AFP on (with plist keys set to 0), the SMB connection seemed to become disrupted as well.

    Thanks again!

  • Joel M Miller Level 1 Level 1 (0 points)

    Opps! I meant to thank pbDixon, who solved the mystery. It's also now clear why trashing the /Library/Preferences/com.apple.AppleFileServer.plist fixes the problem, too, though less elegantly.

     

    But RG24 and yas2253 also had a piece of the problem: having made the 0 -> 10 fix, if I explicitly share my home folder on the target machine, I can no longer connect. If I remove my home folder from the sharing list, I can connect once again, and my home folder is automatically available.

     

    So, two separate ways to break AFP, *both* of which need to be set right. Yikes!!

Previous 1 2 Next