Previous 1 2 3 Next 73 Replies Latest reply: Jan 7, 2013 6:45 PM by PhilBAust Branched to a new discussion.
alastairmac Level 1 Level 1

Before the Lion upgrade, our Macbook Pro would very quickly and reliably pick back up on the wifi network and reconnect.

 

Since Lion, pretty much every time (can't speak for the occasions my wife used it), it's either MUCH slower to reestablish the wifi connection or it doesn't do it at all. Can be solved by turning the wifi off then back on again, but this is a pain.

 

Has anyone else encountered the same?

 

Could it be related to the new config required to provide the 'Airdrop' functionality? (maybe disabling Airdrop would solve it?)

 

Alastair


MacBook Pro, Mac OS X (10.7)
  • SoAmI Level 1 Level 1

    Hi Alastair,

     

    no fix, but I have the same issue, very annoying.

     

    Looking forward to any hints.

     

    Thanks, Henrik.

  • HiDylan Level 1 Level 1

    I have a this same problam too.

  • MacsWereALotBetterB4 Level 1 Level 1

    I also have this problem. Driving me nuts. I'm ready to ditch Lion. Been using a Mac since before they were Macs and I have never seen Apple screw up this badly.

  • letib Level 1 Level 1

    i have the same problem since my switch to Lion. i never see these before.

  • halldl_47 Level 1 Level 1

    I've recently installed Lion and had the same problem.  I turned of the Time Machine auto update option.  Since then I haven't had any problems.  Hope it helps.

  • mbmoore Level 1 Level 1

    Yup, same problem here. Also, I have two Airport Expresses broadcasting the same network name, and unlike Snow Leopard, Lion doesn't grab the stronger of the two.  Very frustrating.  Basically every time I wake the MBP, I have to re-select the right Airport Express.

  • Lanny Level 5 Level 5
    expertise.macosx
    Mac OS X

    It's a known problem. Bug Reports have been filed and Apple is working on a solution.

  • Carlo TD Level 3 Level 3

    I don't have any issues. How could i replicate your issues? What are you doing exactly, maybe i dont understand your situation?

  • SoAmI Level 1 Level 1

    Hi again,

     

    I fixed the issue by cleaning up my keychain, it obviously got corrupted during the Lion migration. I deleted the (now two) entries for the network and created a new one. Works fine now.

     

    Best, Henrik.

  • l8192 Level 1 Level 1

    @SoAmI has the solution that worked for me. Launch the KeyChain application and delete any and all entries corresponding to your Wifi connection. I could have tried the Keychain First Aid option, but I was too stressed for niceties. So just blew away the entries and that seems to have fixed the problem.

  • RobRz Level 1 Level 1

    The key chain solution worked for me...for the most part.  I also had to erase all the stored "locations" in the Open Network Prefernces menu.  Another weirness of the Lion OS, is that all these changes to the key chain and "locations" did not take affect until I turned the computer on and off.

  • BoloMK33 Level 1 Level 1

    I'm having the same problem.  Strangely enough, if I plug a network cable in, I can get to the Internet AND it seems to wake-up my wireless connection.  ***...come on Apple!

  • BoloMK33 Level 1 Level 1

    Well, I called Apple today and the person I spoke to indicated that they knew nothing about the issue. They instead asked me to rest my PRAM & NVRAM and reset the SMC. I was unable to reset the SMC controller because I can't remove the battery...I reset the PRAM / NVRAM and the problem still exists.

     

    I have an appointment with the local Apple store on Sunday AM (kinda busy on Saturday) so I hope to know more then as I can recreate this anytime I choose.

     

    More later....

  • BoloMK33 Level 1 Level 1

    I don't have a power-on password and I'm using MAC address filtering so there is no key involved. The computer sees my wireless AP and even thinks it's connected. I can renew my DHCP lease (thus I ahve an IP address...something in LION is broken.

Previous 1 2 3 Next