Previous 1 6 7 8 9 10 Next 149 Replies Latest reply: Aug 25, 2013 10:24 AM by wizard_chef Go to original post Branched to a new discussion.
  • Hiyouall Level 1 Level 1

    Yesterday, my Magic Mouse began moving the pointer to the side-edge and corners of the screen, whenever the mouse was picked up and put back down.


    Today, I deleted the file in my main library, and the file in the By Host folder in my home folder library Preferences. Restart.


    Then, I shut down, unplugged the AC, and held the power button for 5 seconds. Plug-in and boot-up.


    Also, changed wi-fi router channel from 6 to 1.


    Finally, paired the mouse.


    Now, it works just as it had. No skipping, no jumping, scrolling is back too.

  • Alexandre Vale Level 1 Level 1

    Sorry to the other guy, but it is an OSX issue. I have 2 magic mouses, one for a macbook pro and for my imac.  I resisted installing Lion on my imac for as long as possible, so I just installed it a few days ago when mobile me went dead.  I have been working with the magic mouse for years in the same mac and configuration.  after installing LION I started having mouse troubles.


    I thought it was the mouse, so I exchanged the mice from each computer and the report is: both mice work fine in the mackbook pro, and both mice misbehave on the imac.  It is impossible to use photoshop with the mouse, there is no precision at all.  Do we have to start suing Apple for lost work to be heard??? Apple flat out ignores a trend that has been on since OS X 10.7.1, now I am using OS X 10.7.4 almost a year later from the original post and the issue persists.


    After reading the trends, I notice that my problem in the macbook pro is not the mouse, but the trackpad, since I use the mouse most of the time I had not noticed, but my trackpad is terrible on the macbook, to drag anything is a chore.  How can anyone be expected to use the computer with such a basic and imperative function not working?


    The more I use Lion, the more flaws I find, no wonder they will kill it after just one year.  No pointing device precision...  it is a shame to even read about it, Steve Jobs is rolling in his grave guys.

  • hahyonhwatha Level 1 Level 1

    hey thanks alexandre. your observation about the trackpad connection helped a lot. i went to the trackpad setup and unchecked every available checkbox - all the multi-finger and swipes use. without even a reboot, my microsoft wireless mouse really steadied down. rather ironically, when i signed up to this list to say thankyou, the login menus presented the jumpy behavior in extreme, but then settled down to useable for this reply.


    so you must be onto something about the osx coding for the interface of trackpad and mouse.


    some additional data. i've used trackballs for 20 years and far prefer them to mice or pads. when logitech came out a year ago with a wireless one, i immediately bought it. i have to buy another because i wore out the main button which as it developed the "switch bounce" of normal wear, became too much for the logitech software. but after upgrading to lion the cursor jumping became evident on that too. and as the threads tell, a reset helps, and an unplug replug of the wireless dongle helps.


    i think you're onto something here though with the focus on the lion finger interface, and not a particular mouse.

  • zehfred Level 1 Level 1

    This worked for me too! Now Magic Mouse is working perfectly. I suspect it has something to do with the swollen battery as someone pointed out. The fact is that after disabling the trackpad the problem was gone. Thanks.

  • johncarync Level 1 Level 1

    MY SOLUTION: I read many suggested solutions but, for me, the fix was resetting the PRAM (restart your machine while holding down Option-Command-P-R and waiting for it to chime again).


    My symptoms were: cursor jumping in a random direction while mouse was in use and when connected to an external monitor. If I tried to quickly draw a 1" circle over and over, the cursor would jump to a random location approximately 5" away about every 7 seconds.


    So my suggestion is to try zapping your PRAM. It only takes a minute or two to try it and it might solve your problem. Good luck.

  • edfisher Level 1 Level 1

    I called apple care they had me reinstall Lion, and it fixed it.

    1 turn off coumputer

    2 start while holding down Command R

    3 click on Recovery HD and reinstall ox Lion worked for me nothing else did hope this helps someone else.

    link tells you how to do Recovery


  • johncarync Level 1 Level 1

    MY SOLUTION...didn't work. The problem returned after about 24 hours. So resetting the PRAM was not a fix. Perhaps it's time to upgrade to Mountain Lion.

  • Astroboy2000 Level 1 Level 1

    I have a Mac Pro 2007 (2,1) at work. Recently I upgraded from Snow Leopard to Lion (10.7.5) which is the last supported OSX for this model. After updating is finished, jumpy mouse symptom appears. I tried deleted all the preference filies but it did not work. To make long story short, it's the video board that caused the problem.


    About a year ago I upgraded my video card to ATI Radeon HD 5770 Graphic Card. It works fine on Snow Leopard but not on Lion. On Lion, not only it causes jumpy mouse but also screen flickering on second monitor every few minutes or so.


    So I removed the card and put back the original OEM video card that came with it. The jumpy mouse stops completely and everything is back to normal.

  • David from Sydney Level 1 Level 1

    This happens every so often with my wife's 24 inch iMac (2006?) and her Wacom Cintiq 24inch tablet which is attached as the second display. The Cintiq is placed below the iMac and the cursor goes crazy in the bottom right corner of the Cintiq.


    SOLUTION: The simple solution is to turn off the Cintiq. Then turn it on again, the problem goes away.


    Still don't know the long term solution but it doesn't happen very often and this solution works.


    Other info: The OS is Lion, I should update it.


    Message was edited by: David from Sydney

  • JvdS Level 1 Level 1

    ik heb dit probleem nu ook. (apple mouse bedraad)

    het werken op deze mac is schier onmogelijk.

    heb deze mac met lion gekocht en een timemachine backup van snow-leopard er overheen gezet.

    vr: moet ik een totaal restore doen of heeft iemand oplossing?

    sorry voor mijn engels maar ik woon in nederland




    safari crasht op deze machine zeker 5 keer per dag met send reports en heb nog nooit iets van vernomen


  • Astroboy2000 Level 1 Level 1

    Try to delete QuickTime 7 and delete all the QuickTime extensions inside Preference folders and anywhere else. Then restart your Mac. Download QuickTime X from Apple and install that instead. QuickTime 7 made my mouse jump on my Mac Mini. After I deleted it, the jumpy mouse is gone.

  • flg8r96 Level 1 Level 1

    Hiyouall - That did the job! Thanks!

  • cbmtrx Level 1 Level 1

    FYI folks: I notice that my (wired) RocketFish mouse gets jittery/skippy when I have a second monitor connected to the back of my iMac (2011). Don't ask me why.


    When I unplug the second monitor mouse movement is smooth again. So now I just expect it when I need the second monitor.



  • johncarync Level 1 Level 1

    My eventual solution was to plug my keyboard directly into my MacBook Pro and plug the mouse into the keyboard. I believe there is an occasional latency in the signal the monitor's USB sends to the Mac and that caused my frustrating mouse issues.

  • wizard_chef Level 1 Level 1

    Give up on the Mac mouse and get a 3rd party one. After over a year of struggling with mine with dropouts, short battery life, accidental horizontal shifts into oblivion, I bought a Logitach wireless mouse. Love it. Much more stable, much easier to use and control the pointer. Worth the expense and lack of constant frustsration.

Previous 1 6 7 8 9 10 Next