Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Vacation Autoresponders in Lion Server

Hi everyone.


Has anyone else had any luck setting up autoresponders in 10.7 Lion?

It was advertised as one of the 'new' features, but I dont see it anywhere.


In SL, it was located on the user's wiki pages.


I have server side rules enabled in Server Admin 10.7


Cheers!

Alan.

Mac OS X (10.7), 10.7 Server

Posted on

Reply
Question marked as Solved
Answer:
Answer:

1. "Enable Webmail" in the Server application under the Mail service and make sure Mail Server is on.


2. Goto http://localhost/webmail in your browser and log in


3. In the top right hand corner, click on Settings


4. Select the Filters tab


5. Add a new filter to match All incoming messages and select "Reply with message".



I have not played with this a lot yet, however, it looks like you can create groups of filters and can be enabled and disabled.


Simon.

Posted on

Page content loaded

Question marked as Solved

Jul 30, 2011 1:54 AM in response to pilbaraecho In response to pilbaraecho

1. "Enable Webmail" in the Server application under the Mail service and make sure Mail Server is on.


2. Goto http://localhost/webmail in your browser and log in


3. In the top right hand corner, click on Settings


4. Select the Filters tab


5. Add a new filter to match All incoming messages and select "Reply with message".



I have not played with this a lot yet, however, it looks like you can create groups of filters and can be enabled and disabled.


Simon.

Jul 30, 2011 1:54 AM

Reply Helpful

Aug 15, 2011 11:44 AM in response to JeroenPotters(Macpot.nl) In response to JeroenPotters(Macpot.nl)

As I said in my original reply, I haven't played with this a lot, and when I received the "that works perfectly" message, I thought everything was OK.


I have spent a couple of hours playing this afternoon and I also have the problem that no vaction message is being sent. I created a Filter Group and added another Filter to it (to redirect the mail) and this worked OK, so server-side filtering is working, just not the Reply with message (vacation) part.


If you download the Additional Server Tools, in ServerAdmin, under Mail / Filters there is an option to turn on and off server side mail rules. In my case, this was already turned on.


OS X Lion appears to be using Dovecot for it's webmail. The server-side filters are called Dovecot Sieves. There seems to be a lot more information about the Vacation Sieve on Google than there is currently about OS X Lion Server. I am trying to get some clues here.


Ideas to consider (any comments appreciated):


1. Are my vacation messages being created and then failing to send due to some permissions, restrictions?


2. Do I need to be running any server-side daemons?


3. I would be interested to see if the "number of replies per day" functionality is working. I recall there were some issues with this in Snow Leopard Server.


I will keep looking and get back to this post if I find anything.


Simon

Aug 15, 2011 11:44 AM

Reply Helpful

Aug 15, 2011 12:17 PM in response to SimonOrdish In response to SimonOrdish

Hi Simon,


Thanks for the reply. I came to the same conclusion: server-side filtering is working execpt for Reply with message (vacation).


I start of looking for a solution in Google too and hope to be answering your questions soon.


Jeroen

Aug 15, 2011 12:17 PM

Reply Helpful

Aug 16, 2011 11:56 PM in response to JeroenPotters(Macpot.nl) In response to JeroenPotters(Macpot.nl)

I found this article which might shed some light. I have not had time to delve into it, but i thought I would post this here in case it helps anyone else.


http://www.afp548.com/article.php?story=20040721014726822


Regards


Simon

Aug 16, 2011 11:56 PM

Reply Helpful

Aug 17, 2011 7:09 AM in response to SimonOrdish In response to SimonOrdish

Hi Simon,


I've been testing your suggestion from AFP548: " The vacation filter needs an e-mail address filled in, in the Squirrelmail filter setup, for it to work." Did not fix my issue.


Now going to upgrade to 10.7.1 and hope that will fix the issue... Be right back to let you all know.

Aug 17, 2011 7:09 AM

Reply Helpful

Aug 22, 2011 2:18 PM in response to JeroenPotters(Macpot.nl) In response to JeroenPotters(Macpot.nl)

I also had issues after upgrading to Lion server where the autoresponders did not work. It turned out to be due to greylisting.


See this thread: https://discussions.apple.com/thread/3216002?start=0&tstart=0


Once that was done all started to work.

Aug 22, 2011 2:18 PM

Reply Helpful
User profile for user: pilbaraecho

Question: Vacation Autoresponders in Lion Server