Previous 1 2 3 4 5 6 Next 79 Replies Latest reply: Feb 6, 2013 5:09 AM by AMKan Go to original post
  • Rippe Level 1 Level 1 (0 points)

    No I don't have any antivirus or 3rd party firewall application running...

    I also tried to turn Mac firewall off, but it did not help either...

  • PAHU Level 6 Level 6 (15,180 points)

    I did some more testing this evening and I still cannot get the MF8380Cdw to fail and I cannot find a setting on the Mac or the printer that will force the driver to set itself to Unidirectional. But reading the UFR2 driver guide, it would appear that even if the driver did set itself to Unidirectional, while you won't be able to use certain features of the printer, you should still be able to print.

     

    @Rippe - with the Mac Pro that is working and does show Bidirectional, does the MF8xxx appear in the Bonjour section of Safari? And if you select to Add Printer and have the Default view selected, does the MF8xxx also show?

  • Rippe Level 1 Level 1 (0 points)

    Hi Pahu,

     

    It has to have something to do with Unidirectional/Bidirectional as between MB Pro and Mac Pro has this is difference - one does not work and one works...

     

    For Mac Pro it is Bidirectional, but Safari does not show anything in the Bonjour (same as MB Pro)...

    When adding printer both of them shows MF8xxxx

     

    br Risto

  • PAHU Level 6 Level 6 (15,180 points)

    So with the printer not showing in Safari on the Mac Pro, and therefore assuming that it also did not show in the Default Add Printer view, how did you add the printer on the Mac Pro?

     

    Also, can you describe your network. How does the Mac Pro and the MacBook Pro and the MF connect to each other?

     

    And can you confirm which model you have. An MF8380, MF8350, MF8080 or MF8050?

  • Rippe Level 1 Level 1 (0 points)

    Let me correct - The printer is visible Default Add Printer view.

     

    Printer and MacPro are connect with LAN cable via switch (wireless router) and MB Pro via wireless (I have also tried with LAN cable).

     

    My printer is MF8030Cn

  • Rippe Level 1 Level 1 (0 points)

    Pahu, do you have any instructions how to delete old printer drivers as I don't have any tool to do that for me?

    I suspect it is still some old dependencies that blocks the service and I would not like to re-install whole Mac OS...

  • PAHU Level 6 Level 6 (15,180 points)

    For the UFR2 driver, first delete any printer using that driver in Print & Scan.

     

    Then open Finder and navigate to HD > Library > Printers > Canon and trash the UFR2 folder.

     

    Then navigate to HD > Library > LaunchAgents and trash the files "jp.co.canon.UFR2.BG.plist" and "jp.co.canon.CUPSCMFP.BG.plist"

     

    Now restart your Mac and after the restart you can empty the Trash to remove the UFR2 driver files.

  • Jordie07 Level 1 Level 1 (0 points)

    Hi Pahu,

     

    I think you thought I dont exist anymore, but I am still here and the printer is still not working.

     

    I was succesfull in printing the report you asked. Other information then Rippe:

    ROM-controller ver

    Main 0.128 (TYPEA)

    Boot 01.07

     

    I wasnt succesfull in finding the printer info butteon, so I havent checked if its bi or uni directional. If I have a document in word for example, and I select 'printing', then below the image of the paper I only have a button with the paper-settings and below that a button to turn the document into a pdf. At the top I see the printer and below that is select 'standard-settings'. In the top field is a added to the printer, I pushed that and i received a software update which took quit a while. I almost became happy but unfortanately nothing changed afterwards and the same problem exists.

     

    Is there anything else I can do?

  • PAHU Level 6 Level 6 (15,180 points)

    Hello Jordie07 and welcome back. Thought you were only going to be a few days

     

    With regards to the Printer Info button, from the Word print dialog you would have to change the menu that shows Word to one of the Canon driver menus, like Special Features. This is where you will see the Printer Info button.

     

    As for the Software Update, the Canon UFR2 driver is not provided by Apple so I'm not sure why you would have seen an attempt by the OS to update the driver. At least it explains why nothing changed after the update supposedly completed.

     

    Looking back at your information I'm not sure where to progress from here. The action that often resolves this mess is trashing the driver and reintalling. But since you have already done that with no success then you either have a driver issue or a network issue. So to check the driver, as a test, I would connect your Mac to the MF via USB cable. You will have to create a new printer in Print & Scan for this USB connection. Once the printer creation is complete then see if this will let you print.

  • Rippe Level 1 Level 1 (0 points)

    Hi Jordie,

     

    I solved the problem by re-installing Lion, it took about 2 hours but after that everyting has been working fine.

    Do not afraid the re-install procedure as it won't touch any of your other data.

     

    br Risto

  • Jordie07 Level 1 Level 1 (0 points)

    Dear Pahu and Rippe,

     

    YES!!!!!! It works finally!! Dont have the clue what went wrong, but I trashed the old drivers, everything I could found around printers and re-installed lion and then.... it finally prints again.

     

    Really a lot of appreciation about your help here! This is more than one could expect!

     

    Kind regards,

    Jordie

  • PAHU Level 6 Level 6 (15,180 points)

    Great to read that you finally got it working Jordie.

  • tjt74 Level 1 Level 1 (0 points)

    Hi Pahu & Rippe -

     

    I'm a newbie to Mac world, and have a question regarding CN8030 printer, and using it wirelessly through Airport (although it is USB printer).

     

    I have it working from my Win7 laptop just fine (i.e. I can print wirelessly to it), but have been experiencing the same problems that have been discussed in this thread when I have tried to print from iMAC (with OS X 10.7.3).

     

    Last time I tried to enter the Airport's own IP address to the LPD field, the Airport stopped functioning altogether, and now I won't try it again, until I'm sure

     

    Also - I have downloaded and installed the v2.35 UFRII driver from Canon, but that hasn't fixed the situation.  Also, I re-installed Lion altogether.   One funny thing is that after I have installed v2.35 driver, it shows up in the FInder as a 'drive' alongside the iMAC Hard Disk, and the Recover partition.   Should that be the case?

     

    PAHU & Rippe, the geniuses here, how should I proceed?

     

    Thank you - Teemu

     

    (p.s.  I have tested via direct USB connection that I get the printer to work - it's just printing wirelessly via Airport to the printer that does not work.  However, the wireless printing works fine from WIn7 laptop with Bonjour for Windows)

  • PAHU Level 6 Level 6 (15,180 points)

    tjt74 wrote:

     

    I'm a newbie to Mac world, and have a question regarding CN8030 printer, and using it wirelessly through Airport (although it is USB printer).

     

    I have it working from my Win7 laptop just fine (i.e. I can print wirelessly to it), but have been experiencing the same problems that have been discussed in this thread when I have tried to print from iMAC (with OS X 10.7.3).

    This is a limitation of the Canon UFR2 driver for Mac OS X. This driver requires bidirectional communication and the USB port on the Airport does not support bidirectional communication.

     

    The UFR2 driver for Windows does not have the same requirement as the Mac driver and that is why you can get it working from Win 7.

  • Adrian Beard Level 1 Level 1 (0 points)

    Hi there Pahu,

    Hope you don't mind me resurrecting this thread!

    I have a MacPro, running 10.7.5. I also have an MF8340Cdn that I cannot get to work. I've tried both IP and USB methods of connecting it.

    I've read through the thread and tried the things you've mentioned, but to no avail.

    The printer is seen and I can add it to the Printers list. If I cannect via IP, it doesn't have the name of the printer, just the IP address. When I try to print, it gives back an 'error' in the print queue, but no other information. If I try to use it with the Generic PostScript Printer set, instead of selecting the Canon option, it says it's printing and the document disappears from the print queue, but doesn't come out of the printer.

    I'm using the latest drivers from the Canon UK website.

    Not sure where else to go - any suggestions would be very much appreciated.

    Cheers,

    Adrian.

    EDIT: Not sure if this would help track down any issue, but I can scan from the unit to my Mac, but not from the Mac (using Image Capture). Also, I don't see either UFR2 Backgrounder or CMFP Backgrounder in the Activity Monitor.