Previous 1 2 3 4 5 6 Next 79 Replies Latest reply: Feb 6, 2013 5:09 AM by AMKan Go to original post
  • PAHU Level 6 Level 6

    Hello Adrian.


    If the UFR2 Backgrounder is not running then the print queue will not be created correctly and this will stop the Mac from printing to the MF8340. To check what the print queue is currently set to, you can open System Information (Applications > Utilities) and select Printers in the left hand column. The top right pane will show all the printers on your Mac, or if you only have the MF8340, then you will just see it in the right pane. With the MF8340 selected, you will see information about the printer queue. The print queue starts with URI and should look something like this;


    URI:          cnbmzd://localhost:59693


    If you have something else set then delete the printer from Print & Scan and open Finder and navigate to HD > Library > Printers > Canon > UFR2 > Utilities. Here you will see UFR2 Backgrounder. Double-click it. Nothing will appear on the screen but if you open Activity Monitor you should now see UFR2 Backgrounder. And if you do, add the printer again and then check the print queue URI via System Information. If it looks like above, then you should now be able to print.

  • Adrian Beard Level 1 Level 1

    Hi Pahu,

    Thanks for the quick response.

    I have deleted all other printers to avoid any conflicts.

    The Printers section in System Information is:


    Status:          Idle

      Print Server:          Local

      Driver Version:          2.0

      Default:          Yes

      Shared:          No

      URI:          lpd://

      PPD:          Canon MF8300 Series UFRII LT (UK)

      PPD File Version:          2.0

      PostScript Version:          (3010.000) 550

    (3010.000) 651

      CUPS Version:          1.5.4 (cups-297.11)

      Fax support:          No

      Scanning support:          No

      Printer Commands:          AutoConfigure Clean PrintSelfTestPage

      CUPS filters:


      Path:          /Library/Printers/Canon/CUPSCMFP/Bins/capdftopdl


      Path:          /Library/Printers/Canon/CUPSCMFP/Bins/commandfilefilter



      Sandbox compliant:          Yes



    So, not quite what you've indicated above, but not being at all knowledgeable about networking, I'm not sure if it's still accpetable!


    I ran UFR II Backgrounder and checked in Activity Monitor, and it hasn't come up.


    I reread the thread, and think I correctly unistalled the software, then reinstalled it again. Same result.


    Any ideas what I should try now?


    By the way, I tried Canon's tech support - not very helpful at all.


    Cheers, and thanks again for your time.




    EDIT: Not sure if it's important, but in Print & Scan, it's the IP address of the printer that comes up as it's name and the icon is of a generic printer, rather than the MF8300 series.

  • PAHU Level 6 Level 6

    Thanks for supplying the System Information. As I expected, the print queue URI is wrong and this would be due to the UFR2 Backgrounder process not running on your Mac.


    So to fix this we need to determine why the Backgrounder process will not open on your Mac. From my test Mac, I cannot stop the Backgrounder from starting. If I remove the UFR2 Backgrounder plist file from the LaunchAgents folder, the Backgrounder will not start after I log in. But if I manually browse to the UFR2 Utilities folder, double-clicking the UFR II Backgrounder icon starts the service.


    One thought is that you have third party software installed on your Mac that is stopping the process from opening. I've had issues in the past with Little Snitch impacting the UFR2 drivers installation and operation. Do you have this app or an application like it?


    If not, you could delete the current MF8340 printer and then open Finder and navigate to HD > Library > Caches > Canon > CUPSCMFP > CCPD and trash the ccpd.conf file. Then restart the Mac and then check Activity Monitor for the UFR2 Backgrounder process. If it is not present, navigate to HD > Library > Printers > Canon > UFR2 > Utilities and double-click the UFR2 Backgrounder icon. If this still fails to show the UFR2 Backgrounder process in Activity Monitor then there has to be something else causing this. But since I cannot recreate what can cause this process not to start, then I cannot suggest a solution at this stage.

  • Adrian Beard Level 1 Level 1

    Hi Pahu,

    I did indeed have LittleSnitch installed.

    I uninstalled it, removed and then reinstalled the printer.

    No joy, still the 'error' in the Status column of the Print Queue.

    I then tried trashing the ccpd.conf file and rebooting. Same result, even after trying to start the UFR2 Backgrounder manually.

    I tried creating a new user to see if that might help - no change.

    Any ideas of what I could try next?



  • PAHU Level 6 Level 6

    Hi Adrian. So after removing Little Snitch does this allow the UFR2 Backgrounder process to start?

  • Adrian Beard Level 1 Level 1

    When I double click the icon in the folder, it does the 'grow and fade out' thing that usually indicates an application is starting, but it doesn't show up in the Activity Monitor.

  • PAHU Level 6 Level 6

    Then without the Backgrounder you will not get the correct print queue. I will do some tests with Little Snitch installed when I'm back at work Monday. I still think it may be the cause for your issue.

  • Adrian Beard Level 1 Level 1

    Great, thanks again for looking into this.

    I used the uninstaller that came with the Little Snitch dmg, so it should be ompletely gone from my system.

    Have a good weekend.

  • PAHU Level 6 Level 6

    Okay. Spent a bit of time on this issue today. For starters, Little Snitch does stop the queue from being created correctly. This is because the utility stops the UFRII Backgrounder process from running. So I added UFRII Backgrounder to Little Snitch's exception list and set it to outgoing only. This allowed the UFRII Backgrounder process to start but still the print queue URI would not be created correctly. So I then edited the entry to add UFRII Backgrounder as an incoming service also. But again the queue was incorrect.


    My last test was to uninstall Little Snitch and then add the printer again. But still the print queue URI was created incorrectly. So I have more testing to do to see what else could be the cause. To be continued...

  • Adrian Beard Level 1 Level 1

    Thanks for spending the time looking into this one, Pahu.



  • PAHU Level 6 Level 6

    Finally managed to get the printer queue created correctly. Little Snitch certainly did impact the UFR2 driver installation and operation.


    So with Little Snitch uninstalled you will need to remove the MF8340 from Print & Scan.


    Then open Finder and navigate to HD > Library > Caches > Canon > CUPSCMFP > CPPD and trash the file ccpd.conf.


    Then run the UFR2 v2.41 installer again and when the installation has completed, open Finder and navigate to HD > Library > LaunchAgents and ensure that the following two files are present - and


    If they are, open Activity Monitor and ensure you see Canon CMFP Backgrounder and UFR II Backgrounder. If neither is present, log out of the Mac and log back in and check again. We need both services running to add the queue correctly.


    With the backgrounder services running, open Print & Scan and add the MF8340 using IP > LPD for the protocol.


    With the printer added, open System Information, select Printers and for the MF8340 queue, ensure the URI shows "cnbmzd://localhost:59693". If it does, then see if you can print. If the queue shows "lpd://ip address", then open Finder and navigate to HD > Library > Caches > Canon > CUPSCMFP > CPPD and check the Date Modified time on the ccpd.conf file. It should be set to the time you just added the MF in Print & Scan.


    Hoping this gets you printing. If it doesn't, then I'll have to do some more investigation.

  • Adrian Beard Level 1 Level 1

    I'm out of the country till next week now, so I'll get onto it as soon as I get back.

    Thanks again for all your efforts on this.

  • Adrian Beard Level 1 Level 1



    Got as far as logging out then back in again. No backgrounders running.


    I tried starting them manually from their respective folders, but no joy.

  • PAHU Level 6 Level 6

    So did the Backgrounders start when you manually opened them?


    Does the print queue still show "lpd://ip address" ?

  • Adrian Beard Level 1 Level 1

    The Backgrounders did not start. They did the grow/fade thing when I double clicked them, but didn't show up in the Activity Monitor.


    The Print Queue still shows 'lpd://IP address'.