Previous 1 2 3 4 5 6 Next 112 Replies Latest reply: Mar 11, 2016 12:48 AM by charlotteoswald Go to original post
  • RadRod Level 1 Level 1


    I will be sure to update when / if I get a reply from Apple.


    I only put the Safari background info in because it had to do with certificates and related to my user ID only. It's somewhat similar and followed from Snow Leopard on an iMac to Snow Leopard on my MBP to Lion on my MBP.  Since the wipe and reload, it's gone. Thankfully.


    Reading Thomas's link to the corrupt user ID, I suspect that's the genesis.   And ...


    With respect to Priviledges / Permissions, my problem only seems to happen with old restored files.  Newly created documents are fine.


    Adobe Lightroom3 is interesting….on a Delete it asks if I want to remove the image from my disk and not just the catalog.  I click yes, remove from disk.


    Normally the image goes to the trash.  In this case LR3 leaves it in the folder but takes it out of the catalog.  So it's ignoring the problem.  That's good news…. Bad news my LR3 folders will be littered with images I want to delete. As you said the process to delete those files is tedious.


    This is Only true for old images.  I imported a new one to an LR3 folder, then deleted it.  The image went to the Trash.


    Here is a post with a Utility that fixes the problem (Delete files) with a batch process:



    The Postee said he was given direction by an Apple rep.......  But probably not the 3rd party utility....


    I'll wait to hear from Apple before I go the 3rd party route.





  • jupzchris Level 1 Level 1

    I had this issue and it drove me nuts trying to figure it out.


    Here is what was happening to me


    I had a file on my windows machine that i dropped into my shared folder on my mac


    i went to move the folder to my desktop from the shared folder.

    It asked for a password

    i started to delete some of the photos and it would still ask for the password


    so i right clicked on the folder went to get info and noticed that it did not have my user listed at all

    so i just added the user and gave me persmission to read and write and that fixed it.




  • RadRod Level 1 Level 1

    Thanks Chris,


    You are absolutely correct.

    The problem is, I have a lot of image files that have this problem, and correcting them one by one is tedious.

    I might as well just type my password when I delete or move a file.


    What's worse is Adobe Lightroom3.  When I delete a junk image (and there are many from a shoot) from a shoot, LR3 indicates the file is deleted and moved to the trash, but in fact it is still in the folder for that shoot / import.


    My Apple tech left me a voice mail with instruction to type in Terminal.  I'm a bit miffed because he didn't respond to my email and provide written instructions, or better yet set a time to implement the commands.


    The tech said he received a reply from engineering pointing to the followin "K" Base Articles.

    TS 1334


    HT 4761


    TS1334 is as follows...

    sudo chmod -RN ~


    WARNING: Improper use of the sudo command could lead to data loss

    or the deletion of important system files. Please double-check your

    typing when using sudo. Type "man sudo" for more information.


    To proceed, enter your password, or type Ctrl-C to abort.


    I selected ^C because I'm a whimp.


    I know if I imlement this on my own it will either not work or I'll jack-up my machine.  (or both)


    I'm going to get in touch with a tech and implement these while I'm on the phone or having them remote control my system.

    I put in too much time and effort rebuilding my 3-4 month old MAC from bit "1"

  • RadRod Level 1 Level 1



    I am so very happy to report that my problem is resolved.

    At least five tries in a row worked ( moves & Deletes) with old files from a backup with permission issues.


    I worked with a Sr. tech and a very simple command (that I was instructed to try before) worked.


    Lion Users:


    1) Shutdown

    2) Powerup holding CMD "R"

    3) Keep holding until you get to utilities page.

    4) Ignore the options in the center.

    5) Click on "Utilities" then "Terminal" On the top left menu bar. (Next to the Apple Icon)

    6) in Terminal enter "resetpassword" lower case, no spaces.

    7) Enter.

    8) You will get a popup to reset your password.

    9) DO NOT FILL IN THE FIELDS with a new password.

    10) Click the "Reset" button in the section below the fields for a new password.

    11) Close everything and reboot.

    12) Done.

    13) Your admin password stays the same.


    Nothing else was entered in Terminal

    The fix (for me) was different than that listed in TS1334.


    Hope this helps someone else.

  • oldcro Level 1 Level 1

    Well I have had no problems and the iMac works as it should in spite of changing the permissions and keeping the original password. I work on the simple thought that if I should not do something, then I should not be given the option to do it. Interestingly there have been a variety of solutions posted here, some good and some doubtful, but why isn't there one solution which works for all?


    As I mentioned earlier, nobody else can touch my iMac so where is the danger in altering the permissions?

  • Level 8 Level 8

    oldcro wrote:

    As I mentioned earlier, nobody else can touch my iMac so where is the danger in altering the permissions?

    Nobody was supposed to shot Lincoln !

    Nobody was supposed to strike the World Trade Center !


    But, for sure, you are free to play with matches.


    Yvan KOENIG (VALLAURIS, France) samedi 27 août 2011 16:24:48

    iMac 21”5, i7, 2.8 GHz, 4 Gbytes, 1 Tbytes, mac OS X 10.6.8 and 10.7.0

    My iDisk is : <>

    Please : Search for questions similar to your own before submitting them to the community


    To be the AW6 successor, iWork MUST integrate a TRUE DB, not a list organizer !

  • thomas_r. Level 7 Level 7
    Apple Watch

    I work on the simple thought that if I should not do something, then I should not be given the option to do it.


    If you jump out a window at the top of a 30-story building, that's not a good idea.  Does that mean that those windows should be fastened shut to prevent that from happening?  Perhaps, but it also prevents people in that building from opening the windows on a nice day, letting fresh air in and reducing air conditioning costs.


    A computer's not much different.  Except that sometimes those windows are doors, opening on a 300-foot fall.  You wouldn't want to step through such a door.  A good OS tries to keep such doors locked, while also providing you the keys to open them if necessary.


    Interestingly there have been a variety of solutions posted here, some good and some doubtful, but why isn't there one solution which works for all?


    Probably because there are several causes involved. 


    As I mentioned earlier, nobody else can touch my iMac so where is the danger in altering the permissions?


    The danger is that you could very easily bork your system by fooling around with permissions.  As evidenced by this thread, even fooling with the permissions on a user's home folder without knowing what you're doing can cause problems.


    Honestly, I think the OS should only allow you to change permissions via the Get Info window on files/folders that you have created, and require other changes to be done in the command line only.  There would be a lot fewer people getting themselves into these kinds of permissions-related problems if that change was made.

  • Cbuzio Level 1 Level 1

    Noleigator, I seem to be having a similar issue here.

    I have tried migrating with the time machine disk, and it created a new user in my new Macbook Pro with Lion (came already installed). I ended up with 2 admins in my mac. I then copied all the files from the old user (the one that came with the migration) and pasted them on my new user. I tried to delete the old user in the "User and Groups", but it got stuck, always saying "deleting" and not doing a thing (checked the cpu, it was doing nothing).

    I restarted the mac, and then noticed the other user was no longer there but the old files were still in the users folder. I had to delete them and thought the problem was solved (it was doing that thing of asking for the password from the begining).


    Here is were it matches your problem: the individual files came indeed from the time machine and now they all have that "everyone - custom" in them.


    (In my case, the folders have a "user" that doesn't seem to show up. I mean, it says "fetching..." and never does fetch the name. it has "read and write" privileges.)


    If you change the custom to, for example, "read only", perhaps you will be able to delete it... at least I managed to without it asking for the password.

    But of course, it is really time consuming to change this in every file.

    I found here in this forum post

    a possible solution for changing all the files with that "everyone-custom" into "read only".

    I haven't tried it yet, but I intend to, and if it helps I will let you know!


    here is the answer in that other forum post:



    I had this issue too, but my file permissions were correct on my .Trash folder.

    After a chat with a very helpful Apple Support rep the fix was to reset the permissions on the whole home folder.


    Check the permissions on one of your offending files (Get Info) and if you see there are 2x 'everyone' permissions and one is set to 'custom' then you will have the same issue as me. If you change the 'custom' permission to something else you will find it will now delete.


    I downloaded a small app called BatChmod and used this to batch process the permissions of my whole home folder. I suppose you could use chmod if you like ;-)


    See pic below for the settings, and once run, log out and back in again.


    Enjoy all your un-authenticated delete and move goodness!



    Screen Shot 2011-08-04 at 18.03.15.png


    I'll keep checking your post for possible solutions!

  • Cbuzio Level 1 Level 1

    I have tried the app BatChmod with success. I can now delete the files I changed without a problem. I did, however, change a few settings from the ones suggested in the image.


    In the owner and staff I selected (from the drop down list) the "---------" so that it wouldn't change that. I wouldn't want to be the owner of something I shouldn't and then have even more problems.


    However, first I used it in folders I wouldn't mind too much loosing... folders with some pictures, nothing much.


    I was also not sure what the "X" selected meant, but now my files (when I check the info) have "no access" for the user "everyone". I now only have one user that has that name.


    Does anyone know If it should be in "no access"? or should it be in "read only"?


    Anyway, I do hope this helps you.

  • MSiLight Level 1 Level 1

    I Found a Solution,

    Open your Home folder,

    then get info,

    in the bottom click on the lock bottun and enter your password, click on + and select your name,

    then in the privilege select read/write,

    then click on the perefrence icon beside +, apply all enclosed folder.....

    it's work for me. all privilage in mine.


  • fredjapan Level 1 Level 1

    I think I have a solution. At least it worked for me.


    I tried booting with the Command-R and use the reset password utility to reset the ACLs on my home folder, and somehow that didn't work. So I let it go a few days. I tried a million things, not too afraid since I had a complete backup of my files... Changing permissions on folders and permissions was not helping, very frustrating.


    But then someone suggested using MacPilot to do the same. It is difficult to find, there is way too many options in that application (!!) but then it was called "Reset Access Control List...", applied it to my user's folder, and the problem went away completely. Finally!

  • thetobster Level 1 Level 1

    The key definately seems to be in the ACL for the home folder and BatChmod fixed it for me.  All I had to do was click "Clear ACLs (10.5+)" on my home folder then everything was immediately fixed. I actually didn't have to adjust permissions.


    Great thread, thanks for the help everyone!

  • Mr Saphique Level 1 Level 1

    I upgraded from Snow Leopard 10.6.7 to Lion 10.7 and now running 10.7.2. My problem was that evertime I want to create or delete a folder on my Lion HD it required me to enter my admin password.
    Even after I just entered it seconds ago. The permissions on my disk ( the disk it's self) was System: Read & Write, wheel: Read, everyone: read. I changed wheel to Read & Write, didn't help. Then, I changed everyone to Read & Write. That actually helped! So the answer is to change your harddrive's permissions, everyone: Read & Write.

  • ankhank Level 1 Level 1

    It's not that simple.


    I've been round and round on this -- even went through erasing  the internal drive on my mid-2011 Lion machine, installing Lion from recovery/Internet, reinstalling everything.


    Everything I've tried -- from the simple fixes suggested above, to flushing all the ACLs, to the format and reinstall -- has fixed the permissions problems, for a while.


    Then the problems come back.


    The old 'permission to trash' problem on my Mini just came back again overnight, somehow the drive filled up with temp or cache or something and was barely stumbling in the morning. 


    Restarting the Mac and manually deleting files got lots of room back.


    Fixing permissions this morning got:


    Group differs on “Library/Java”; should be 0; group is 80.
    Permissions differ on “Library/Java”; should be drwxr-xr-x ; they are drwxrwxr-x .
    Repaired “Library/Java”
    Permissions differ on “System/Library/User Template/cs.lproj/Pictures/iChat Icons”; should be lrwxrwxrwx ; they are lrwxr-xr-x .
    Repaired “System/Library/User Template/cs.lproj/Pictures/iChat Icons”
    Permissions differ on “System/Library/User Template/hu.lproj/Pictures/iChat Icons”; should be lrwxrwxrwx ; they are lrwxr-xr-x .
    Repaired “System/Library/User Template/hu.lproj/Pictures/iChat Icons”
    Permissions differ on “System/Library/User Template/tr.lproj/Pictures/iChat Icons”; should be lrwxrwxrwx ; they are lrwxr-xr-x .
    Repaired “System/Library/User Template/tr.lproj/Pictures/iChat Icons”
    Permissions differ on “Users/Shared”; should be drwxrwxrwt ; they are drwxrwxrwx .


    Why the heck would those change overnight?


    Apple never admits problems until they have solutions.   The long long silence over this one continues.

  • exxi Level 1 Level 1

    had the same issue and even worse, after figuring out that itunes was not realy moving files to the trash, even when i asked it to do so.


    i saw that every file in my itunes music folder had this special second everyone-permission. i headed over to the terminal and used ls -ale to also show me the etries of the acl for this file (as an example i use the itunes library file ):


    $ ls -ale iTunes\ Library.itl

    -rw-------@ 1 exxi  staff  1234901 21 Dez 17:23 iTunes Library.itl

    0: group:everyone deny delete


    as you can see, there is a acl setting that prevents the deletion without a confirmation, even if it is me that owns the file wants to delete it. furthermore, if you try to remove the file via rm in the terminal, you'll get a permission denied error. to change that behaviour one can execute the following:


    $ chmod -a "everyone deny delete" iTunes\ Library.itl


    this will remove that special acl rule and you will not be asked for confirmation by finder when you want delete the file. also deletion via rm in terminal will also work again.


    to apply this to a full set of folders with subdirectories (as i did for my music folder), run this


    $ chmod -R -a "everyone deny delete" *


    from the folder that is the starting point. as others already have written, please do that only for the folders in your home directory, not on the system.


    i don't know when this started (or if it was there all the time since a moved over to lion), but now it is solved for me.




Previous 1 2 3 4 5 6 Next