Previous 1 4 5 6 7 8 Next 112 Replies Latest reply: Mar 11, 2016 12:48 AM by charlotteoswald Go to original post
  • abfield Level 1 Level 1

    I'd also like to report that this thread was very helpul and fixed my problem.  I'm on a brand new iMac 2011 running Lion.  I had an external NTFS formatted drive that contained a bunch of files I wanted to move to my new Mac.  So, I plugged the baby into the iMac and copied them to a folder under "Macintosh HD".


    I created an account for my wife (non-admin) and when logged in as her copied some of her personal files from that new folder to her personal User/Documents and User/Music.  This completely boned up the permissions because she was unable to edit any of the files and when trying to move or delete it would ask for an Admin password.


    After reading this (and several other) threads I opened Terminal on her account and first did a recursive chmod to make sure the file permissions were set.  I was also seeing the phantom second "everyone Custom" permission in Get Info.


    from Documents and then Music I ran: chmod -R 755 *


    then I ran: chmod -R -N *


    I then did an ls -le and the ACLs were gone.  She is now able to edit, move, delete the files in her User folders.


    I still do have an issue where Macintosh HD itself only shows "system: Read & Write", "wheel: Read only" and "everyone: Read only" as permissions.  There is no Admin or my user name.  So, each time I want to create a folder directly under Mac HD I have to enter my password.  That's for a different thread and I understand there are other posts on this topic.


    Thanks all!

  • Para 20 Level 1 Level 1

    Thanks, bud. Worked for me.


    RadRod wrote:




    I am so very happy to report that my problem is resolved.

    At least five tries in a row worked ( moves & Deletes) with old files from a backup with permission issues.


    I worked with a Sr. tech and a very simple command (that I was instructed to try before) worked.


    Lion Users:


    1) Shutdown

    2) Powerup holding CMD "R"

    3) Keep holding until you get to utilities page.

    4) Ignore the options in the center.

    5) Click on "Utilities" then "Terminal" On the top left menu bar. (Next to the Apple Icon)

    6) in Terminal enter "resetpassword" lower case, no spaces.

    7) Enter.

    8) You will get a popup to reset your password.

    9) DO NOT FILL IN THE FIELDS with a new password.

    10) Click the "Reset" button in the section below the fields for a new password.

    11) Close everything and reboot.

    12) Done.

    13) Your admin password stays the same.


    Nothing else was entered in Terminal

    The fix (for me) was different than that listed in TS1334.


    Hope this helps someone else.

  • doclipper Level 1 Level 1

    Thomas, I have read through this entire post and continue to have, as best I can tell, the issue that Noliegator had when he started this post.  Taking your point about multiple problems within a post, let me confirm that the problem I encountered just today is not being able to drag and drop files on my desktop to folders on my desktop, including the trash.  When I create a new folder on my desktop, the Finder requires my password to move the file to the new folder as well.


    I have tried several times the recommended fix to reset user folder permissions.  I would observe that in my case there are 3 users:  Myself, my wife, and Admin.  When first arriving at the Utilities screen, the Reset button is grey and I have to select one of the 3 users in the drop down menu for the Reset button to go live.  I performed reset for each of the users.  When I restart, the issue persists.  Repairing permissions also does nothing to correct the problem. 


    I can't tell if the User Folder permissions fix worked for Noliegator, but it did not for me.  Perhaps I have missed other fixes suggested in this post involving chmod but it is not clear that they apply to Noliegator's orginial inquiry.  If you have any thoughts at this point, I would be grateful.

  • ankhank Level 1 Level 1

    >  3 users:  Myself, my wife, and Admin.


    I had no luck either, and also had that setup (brought over via Migration from an older Mac)


    One fellow suggested creating a new "Group" containing the user accounts.

    That didn't work for me, but again possibly because I'd 'migrated' without having it already set up.


    I gave up.  My wife has her own computer now.


    Very clever of you, Apple marketing department ...

  • lucky4udan Level 1 Level 1

    Combining abfield and radrod' suggestions, here is the solution that worked for me. (Apple Sr. Tech advised this in my case.)


    1. Launch and go to user home directory and type:
    2. sudo chmod -RN ~
    3. at the prompt, enter your admin password
    4. You may get "Failed to clear ACL on File" msgs. Don't worry, the next step will address those.
    5. Restart in Recovery Boot Mode (hold down command R while rebooting)
    6. From the top menu bar, select Utilities > Terminal and type:
    7. resetpassword
    8. Leave the dialog box blank, but click the Reset button on the very bottom right.


    Worked for me.

  • hjerrold Level 1 Level 1

    Like the others have said, this "sudo chmod -RN ~" fixed my issues as well.  I was having to enter passwords for everything, every file i moved to another folder was a copy, vmware was complaining about permissions on the vmx file, shared files where not working as expected, everything was borked.


    Tried permissions repairs both from Disk Utility and from the command-R utility, tried creating new accounts, nothing fixed it.


    My wife was about to shoot me.  This resolved it in an instant.

  • DarMah Level 1 Level 1

    I went through nightmares with this permission problem and had to clean start all over again. This solved all my issues except of "iMail". Every time making a change in iMail Preferences, I get the message;

    "Error Saving Preferences,  Writing your preferences to disk has failed. Your preferences may not have been saved. The permission on ~/library/preferences may be wrong or your disk may be full"

    I did what you suggested with "sudo chmod -RN ~" but has not solved this problem.

    Anyone knowing what to do to get rid of this last "permission problem"?

    I created "" email in "iMail" and got the above message but it created the email account, however, after exiting, the next time opening iMail, my email was not there.

  • neiler2 Level 1 Level 1

    Similar issue here. My gf just got a new Mabook from work. It was setup by her IT guy. I transferred her user account from her old computer using migration assistant. Then had persistent requests for password when moving, renaming and deleting files. I had her log-out and login today and that fixed the problem.

  • lcapel Level 1 Level 1

    I had a similar issue where Finder required my password to delete files, then once I typed it they just disappeared and the Trash icon looked empty. After investigating I noticed that my .Trash folder in my Home directory had the private folder icon on it and I only had custom access. From the Terminal i then noticed that root had somehow taken ownership of the .Trash folder, I managed to fix it by typing the following in the Terminal:


    sudo chown [username]:staff .Trash


    I also previously used this to check the ownership of the folder:


    sudo ls -ld .Trash


    And initially this to show the hidded files in Finder (Swap YES with NO to revert):


    defaults write AppleShowAllFiles YES; killall -HUP Finder


    I hope this helps someon with a similar issue.

  • Tresgute Level 1 Level 1

    I had the exact same problem since I upgraded my macbook to Lion. I looked through the whole discussion and finally decided to try your below solution. It worked as magic! Thank you, Thomas!

    Thomas A Reed wrote:




    You've posted this on the tail end of an old, long topic...  that's never a good idea.  In the future, start your own.  However, what you need to do is probably to reset your user folder permissions.  Since you are now using Lion, hold down command-R at startup.  When the Mac OS X Utilities window appears, choose Terminal from the Utilities menu.  Type "resetpassword" (without the quotes) and hit return.  Do not change the password in the window that appears...  click the Reset button under "Reset Home Directory Permissions and ACLs".

  • AsstroApple Level 1 Level 1

    This worked perfectly!!! Thanks!!!

  • YoCraig Level 1 Level 1



    I came to this thread because all of a sudden I too was being asked to supply my password everytime I tried to move a file to the trash. After entering my password teh file(s) would be immediately deleted, not moved to the trash as is normal.


    I don't know what changed on my system or why to create this problem, but the advice given in this thread to type the following in the terminal fixed it:


    sudo chown yourusername .Trash

    Thank you!

  • Jeff1963 Level 1 Level 1

    I just ran into this problem and this solved my problem.  Even though this post is nearly 18 months old, it solved my problem.  thank you.

  • darrellfromCADCA Level 1 Level 1

    Thanks, the link provided worked for me.

Previous 1 4 5 6 7 8 Next