1 4 5 6 7 8 Previous Next 105 Replies Latest reply: Jan 25, 2014 4:37 PM by T.S Go to original post
  • 90. Re: Finder requires password for moving or deleting files every time.
    browndogva Level 1 Level 1 (0 points)

    Had the same issue develop several months after installing Mountain Lion; deleting a file from the desktop required a password.  Tried the link above and that didn't work, but this Terminal command posted by lcapel worked perfectly - thanks !

  • 91. Re: Finder requires password for moving or deleting files every time.
    SparkyCanada Level 1 Level 1 (115 points)

    RadRod's solution worked for me today - thanks!

     

    SparkyCanada

  • 92. Re: Finder requires password for moving or deleting files every time.
    abelnino Level 1 Level 1 (0 points)

    Problem solve with "sudo chown yourusername .Trash", thank you

  • 93. Re: Finder requires password for moving or deleting files every time.
    twentysixpoint2 Level 1 Level 1 (0 points)

    lucky4udan wrote:

     

    Combining abfield and radrod' suggestions, here is the solution that worked for me. (Apple Sr. Tech advised this in my case.)

     

    1. Launch Terminal.app and go to user home directory and type:
    2. sudo chmod -RN ~
    3. at the prompt, enter your admin password
    4. You may get "Failed to clear ACL on File" msgs. Don't worry, the next step will address those.
    5. Restart in Recovery Boot Mode (hold down command R while rebooting)
    6. From the top menu bar, select Utilities > Terminal and type:
    7. resetpassword
    8. Leave the dialog box blank, but click the Reset button on the very bottom right.

     

    Worked for me.

    This worked for me.  Very annoying issue.

  • 94. Re: Finder requires password for moving or deleting files every time.
    dbaccaro Level 1 Level 1 (0 points)

    I had the PW issue when trying to dump files in the trash. 

     

    Worked like a charm!

     

     

    Thanks.

  • 95. Re: Finder requires password for moving or deleting files every time.
    svsdnb Level 1 Level 1 (0 points)

    sudo chown yourusername .Trash

     

    This worked wonderfully! Thank you!

  • 96. Re: Finder requires password for moving or deleting files every time.
    choirguy Level 1 Level 1 (0 points)

    I just got this fixed by talking to Apple.  I also had to use my password every time I renamed or moved a file.

     

    Here is how I fixed it:

     

    1.  Right click (or option click, or two-finger click) on the Macintosh HD icon on your desktop and choose "Get Info"

     

    2.  Click on the lock in the lower right and put your password in to unlock.

     

    3.  Make sure the privileges for the system says "Read & Write."

     

    4.  Click on the gear at the bottom next to the plus and the minus.

     

    5.  Choose  "Apply to enclosed items"

     

    6.  Click back on the lock to lock your permissions.

  • 97. Re: Finder requires password for moving or deleting files every time.
    windcor Level 1 Level 1 (0 points)

    I have experienced weird permission errors from many of my applications after following these instructions. Have you personally tested them before?

     

    p/s: If I am not wrong, it changes all the permissions and some applications may cause conflicts as they requires different permissions.

     

    Now I can't open Skype anymore due to the permission error.

  • 98. Re: Finder requires password for moving or deleting files every time.
    Tracy Rasmussen Level 1 Level 1 (70 points)

    I had this problem in Snow Leopard after starting a new system on a new machine. Finder was requiring a password for moving any file, and some database programs would not open their transferred files. I just did the fix you suggested with the get Info, then make sure my user has read/write permissions, select that, go to the gear icon and choose "apply to enclosed items." It worked, when repeatedly repairing permissions had not. Thank you!!!

  • 99. Re: Finder requires password for moving or deleting files every time.
    Diablito Ricci Level 1 Level 1 (0 points)

    The solution by twentysixpoint2 worked perfectly!

  • 100. Re: Finder requires password for moving or deleting files every time.
    Paul E! Level 1 Level 1 (0 points)

    Hi - I had the same problem and this solved it for me. 

     

    Step 1: Open Macintosh HD in finder - right click and select reveal in finder.

    Step 2: Go to system preferences

    Step 3: Select Sharing > under file sharing add Macintosh HD

    Step 4: see what users are there - if you are not there add yourself and give read & write privelage -

     

    all done now I can delete anything I want without having to put my password in - I also shared the hard drive in step 1.  Hope this helps.

     

    pc.

  • 101. Re: Finder requires password for moving or deleting files every time.
    tdogg75 Level 1 Level 1 (0 points)

    After trying a bunch of solutions provides on this thread, the only one that actually worked was this link provided. Such an easy but effective fix. (My issue was that I was required to give username and passowrd when trying to move files into different folders or the trash.)

     

    http://support.apple.com/kb/TS4040

  • 102. Re: Finder requires password for moving or deleting files every time.
    normbal Level 1 Level 1 (10 points)

    This has been bugging me for several months now.  Having to enter my password to delete files.  I thought maybe it was a "feature" some programmer type thought useful.

     

    The solution for ME was following the directions given years ago by going into terminal mode on startup with command-R and typing resetpassword.

     

    But it didn't work the first time.  It DID work when I "reset home folder permissions and ACLs."

     

    Works great.  Now to update to Mavericks like my desktop.  But not before making a complete backup to time machine.

  • 103. Re: Finder requires password for moving or deleting files every time.
    FredGosbee Level 1 Level 1 (0 points)

    I had the same problem.

    When I got info for files there were two users listed as "everyone". One had read/write privliges, the other had Custom"

     

    I opened each users file and Got Info for the users on this system (there are only three: admin, me, and work). The permissions for "everyone" were "read/write" in my user folder but "Read Only" in the others. When I changed them all to "Read/Write" the everyone "Custom" group disappeared and now I can move, delete and modify files without the admi/password routine.

  • 104. Re: Finder requires password for moving or deleting files every time.
    normbal Level 1 Level 1 (10 points)

    Looked at that.  No luck.

     

    I'd actually had my laptop (macbook air) into the apple genius bar TWICE this past month with this as one of several issues (the main one being not being able to recover disc space after deleting programs... for some reason OSX Lion was holding the space in the delete folder and not releasing it - not until the genius bar guy did a command-R startup and repaired permissions and did some cut-paste work with my home folder. I had to back everything up on a peripheral HD and bring it into the shop, took hours).

     

    "Genius" tried fixing the password/permission thing twice, went through all the regular settings, said the other three guys in the backroom told him all we needed to do was the command-R/repair permissions thing and it would work.  It didn't.  They were stumped.

     

    THESE WERE APPLE-TRAINED TECHNICIANS.  With all their resources available.

     

    It wasn't until I got home, did a search for this problem and found the solution on this forum.

     

    This is too much like using a damned windows PC for me.

     

    All this time I thought macs "just work."

     

    A rare series of unfortunate events, software glitches, update issues, who knows.  System seems to be working now, except I installed Windoes 7 under VMware over the weekend and ran into the same problems.  Temporary files being saved, delected files saved, etc.

     

    Started with 150 gB on HD, after installing Win7 I only had 70.  Really?  Win 7 is a 70 gB program?  From a 4 gB disc (or is that a 750 mB CD?  Plus 130 some update files?).  I ran disc inventory X, found the trash was full, deleted everything, rebooted, and I've still got 127 gB free.  Better than it was, but again, this is way too much like a PC OS to me and I don't need another hobby.

     

    I upgraded to Mavericks, let's see if any of this goes away or it's back to the "genius" bar for another round.

1 4 5 6 7 8 Previous Next