Previous 1 2 3 4 5 6 Next 114 Replies Latest reply: Jul 25, 2015 1:18 AM by ryan_macmac Go to original post
  • willObst Level 1 Level 1

    Very interesting - I'll give it a try!

  • JPDy Level 1 Level 1


    I had the same problem but since I have disconnected in preferences panel "Share", every share options in particular "internet share" except for printers it works very well even if the cation to go to sleep is a little long (30s)

  • boz0 Level 1 Level 1

    Same problem with my iMac. The problems seems to come from the audio subsystem in my case, sometimes usbmuxd, sometimes coreaudiod :


    # pmset -g assertions

    9/1/11 6:12:08 PM GMT+0

    Assertion status system-wide:

       ChargeInhibit                           0

       PreventUserIdleDisplaySleep             0

       PreventUserIdleSystemSleep              1

       NoRealPowerSources_debug                0

       CPUBoundAssertion                       0

       EnableIdleSleep                         1

       PreventSystemSleep                      0

       DisableInflow                           0

       DisableLowPowerBatteryWarnings          0

       ExternalMedia                           0


    Listed by owning process:

      pid 169: [0x0000012c000000a9] PreventUserIdleSystemSleep named: "'AppleHDAEngineOutput:1B,0,1,2:0'.noidlesleep"


    Kernel Assertions: 0x0004

    * Kernel Assertion ID = 500

       Created At = 1/1/70 1:02:27 AM GMT+0

       Modified At = 8/31/11 5:50:46 AM GMT+

       Owner ID = 0xffffff8013d81000

       Level = 255

       Assertions Set = None (4)


    * Kernel Assertion ID = 501

       Created At = 1/1/70 1:02:33 AM GMT+0

       Modified At = 8/31/11 5:50:54 AM GMT+

       Owner ID = 0xffffff8013dc2000

       Level = 255

       Assertions Set = None (4)


    # ps aux | grep 169

    _coreaudiod      169   1,9  0,1  2516412   7936   ??  Ss   Mer03     3:50.76 /usr/sbin/coreaudiod

  • andysd Level 1 Level 1

    I had the same issue, but in my case it would sleep fine when the power cord was disconnected -- but not when charging.  I solved it yesterday by running this command from Terminal:


    pmset -g assertions


    as mentioned in the previous post.  In my case it was some CUPS print driver.  I un-installed the "printer" and things are back to normal.

  • apexio Level 1 Level 1

    Well that got me checking into other processes... 


    When I killed the VMware Fusion (3.1.3) networking processes the 'won't sleep when plugged in' problem goes away.


    While pmset -g assertions did show '1' next to 'EnableIdleSleep', no matter what processes I killed that number did not change.

  • apexio Level 1 Level 1

    Internet Sharing is causing this problem too.

  • boz0 Level 1 Level 1

    Yep, despite the audio-related assertions I saw, it apparently was a sharing problem in my case as well : I removed the printer sharing, and all of a sudden, the machine is sleeping well. I had no other sharing enabled, but from what I've read in other places, you might want to try removing every kind of sharing if your mac doesn't want to go to sleep.

  • CndrllC Level 1 Level 1

    The only thing is I dont have any sharing on - at all.  Not internet, not file sharing.  nothing.  No usb devices... Nadda.


    So I dunno whats going on

  • coloradoappleuser Level 1 Level 1

    I was experiencing this on my 2010 iMac and ended up doing 2 things.  Unfortunately I'm not sure which one actually fixed the problem, but the computer definitely sleeps on its own now:


    1) Uninstall VMWare.


    2) Clean install of Lion.


    I am not eager to reinstall VMWare to learn if that was in fact causing the problem, and I don't really use it often.

  • apexio Level 1 Level 1

    coloradoappleuser wrote:


    1) Uninstall VMWare.


    I am not eager to reinstall VMWare to learn if that was in fact causing the problem, and I don't really use it often.


    VMWare has ~6 background network processes.  One or more of them was causing the issue for me so I suspect that was your cause too.  


    I switched to VirtualBox and it doesn't have the issue.  I even use the same guest OS - I copied the .vmdk file from within the .vmware package (Show Package Contents) and added it to a new machine in VirtualBox.  I did have to uncheck 'split hard disks into 2gb chunks' option first, so that VMWare recombined the HD file(s) into a single file.  This may or may not apply to you.

  • Andyzzz Level 1 Level 1

    I was having the same problem on my mac mini 2010 not going to sleep which was caused by a print item stuck in the print queue, I deleted the item and now is all well. Just to your Print & Scan in system preferences, select your printer(s), and then click the "Open Print Queue" button to show the print jobs and delete any that have not completed.


  • rick722 Level 1 Level 1
    Apple Music

    I think this was my problem too thanks!  I'll monitor it for a few days to make sure...



  • Kristjansson Level 1 Level 1

    I'll be goddamned.  Had the exact same problem, caused by file stuck in the print quene for a printer 3000 miles away.  Problem solved.  Thanks man.

  • cookie241 Level 1 Level 1

    Thanks, I had the exact problem. A print queue from my office printer (my MBP normally "sleeps" at home)


    I deleted all queued items & presto problem fixed. Too easy!! but who would have thought!

  • boz0 Level 1 Level 1

    One more thing : if your system still has trouble going to sleep, you can use PleaseSleep (, freeware), I've been depending on it to put my iMac to sleep since Snow Leopard.


    For those who still have problems after turning of every kind of sharing, it's well worth installing.

Previous 1 2 3 4 5 6 Next