1 2 3 Previous Next 114 Replies Latest reply: May 22, 2014 9:49 AM by Eduardo Gutierrez De O.
Essayons Level 1 Level 1 (0 points)

I have an HP OfficeJet 8500 Premier that is only 2 years old.  One of the things I loved about it was the ability to scan documents to a folder on my Mac.  Unfortunately, the only filesharing HP supports is SMB.  In SnowLeopard, SMB worked great (as long as SMB was set up in "Sharing"). 

 

Now, however, I cannot connect my HP printer/scanner to my Mac via SMB.  I have rebooted my Mac, rebooted my printer, turned on then off the SMB sharing, tried to re-setup the scan-to folder on my printer...all to no avail. 

 

One other oddity--when I try to turn off my SMB account (my login account) in sharing, it won't let me.  It asks for a password then unchecks the account briefly, then re-checks the account (leaving it on).  I have the opposite problem on my MBP--when I try to turn on SMB sharing and select the account, it asks for a password and briefly checks the account box, then un-checks it.

 

Anyone have any solutions for getting an HP printer/scanner to Scan-to a Mac running 10.7?

 

Thanks,

T.


iMac, Mac OS X (10.7)
  • 1. Re: Problems with SMB and file sharing in Lion
    RodneyW Level 4 Level 4 (3,030 points)

    There is an issue with SMB sharing that was set up at a "user" level in Snow Leopard and then migrated to Lion.  I have not yet found a way to get the enable/disable preference to work.

     

    I have submitted a bug report.

  • 2. Re: Problems with SMB and file sharing in Lion
    Chih Level 1 Level 1 (0 points)

    Just found out that SMB file sharing has been REMOVED in Mac OS 10.7 (Lion) - so your scanning will NOT work under Lion. Unless Apple decides to add back the SMB into their OS, your scanning will not be able to work like it did under Snow Leopard...

     

    Same thing happened to me with my Multi function printer/scanner

  • 3. Re: Problems with SMB and file sharing in Lion
    RodneyW Level 4 Level 4 (3,030 points)

    Dear Chih,

     

    SMB file sharing has NOT been removed in 10.7. It has been implemented using a "hoome grown" Apple technology, rather than the open source "Samba" suite of tools.

     

    There may be a few bugs in v1 of the new Apple tools, but the overall benefit is that Apple is significantly improving the file sharing compatibility with the latest versions of Windows (i.e Windows 2008 Server and Windows 7).  I expect that - by 10.7.3 - Apple will have these problems completely licked.

     

    Cheers,

     

    Rodney

  • 4. Re: Problems with SMB and file sharing in Lion
    Chih Level 1 Level 1 (0 points)

    Hi Rodney,

     

    Thanks for the info!!

     

    So I guess the SMB file sharing will only be available in the later Apple OS versions?

     

    Do you know around when Apple would be releasing a later version of 10.7?

     

    Thanks again!!

  • 5. Re: Problems with SMB and file sharing in Lion
    RodneyW Level 4 Level 4 (3,030 points)

    SMB file sharing is available now (in 10.7.0), and it works reasonably well with Windows 7 and Windows 2008 Server.

     

    BUT, there are issues with some clients (Samba based printers and servers especially), that cannot connect to the OS X file sharing. 

     

    I don't know the schedule of releases, but I am certain that Apple will fix bugs as they come to light, and will release fixes fairly quickly.  This has been the pattern of OS X for more than 10 years. 

  • 6. Re: Problems with SMB and file sharing in Lion
    Chih Level 1 Level 1 (0 points)

    Ok, I see. Thanks.

     

    I'm actually using a Xerox Multi-Function printer. I'm attaching the specification of the model below:

     

    http://www.office.xerox.com/multifunction-printer/color-multifunction/phaser-618 0mfp/spec-enus.html


    Could you please tell me if the printer will have trouble using wireless scanning under OS 10.7 - I actually had no problem with scanning while I was at OS 10.6.8, but after I upgraded to 10.7, the scan simply stop working.

     

    I called Xerox Technical Support and the guy told me they had a few Mac users who called earlier reporting the same problem after upgrading to 10.7

     

    Thanks again.

  • 7. Re: Problems with SMB and file sharing in Lion
    damarch Level 1 Level 1 (5 points)

    Chih,

     

    I'm having a heck of a time trying to set up the SMB with 10.6.8........can you provide some insight?  I've followed the manual and can't seem to make things work.

  • 8. Re: Problems with SMB and file sharing in Lion
    danielsosmacfrance Level 1 Level 1 (10 points)

    Hello guys,

     

    we have a brand new Canon Advance iR C2380i that used to send scans via SMB to all of our posts. One of the new posts is running in Lion and, besides plenty of bugs and the need to get rid of Cs2 and some other apps, the SMB scan function is not working at all.

     

    I activaded the file sharing and the SMB feature, we're all able to read and write on that folder and I actually can see the folders on the net, the scanner doesn´t though.

     

    The paths are correct, the user left read and write open for all users but anyway we can't make it work.

  • 9. Re: Problems with SMB and file sharing in Lion
    b.Leev Level 1 Level 1 (0 points)

    Uf, 2 hrs of head crashing, wanted to set up SMB feature to scan to shared folder from my HP 8500 wireless.

     

    Now I am reading this, so....

     

    I will leave it for now untill it is not solved by Apple..

     

    "

    Network Folder Configuration

     

     

    Connection failed

    Click "OK" to go back.

     

    This is what I get

  • 10. Re: Problems with SMB and file sharing in Lion
    Richard Unten Level 1 Level 1 (55 points)

    Chih,

     

    I also have a Xerox 6180 MFP that stopped connecting to a Lion Server machine via SMB, but I was able to come up with a workaround using FTP:

     

    Although Lion Server's GUI doesn't have a service switch for FTP, it still exists and can be turned on via command line.

     

    This is the workflow: Everyone at my office shares the Xerox 6180 scanner, so I created individual scan bins in the Xerox Directory for every user.  A user would select their scan bin on the Xerox 6180 (Scan > Server > Scan to... Richard's Scan Bin) and make their scan.  The Xerox 6180 FTPs the file to a Mac Mini running Lion Server.  The user goes back to their workstation, logs into the server via AFP, and grabs the file out of their private scan bin.

     

    My workaround on OSX Lion Server:

     

    1.) I already had a "xerox" user in a group called "scangroup" via the Server.app.  This user is for the Xerox 6180.

     

    2.) In Terminal.app, I created an ftp access group called "com.apple.access_ftp":

       sudo dseditgroup -o create com.apple.access_ftp

     

    3.) Then I added my "scangroup" group to "com.apple.access_ftp":

       sudo dseditgroup -o edit -a scangroup -t group com.apple.access_ftp

     

    4.) Next, I turned on FTP:

       sudo launchctl load -w /System/Library/LaunchDaemons/ftp.plist

     

    5.) In the "xerox" user's home folder, I created a directory called "Scans" and sharepoint subdirectories in it for each Shared User account (e.g. ~/Scans/Richard's Scan Bin)

     

    6.) In Server.app, I gave each Shared User read/write permission to only their subdirectory (i.e. The shared user "Richard" has read/write permission for "Richard's Scan Bin" folder)

     

    7.) In the Xerox Server Address Book Directory, I created entries for each user.  i.e.:

       Name: Richard's Scans

       Server Type: FTP

       Server Address: [Your server's address]

       Port Number: 21

       Login Name: xerox

       Login PW: [your password]

       Server Path: Scans/Richard's Scans

     

    You can also tweak my workaround if you aren't using Lion Server.

     

    Hope this helps!

  • 11. Re: Problems with SMB and file sharing in Lion
    danielsosmacfrance Level 1 Level 1 (10 points)

    My problem here is that I have no Lion servers and most of the mac computers have to be on DHCP in order to connect to a remote windows server. Without a fix IP address I can't use FTP and scan by mail is impossible since we scan huge images.

  • 12. Re: Problems with SMB and file sharing in Lion
    fwdIT Level 1 Level 1 (0 points)

    Problem is that Lion isn't listening on port 139 anymore (SMB - Netbios - TCP) but on port 445 (SMB directly over TCP)

    Sadly my Phaser 6180 MFP doesn't allow me to choose port 445

    Going to setup FTP then on my desktop I guess

  • 13. Re: Problems with SMB and file sharing in Lion
    Essayons Level 1 Level 1 (0 points)

    Thanks all for your comments and suggestions.  I found one possible work-around because I have a time capsule (which does still have working SMB):  I had my OfficeJet scan to a network folder which I created on my Time Capsule and I created an alias to that folder on my mac in the same place where I used to recieve my scans.  Not pretty but very functional.

  • 14. Re: Problems with SMB and file sharing in Lion
    ve7tcc Level 1 Level 1 (0 points)

    Perhaps you can download vanilla samba ( http://www.samba.org  or here http://mac.softpedia.com/get/Network-Admin/Samba.shtml ) and install it on lion, and set it up the way you want it.

1 2 3 Previous Next