Previous 1 2 3 Next 61 Replies Latest reply: Mar 1, 2012 8:08 AM by fabiolr
lpotr4 Level 1 (0 points)

I'm not sure if this problem was present prior to updating to Lion from the latest 10.6, but I can't seem to disable file sharing using SMB on my MBP. I've only known to have used my login password as the same login when I activated SMB share a while back, and now all I get when using the same password is "Incorrect Password". I've tried implementing most of the suggestions I've found in this forum and on the web and that included resetting the password in System Preferences > Users & Groups (Accounts). I logged in using another admin account and it would not also let me turn off SMB sharing and returning an error "Incorrect Password" whenever I typed in what I believe to be the correct password (which is the user/admin pw used to log into the account currently being used). I have also tried: looking through the System Preferences > Security & Privacy (in hopes that FileVault has a hand in this, and it is currently off), then tried repairing Keychain (newp), and lastly, changed the Master Password to no avail. The one suggested fix I didn't try is creating a new user account and migrating all my files to that account. I'd rather not since that is way too much hassle just to turn off SMB sharing.


If anyone has ideas on how to reset or turn off file sharing using SMB, or knows how to resolve this issue, please post some help as this is driving me batty.






PS. Also another unrealted question: Is AirDrop not supported on a 2008 MBP? For the life of me, I couldn't find AirDrop anywhere on my mac (looked at the sidebar and prefs to enable it and it's not there as an option). My card type is an AirPort Extreme (802.11 a/b/g/n -- with firmware Broadcom BCM43xx 1.0)

MacBook Pro 17" 2.6GHz, Mac OS X (10.6), 200GB/7200 RPM HDD, 4GB RAM, 2008 non-unibody
  • lpotr4 Level 1 (0 points)

    I also forgot to mention, I had file sharing enable using SMB (and AFP) turned on for two user accounts (mine and Public) while in Mac OS 10.6 (Snow Leopard) and left it on as I upgraded to 10.7 (Lion). This leads me to believe that Lion has somehow 'locked' that setting from Snow Leopard, even making the passwords invalid thus leaving me no option to disable those accounts with SMB turned on in Lion. I hope there is a fix to this... soon.

  • darkthunder Level 1 (0 points)

    I am having the same issue... there are several posts on various forums about this but no answers yet. Apple I am a new Mac user! Please help!

  • lpotr4 Level 1 (0 points)

    Having found no immediate solution, I went ahead and rolled back to 10.6.8 via my last TimeMachine backup (that is 3.5 hours of my life I'll never get back). While back in Snow Leopard, I was able to again disable smb sharing by typing in the same password that Lion was flagging as "Incorrect Password".


    This leads me to believe that anything samba (smb) related must be cleared or returned back to a disabled state prior to updating to Lion as neglecting to doing so will render you an smb setting that you can no longer edit. I hope that Apple is aware of this bug and address it soon as I'm sure I am not the only person having this problem.


    In the meantime, I have prepped my current SL install and also (re)applied the latest 10.6.8 combo updater for good measure, while still in SL, I also went ahead and removed all my apps that are still PowerPC and any other apps that I know fails under Lion. Waiting on another 3-hours or so for Lion to re-download and install. *sigh*

  • Guy-CP Level 1 (5 points)

    Same problem here after upgraded to Lion. I have asked thgis question on other site and got this answer which seems to be the only possible solution to try but unfortunately it is out of my skill


  • JaimeAstin Level 1 (5 points)



    I think it is all because of a restore of files from snow leopard....

  • JaimeAstin Level 1 (5 points)

    Well, I had the same issue.  Called apple support and no fix.  They made and apple genius bar appointment.  I went.  The genius was good, I got a parking ticket for the time being in the apple store, but still no answer.  The genius deleted the user accounts hoping the rid the problem as a last atttempt.  Still did not fix it.  I told him rather than waste anymore time with this, I was going to reinstall the OS.  I did that and restored from time machine and the problem came back.  So I reinstalled it again without migrating data from time machine and so far I have no issues. 


    My advice to anyone with Lion and needing to share with SMB and use CFIS do not migrate data from a snow leopard backup...   Shoot, I would not migrate from it in any case now.  I notice all of these useless files all over my computer even though the original application was not apple to transfer to lion. 


    My Post on Mac Rumors


    My Video of the Problem...

  • lpotr4 Level 1 (0 points)

    I think that's the problem right there, Lion doesn't like the saved data from Snow Leopard: updated or migrated. After rolling back to SL via Time Machine backups, I was able to go in and turn off sharing via SMB on all accounts it was active on and left it off. I did some ppc app cleanup and prepped the system again (did the SL combo updater) before upgrading back to Lion. Once back on Lion the SMB share settings remained off (as I have left it in that state in SL) but once again could not be accessed or turned on using the same password, instead it would throw an "Incorrect Password" error just like it did initially. I  then went ahead and created a new Admin user account and from there I could turn on SMB sharing on and off with the login credential and I get no invalid password errors. This alone has led me to believe that Lion is not playig nice with data/password/info updated or migrated from Snow Leopard. Thanks for confirming this btw...


    I hope Apple addresses this soon.

  • darkthunder Level 1 (0 points)

    I don't believe this issue is limited to those that upgraded from Snow Leopard. I have a new Mac Mini with Lion preinstalled and the same issue is happening on my system.

  • JaimeAstin Level 1 (5 points)

    I am using a Mac mini (2011) as well...  I honestly can't confirm having the issue before the migrate, but I know I am fine now after the restore and not migrating. I did test with a restore and migrate and the same issue was present.... 


    I know it is an issue none the less.


    Now, on your Mac "darkthunder"' what issue are you having. All of the above, or just one or so.   Just asking as it seems we are troubleshooting each others problem

  • dan67 Level 1 (0 points)

    We must recreate a user account but not through the Sharing but by Users and groups. The account created is placed in the group (staff)
    The primary account must be recreated and overwritten.

  • Jackalton Level 1 (5 points)

    I had exactly the same problem, and it turned out I had a Sharing account in Users & Groups that I presume was a hangover from my previous SL installation. Deleting this account deleted the account in SMB sharing too.

  • lpotr4 Level 1 (0 points)

    It seems the Mac OS 10.7.1 update did not address this sharing error issue at all. What a disappointment. I'm apalled how with all the 'new features' pushed out by Apple that they would (continue to) ignore such a glaring functionality flaw that affects one of the core usability of ANY operating system: file sharing.


    Fix the **** thing Apple!

  • mibrodt Level 1 (20 points)

    I believe if you do not have the SMB Sharing box checked, then it shouldn't matter that your user account box is checked because SMB Sharing should be off to begin with. With the SMB Box un-checked, have you tried to connect to your user account over SMB?


    Also, have you tried checking the box for SMB sharing first, then try disabling the account? I don't know if that is a fix, but I now there was a similar issue when trying to add or remove users from Remote Management pane in 10.6. Also, is this just a local account or is it an Active Directory account? I know in 10.6 there seems to be an issue where you can't enable SMB sharing for Active Directory-based accounts (which makes no sense). I wonder if the same is true here.

  • lpotr4 Level 1 (0 points)

    SMB Sharing is turned off and user accounts associated with it are also checked off now, but that was only after I reverted back to my Snow Leopard restored backup and turning those (sharing) off from there. However, after updating back to Lion, I am unable to toggle (on or off) SMB or AFP sharing for the same user accounts with "Incorrect password error" still being present (despite using that same assword and it working in SL). At this point I have exhausted every suggestion I have enountered on the internet from resetting passwords, resetting Keychain login passwords, deleting any "SMB" login in keychain, running permissions repair etc. BUT, as I stated somewhere earlier, creating an entirely new user admin account does not yeild the same errors and I can toggle SMB and AFP sharing on and off without the "Incorrect password" error. This leads me to believe that Lion has somehow screwd up the passsword syncing of my old user accounts which I am not ready to relinquish at this point for a brand new one (and I don't see why I should).


    Also an Apple note about leaving SMB on:

    Because passwords for some Windows users may be stored less securely, it’s a good idea to disable Windows users’ accounts when they’re not in use. Deselect the On checkbox next to an account to disable the account. Be sure to disable the account before you turn off file sharing on your computer. Otherwise, the password is still active and stored in a less secure manner.


    I suppose I'll just continue to ignore that this issue exists on my MBP since Apple is doing the same.

Previous 1 2 3 Next