Previous 1 2 3 4 5 Next 61 Replies Latest reply: Mar 1, 2012 8:08 AM by fabiolr Go to original post
  • François J. Perreault Level 2 (175 points)

    This seems to have occured before...  here are some links that might hint at a solution, or perhaps, help makes sense of what's really taking place!

     

    might help: http://superuser.com/questions/79220/enable-smb-file-sharing-on-os-x-incorrect-p assword

     

    more in-dept: https://discussions.apple.com/message/10111173?messageID=10111173&#10111173?mess ageID=10111173&

     

    seems deprecated: http://hints.macworld.com/article.php?story=20030930084454653

  • François J. Perreault Level 2 (175 points)

    Another page suggested that you simply re-change your password (using System Preferences | Users) which didn't work for me.  However, after reading through all these links, and having had toyed with this a few years ago on OS X and Linux, I am pretty sure that all this is rather dependant on the "smbpasswd" command, which I cannot find anywhere on my system!!?? 

     

    Could it be that's it's all failing simply because that piece of the puzzle is missing?

  • mibrodt Level 1 (20 points)

    the smbpasswd tool is probably not there because Lion doesn't use Samba. Apple built their own Windows Services to replace Samba in Lion. This may also explain why the incorrect password error is happening when migrating. Because the SMB sharing is being handled by custom tools, not Samba, the migration utility doesn't translate the smb password information from one to the other properly. If you create a new account in Lion, you can modify it because it was created using the new Windows Services.

  • darkthunder Level 1 (0 points)

    The problem is not isolated to only those migrating to Lion. I am a new Mac Mini owner. My Mac was preloaded with Lion and I had the same password issue being discussed here.

  • lpotr4 Level 1 (0 points)

    Also just to be clear (since several suggested fixes only address external login problems), the "Incorrect password error" I encounter does not only occur when accessing my Mac from a Windows machine, more specifically, that error is happening locally, on my machine while I try to enable/disable an existing user account's SMB sharing. I've attached the screen cap below:

     

    smberror.png

     

    PS. As a note, this error is not consistent apparently with all Macs, as I've had cowerks who did the upgrade from SL to Lion that does not see this error. These are the newer MBPs though compared to my early 2008 17" MBP. Not sure if it has anything to do with hardware but just wanted to throw that out there.

  • jmcgeejr Level 1 (0 points)

    Hi, I am going to bump this as I too am still having this problem.   I have tried so many things and yet to no avail.  I am not in a place where I want to reinstall Lion and then recreate my account.  Any one have any updates?

  • jmcgeejr Level 1 (0 points)

    Going to add an update to this, for stuff I have tried, I just made a CCC of my drive, reinstalled LION from scratch and then did migration assistant, this time I didnt choose any of the computer or network settings, still no dice, I even unchecked file sharing before I did the CCC.  Meh, hopefully someday apple will acknowledge this and fix it.

     

    I really would like to not have to share EVERYTHING THAT MY MAIN ACCOUNT HAS ACCESS TO to everyone else on my network.

  • Simonp123456 Level 1 (5 points)

    I'm having this problem too. Also getting crashing of Photshop elements since upgrading to Lion.

    I might end up going back to Snow Leopard there are just too many problems with Lion it's beyond a joke,

  • jmcgeejr Level 1 (0 points)

    Some of us are stuck with it , I am not willing to do the hack to get SL installed on my 2011 mini.

  • Boaz_ Level 1 (0 points)

    I found a workaround to the "incorrect password" problem in the smb share:

     

    Create/enable a "root" account (do a search on how, it's pretty simple), login via root and edit your smb settings.  Worked for me.  Good luck....

  • François J. Perreault Level 2 (175 points)

    Please do tell us what settings you changed to resolve the issue!

  • Boaz_ Level 1 (0 points)

    To enable root user see this:

     

    http://support.apple.com/kb/ht1528

     

    Once root user is enabled, log in as "root", then go to file share settings and adjust your smb settings.

  • jmcgeejr Level 1 (0 points)

    Just a heads up that this doesnt fix the unable to deselect account issue, not sure about the wrong password error.  But the one that is  from an account migrated from SL to lion with smb sharing enabled is still bugged out and cant be deslected.

  • François J. Perreault Level 2 (175 points)

    I haven't tried the root thing yet, however, I thought I should mention that my account wasn't "checked" before migration (to Lion) because a) admin accounts had access without needing to be enabled in the sharing dialog, and b) I was mapping read-only shares as "Guest" anyhow (at the time).  None of this works anymore.

  • Ryccardo Level 1 (25 points)

    I've found a solution (10.7.1, unable to turn on Samba login for my primary account, using FileVault2);

     

    1. Go to Preferences / Users & Groups
    2. Change your password.
    3. Disable sharing access for Guest.
    4. Create a new Sharing Only account.
    5. In Sharing Preferences, enable Samba access for the account you just made.
    6. Optional: undo the changes you made in steps 3 and 2.
    7. Enable/disable Samba for your account.
    8. Optional: remove the new account.