Previous 1 2 3 Next 34 Replies Latest reply: Nov 9, 2012 11:12 PM by hoops7 Go to original post
  • Fred de Gembloux Level 1 Level 1

    Certificates are now finally correctly assigned to each key, but pay attention to the command to (re)assign them...


    mymac:~ waider$ sudo serveradmin settings notifications:sslKeyFile = "/etc/certificates/ concat.pem"

    mymac:~ waider$ sudo serveradmin settings notifications:sslCAFile = "/etc/certificates/ chain.pem"

    When typing the command "serveradmin settings notification:sslKeyFile" type notification without "s".


    It worked for me... for the certificate part. I still get disconnections from apple servers.



  • waider Level 1 Level 1

    Yup, I mentioned this a few posts down from my original suggestion - not sure if this was a cut & paste error on my part or a change from 10.7.2 to 10.7.3

  • Matt Domenici Level 1 Level 1

    The disconnect from the feedback server is not an error, although the null would suggest otherwise.  The feedback server needs to be polled intermittently to see if there's any devices that are no longer registered or responding to the profile manager's requests -- in essence, this is the feedback loop from the server (on Apple's side) to let your server know "there's nothing to report."

  • Rahan75 Level 1 Level 1



    My turn to have a Notification pb, here is the error that shows in the log :


    [twistedcaldav.notify.Notifier#warn] Could not create node /CalDAV/

    2012-08-14 12:38:25+0200 [-] [caldav-3]  [-] [twistedcaldav.notify.Notifier#warn] Could not create node /CalDAV/


    any idea ...


    Thanks !

  • hoops7 Level 1 Level 1

    Hi I had this exact issue with clean install of Lion Server 10.7.5 with no services initiated except the web service was turned on and I had also set valid verified SSL certificate. The same repeating error arose after restarting the server -


 [628]: Unable to find identity


 [628]: Unable to configure SSL.  Not starting HTTP Server


    jabberd_notification/router[150]: [, port=49541] connect

    jabberd_notification/router[150]: [, port=49541] disconnect[1] ([628]): Exited with code: 1[1] ( Throttling respawn: Will start in 10 seconds

    As noted by the gurus in this post (and other key posts thanks Mark 23 Beno44 Drizzt others) the issue is with the SSL Certificate set for APN.

    The common cause of this issue is that when you set up OD by pressing the "configure"  button in ProM settings (as per numerous authoritative recommendations - 318, ToddOlthoff, Ars Technica  to create a stable ProM) which then creates an OD master -

    = this creates a new certificate (which you can see by pressing the SSL Certificate "edit" button which has the title "[your domain name].com - [your domain name].com OD Intermediate CA"

    Alternatively it is in keychain and although it is headed with [your domain name].com it is issued by "IntermediateCA_[your DOMAIN NAME].COM_1" (note capitals).

    ARS TECNICA noted the creation of the 2nd certificate and recommended to configure the OD separately.

    The solution is to set the "OD" certificate with the SSL "edit button

    Watch the system log (from the Console App (in the Utilities folder)) as it now loads jabber notifications etc.

    The extra solution is that you can set the SSL certificate for OD in SAdmin/Settings/LDAP checkbox to "Enable SSL" then select your Verified 3rd Party SSL Certificate from the drop down menu as the SSL for OD

    then back at SApp reset your 3rd Party certificate again

    watch the system log loading jabber notifications as before

    Now that the OD is set with the right SSL the Certificate you set in SApp will match

    Hope this helps

Previous 1 2 3 Next