Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Mail no longer shows attachments in paper clip column

Since updating to Lion, new emails that have attachment do not have a paper clip showing in that column. Old emails have it. I need it to show and can't figure out how to make that happen.


I'm sure it simple, can anyone help?

Thanks

iMac, Mac OS X (10.7)

Posted on

Reply

Page content loaded

Jul 30, 2011 6:34 PM in response to kkd78 In response to kkd78

Is this the inbox or the sent box?


In classic view you control click in the column header area and check attachment. This should carry over to the new View.




Newly sent mail seem to be missing the Attachment paperclip (sent box.) Hopefully this can be sorted with enough feedback.



http://www.apple.com/feedback/

Jul 30, 2011 6:34 PM

Reply Helpful

Jul 30, 2011 6:33 PM in response to leroydouglas In response to leroydouglas

They were in the Sent box, and I dragged to another mailbox. But the paper clip didn't show up in the Sent box or the box I dragged to.


The paper clip column heading is shown, but there is no indication next to teh new mail messages that have attachments. When I open the message, the attachments are there.


Thanks

Jul 30, 2011 6:33 PM

Reply Helpful

Jul 30, 2011 6:52 PM in response to leroydouglas In response to leroydouglas

I think the problem (bug) is bit worse. Try sending just an attachment (no text). I get this for a display:

User uploaded file

Perhaps why the icon missing, is because Mail can't determine what's in the message correctly. Well, let's see what comes out in 10.7.2 🙂

Jul 30, 2011 6:52 PM

Reply Helpful

Sep 9, 2011 8:00 AM in response to kkd78 In response to kkd78

Exact same problem here. Have you heard anything yet? Nothing in this thread either applies directly, or fixes the issue, for me. 10.7.1, Apple Mail (all current), multiple POP and IMAP accts checked, no paper clips in Sent. Tried, for fun, to moving sent mail with attachments (and no clip) into another mailbox, like Inbox, to see. Still didn't show up. No response from Apple on bug report, of course.

Sep 9, 2011 8:00 AM

Reply Helpful

Sep 9, 2011 8:38 AM in response to artboygrafix In response to artboygrafix

artboygrafix wrote:


10.7.1, Apple Mail (all current), multiple POP and IMAP accts checked, no paper clips in Sent. Tried, for fun, to moving sent mail with attachments (and no clip) into another mailbox, like Inbox, to see.


Still didn't show up. No response from Apple on bug report, of course.




I did get a follow up from the bug report on Date: August 15, 2011


From the Developer Support- it is a known issue.

Sep 9, 2011 8:38 AM

Reply Helpful

Apr 12, 2012 7:29 PM in response to Ashka In response to Ashka

Got signed out.

The sent paperclip shows up fine if the mail is put into folders on your Mac or if the reply is opened.


You can always change over to the old classic Layout > Mail prefs > Viewing.

Just left click the bar and select the columns you want including attachments..

Apr 12, 2012 7:29 PM

Reply Helpful

Apr 12, 2012 7:44 PM in response to Ashka In response to Ashka

I have 0SX 10.7.3, I'm in classic layout mode because that's what I prefer. After switch to Lion, the paperclip for sent emails simply does not appear. Perhaps it does for you, but it does not for me, and apparently many others. If we could figure out why it is a problem for some but not for others, maybe a fix could be worked out.


If I open the email, then I can see the attachment, but this isn't the problem. The problem is that the paperclip doesn't show up in the paperclip column for any sent email, so when I'm trying to find sent emails with attachments, I can't identify those with attachments.


It is also odd, because the clip DOES appear for incoming mails, just not sent mails.It's a real pain, and clearly many people have this problem and Apple has not solved it.

Apr 12, 2012 7:44 PM

Reply Helpful

Apr 13, 2012 5:48 AM in response to maestrodave In response to maestrodave

Thunderbird works fine, I've used it off and on, no complaints at all - message rendering is good, but I've noticed one or two odd things which may have more to do with the message, not the mail app. If you're an iPhone user, I dont know how well it integrates, but it's the best desktop mail option if you want to ditch Apple Mail, IMO. I can't believe how annoying it is not to have the paperclip for attachments in sent mail in Apple Mail, but it really is bothersome. Has anyone found a plug-in for Mail that fixes this? Clearly Apple has other fish to fry.

Apr 13, 2012 5:48 AM

Reply Helpful

Apr 16, 2012 2:40 PM in response to kkd78 In response to kkd78

Solved - I have the same problem and found a solution to resurrect the clip icons in the sent folder.

I read it on another Apple post and revised it slightly to work a bit easier. See below :


[ Note : For the original solution click on the link and go down to oakmontoz's solution. https://discussions.apple.com/thread/3308790?start=0&tstart=0 ]


1 - Create a rule in the Mail Preferences pane

2 - Call it "Get My Paperclip Icons Back!"

3 - Set conditions as below :

A - If ALL of the following conditions are met :

B - From Ends With [Your email address here] (you can do this for multiple too]

C - Any Attachment Name Contain "." [with the quotations around the dot]

Perform the following actions :

D - Mark as Read [which really makes no impact on how its viewed]


Click Ok. When message "Do you want to apply your rules to messages in selected mailboxes?" I chose "Dont Apply". [But you can click "Apply" if you are in the "Sent Folder"


Then go to your sent folder, Select your messages [recent/all], and right click "Apply Rules" or from the menu Message -> Apply Rules.


Voilla! Paperclip icons are back. Plus "Mark as Read" did no harm to your already colored/flagged sent emails.


Hope this helps!


Note : If you could make this rule apply automatically when you send mail, well... until Apple fixes this problem, this would be the seamless solution. Until then, you would have to do it manually.

Apr 16, 2012 2:40 PM

Reply Helpful (1)

Apr 16, 2012 3:20 PM in response to iBiM In response to iBiM

YES!!!! This works! It is so great to have the clips back. It's a bit of a pain to have to do this for all the different mailboxes I have, but it is so worth it. Thanks to you and to the original poster - surprising how something so small can make such a big difference. I wonder how the first poster figured out this unusual solution.

Apr 16, 2012 3:20 PM

Reply Helpful
User profile for user: kkd78

Question: Mail no longer shows attachments in paper clip column