Skip navigation

SystemUIServer and LoginWindow Using a Ton of Memory

6438 Views 20 Replies Latest reply: Feb 24, 2014 10:24 AM by jpostelnek RSS
1 2 Previous Next
willthethrill01 Calculating status...
Currently Being Moderated
Aug 8, 2011 11:38 AM

My SystemUIServer and LoginWindow processes are using a lot of memory like 300MB of memory and I have a feeling this is what is causing my computer to run slowly and freeze after it's been on for a while. It seems to be some kind of Memory leak since the memory usage gets worse over time.  I can quit the SystemUIServer service which is relaunched since it's a launchd and will gradually go back to eating up memory.

 

In addition to this pretty much anything you try to do in the System Preferences freezes which means I can't even create a new login to see if it's something corrupted in the user files.

 

I'm running OS X Lion which has been a pain since nothing has worked right since I installed it.

iMac6,1 2.16 GHz Intel Core 2 Duo, Mac OS X (10.6.4)
  • spandrelf Calculating status...

    DItto to EACH of the above, which suggests this is not a fluke of will's machine. I'm also a recent Lion upgrader. My Activity Monitor stats at this moment include:

     

    420MB for loginwindow process

    400MB for SystemUIServer process

     

    And ALSO the System Preferences here are going unresponsive (needs to be force quit), especially Users & Groups -- in my case, right after authentication, every time (though it wasn't always so after Lion upgrade -- I wish I could retrace what might have triggered the problem, but it happened after I added a second active account).

     

    Lots of spinning beach balls. Any explanations or further correlations? I'm on a 2008 2.4GHz iMac...

  • spandrelf Level 1 Level 1 (0 points)

    My general sluggishness now seems to have been cleared up by scouring the HD library (not the user one, but the root-level one) for old-ish (pre-Lion) LaunchDaemons, LaunchAgents, and StartupItems -- surely brought in by the Migration Assistant when I imported a second user recently. I also repaired permissions.

     

    So long as I'm on a fresh restart and have not touched Users & Groups preferences, all seems ok...

     

    Nevertheless, authenticateing at Users & Groups still causes this RAM-bloating unresponsive hang (involving the 3 processes mentioned above),  which eventually locks up all my memory even after I force-quit System Preferences. So, I'm giving up on trying to make changes in Users & Groups until I hear something further about this buggy behavior.

  • spandrelf Level 1 Level 1 (0 points)

    I agree the basic problem remains unsolved. At one point after walking away from the machine for a while I came back to 500MB + "Real Mem" figures for both SystemUIServer (519 MB) and loginwindow (532MB). Leaking indeed.

     

    AND (alas) the leak begins even if I *don't* invoke System Preferences at all, contrary to my hope. Yet the leak doesn't start right on boot or even on login (though logging out seems to serve as a temporary fix). It starts at some point when I'm going about my business. So I've now got Activity Monitor showing Memory usage in its dock icon constantly, hoping to isolate what's triggering it.

     

    In removing old stuff that had gotten migrated in up to root level: I just looked for 3rd-party stuff that I recognized as pre-Lion (VMWare Fusion has stuff in there that I noticed was still making tracks in the console; so did Tivoli Storage Manager and a few other utilities I had installed over the years); it helped that I could see the Migration Assistant-modified timestamp on everything that was sucked in from the second (older, very customized) user account that I had pulled over last week, since I'm pretty sure that's where the offending element (if any) came from.

     

    Anyway, as much as *something* might have been achieved by cleaning out pre-Lion stuff, something else that remains is either corrupted or buggy.

     

    If we're the only two with this problem, we should compare System Profiler notes and see whether there's some third-party app, utility, or account configuration that's shared across our two machines...

  • spandrelf Level 1 Level 1 (0 points)

    In case anyone else is troubleshooting this: I have set up Activity Monitor to launch on login, using the Dock icon to show its RAM piechart graphic (nice feature!). So, I can see the used RAM start to bloat immediately when the leak starts, and I know I have just a couple responsive minutes left to close my work down and restart. The good news is that I can run my basic productivity apps (Word, FileMaker, Things, Chrome, launchbar, Evernote) for hours without triggering the problem. I've watched loginwindow and SystemUIServer hover mostly at 16MB-18MB and behave themselves... until something sets them off.

     

    I've identified two consistent triggers since I started watching for them -- besides the System Preferences account-related operations noted by OP (willthethrill) above: SplashID Safe 6 (launching it reliably causes loginwindow and SystemUIServer to start gobbling, and not to stop, even if I quit it); and certain video operations (such as using Quick Look on a .MOV file or having a YouTube video come up on Chrome). Of course, the actual applications at issue may well be red herrings (SplashID tech support hasn't heard of my problem), but it's a start.

     

    I'll report back if the problem somehow becomes clearer in its outlines... Meanwhile, my current suspicion is that using Lion in combination with Migration Assistant (from an originally pre-Lion account with lots of complexity, much of which I've since tried to purge) may have set up this problem.

  • kisuke3 Level 3 Level 3 (910 points)

    is this happening in safe mode?why its happening is most likely you have 3rd party apps that are not compatible with Lion anymore. Which is explained here

     

    http://support.apple.com/kb/HT4849

  • spandrelf Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 29, 2011 12:28 PM (in response to kisuke3)

    Thanks Kisuke. When I want to throw more time at this, I'll try hanging out in safe-boot mode; as it is, I'm trying to get *some* work done at the moment.

     

    I'm of course aware not all apps are compatible with Lion, and most developers have released updates. But merely "having" pre-Lion apps (the app files by themselves) should not be a problem. They're just files.

     

    *Using* incompatible apps (or having the system load faceless stuff installed by old apps) would be a problem, sure, but this leak happens reliably when I run *System Preferences* or *Quicktime*. In other words, there's no 3rd-party app I'm launching, at the user level, that explains this problem. I've also purged all sorts of third-party-app-related stuff from my library (both root and user Library directories) as reported above, and spent considerable time examining Console logs and Activity Monitor screens looking for further clues and pointers.

     

    Of course it's likely that *something* ported via Migration Assistant (from my old account that has been in use since, say, Tiger) could account for this problem, but it's nothing obvious. That's why I'm contributing to this thread. Many people, besides myself, trust Migration Assistant's offer to "help" set up an account. Although I will avoid it next time (and may give up and re-migrate manually), perhaps discussion here can help someone else isolate the particular thing that causes this leak.

  • persefer Calculating status...

    My macbook pro has the same problem. I upgraded to Lion and userwindow and systemuiserver tasks are using 800+1gb of my ram in a few minutes later I open my computer. Every app is freezing than. This mac is new but also its cdrom is not working. I want make a format and clean install but I cant I will send it to a service tomorrow

  • Cyberpundit Level 1 Level 1 (5 points)

    That link is utterly useless.

     

    So, how do we recognize which older apps are outdated? The memory hogs are ONLY the SystemUI and the LoginWindow thingies. THey're top of activity monitor, and consuming in total 4GB of my 8GB memory. All other apps -- Chrome, SnagIt, Skype, Word, Powerpoint, Terminal -- their consumption varies depending on time, which is hard to pinpoint as being the cause of the memory bloat.

     

    What's the fix?

     

    I deleted com.apple.longinwindow.plist as suggested elsewhere, then restarted machine, but no dice. It still does the same.

  • Cyberpundit Level 1 Level 1 (5 points)

    Is there an fix to this problem at all?

     

    There are gazillions of threads on this subject and not a single useful post on Apple Support website.

     

    Following are the suggestions in these threads, NONE of which are helping me:

     

    1. Delete com.apple.loginwindow.plist

    2. Delete com.apple.loginitems.plist

    3. Disk Repair

    4. Reboot and repair permissions + repair disk

     

    I've done all of the above. The computer is still moving like molasses in cement shoes. 

     

    I don't have the time for a "clean install" and all that nonsense. Apple promised me an "upgrade" with a software that I *paid* for. It's this software's bloody job to do what I paid for it to do. If it's not doing its job, I need my money back. I was perfectly happy with Snow Leopard -- the "additions" in OSX Lion are as pathetic as with iPhone "4GS". 

     

    Welcome any thoughts from people who've been in the same situation, and hopefully SOLVED the problem. Thanks!

  • bk59 Calculating status...

    It may be caused by permission. You may use Disk Utility to verify and repair it, then erase all free space.

    After that, reboot lion, and reinstall lion again. Everything, includes system preferences should get normal again.

    Good luck.

     

     

    n.b.  this is my actual situation and solution.

  • ermilano Calculating status...
    Currently Being Moderated
    Feb 7, 2012 1:54 PM (in response to bk59)

    Thank you bk!!

    I searched high and low for a remedy to this problem and you are the only one with a solution.

    Reinstalled a few days ago and so far everything seems to be back to normal.

  • h p Calculating status...

    Having the same problem here. Since a few days.

    The only thing i can recall is re-installing Flash Player (version 11.1)

     

    I can only trigger this problem, if i go to a YouTube page and start a video.

     

    Question: what are random, normal sizes for both the processes "SystemUIServer" and "loginwindow"?

    Answer: (forgot my mac mini also running on Lion): resp. 32MB and 16MB

     

    Mine are about 350MB's, just after a clean boot and starting a game of a Youtube video....

  • phedre Calculating status...

    Confirming: this is related to flash, at least on my machine. Mac OSX Lion, 2.8GHz i7, 8GB RAM.

     

    I started activity monitor on login as spandrelf did. I then monitored it closely as I started various programs: SQL Developer, Chrome, Adium, Console, Terminal, Eclipse, none of these triggered it. I watched for about an hour, then I went to youtube and clicked on a video. I have flashblock installed so nothing played automatically. Just loading the youtube page went fine. Then I clicked the play button - instantly the size of both loginwindow and systemuiserver began to increase.

     

    I've seen them get as high as 3GB each. The only solution is to logout and log back in, which resets them to ~17-30mb.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.