Previous 1 2 3 4 5 Next 111 Replies Latest reply: Dec 16, 2014 6:07 PM by Foremost authority Go to original post
  • Sebast1aan Level 1 Level 1 (35 points)

    Also, I created another new admin account and tried to unlock the system preferences with that, but no luck. It seems that only the root account works.

  • Sebast1aan Level 1 Level 1 (35 points)

    Did some more testing and to recap:

     

    • It only works with root. I created a new admin but the new admin cannot unlock either, not when the new admin is logged in and not when logged in as another trying to authenticate with the new admin.
    • I can lock the Directory Utility and then unlock as admin, so for unlocking the Directory Utility I don't need root. Isn't that super weird?
    • Cannot install software that needs admin priveleges unless I specify the root account.
  • Sebast1aan Level 1 Level 1 (35 points)

    Ok, so the GUI is not using sudo (which I didn't think it was), but I finally found what is managing the GUI security, which is the Authorization Services API

  • flaviorodrigo Level 1 Level 1 (0 points)

    Ok, not sure if someone on this thread is testing 10.7.3. Its release notes says it`s dealing with SmartCards issues. I tried the following updates:

     

    10.7.3 11D46: the problem stopped happening and I could insert CAC token and unlock system prefs without any issues. Then...

     

    10.7.3 11D48: everything went back again... no unlock possible.

     

    10.7.3 11D50: same thing, all broken.

     

     

    If the final 10.7.3 won't solve it, I think I will have to timemachine it back to it as it's not possible to reinstall a previous version of the updates.

  • Dagwood Level 1 Level 1 (0 points)

    Installed 10.7.3 Combo Update and the Preference Pane are still unable to be unlocked after using my CAC card in Safari.

  • flaviorodrigo Level 1 Level 1 (0 points)

    Same here, combo update 10.7.3 made no difference.

  • ttoomema Level 1 Level 1 (0 points)

    I am using Estonian ID card and its software. Used to have same conflicts while using ID card, but after updating OSX to 10.7.3 issues were resolved.

     

    Plugged SCR, unplugged, plugged again and inserted smart card (Estonian ID card) into reader. Opened Safari and authenticated myself to some webpage - System Preferences panel worked as it had to. In other words I was able to unlock/lock/unlock/../unlock it as many times as I wanted.

     

    (makes me curious. how did problems find a solution in my OSX and same time you guys are telling that update to 10.7.3 made no difference)

  • ttoomema Level 1 Level 1 (0 points)

    My bad - had SP running on backround while was doing previously mentioned operatsions.

     

    Confirmed: 10.7.3 did not make any difference.

  • woomy Level 1 Level 1 (0 points)

    im having the same problem have u worked out how to fix it, it seems like that hard drive is locked as well as i am unable to reinstall mac os lion

  • Sebast1aan Level 1 Level 1 (35 points)

    Ok, I ended up reinstalling Lion, which solved it. Crap I know, but works for now.

  • woomy Level 1 Level 1 (0 points)

    how did u reinstall lion coz i cant even do that:(

  • flaviorodrigo Level 1 Level 1 (0 points)

    Sebastlann, when you reinstall, did you apply the CAC drivers after aplying the 10.7.3 update or before ?

  • stephen.bradley Level 1 Level 1 (20 points)

    For everyone who's thinking about re-installing Lion for this problem...let me just add that I have completely wiped and restored Lion (for another issue that I created myself) and the problem was not fixed.

     

    Like some posters, I sometimes use a CAC on my computer, but that doesn't SEEM to be the problem. I also use Thursby's PKCard software, which another poster mentioned, and I'm going to test and see if that's the issue, but I suspect not.

     

    For me, the problem happens only when the computer wakes from sleep. From a clean boot, I can always unlock my preferences. However, if the computer sleeps (ex, closing the lid), the preference panes are locked. I'm not sure this happens 100% of the time, but I'm about to find out.

     

    Anyway, don't rush to reinstall, it's not a reliable fix.

  • jaak Level 1 Level 1 (0 points)

    Had same issue. For me just plain restart helped, at least for now. I have the latest update of 10.7.3, and I do use sometimes smart card.

  • stephen.bradley Level 1 Level 1 (20 points)

    Well, after a lot of fooling around with different things, I take back what I said previously. The problem most definitely IS the CAC.

     

    When Apple removed CAC support in 10.7, it looks like they did it by just removing the libraries needed to access the CAC, but left the operating system hooks in place. Prior to 10.7, if you had fully enabed CAC on your system, you'd use your CAC/pin to do things like unlock system preferences. Well, the code for that is still there, they just removed CAC support.

     

    So if you install third-party CAC support - Thursby PKCard, CAC_KEY, or any of those other things, or if you still have the libraries from Snow Leopard, once you put in and access your CAC (by using it on a website or signing an email) the system wants to use it to authenticate other things too (like system prefs). Unfortunately those third party solutions don't support the system hooks, so it doesn't work.

     

    What's worked for me recently is firing up activity monitor and force-quitting securityd and the processes that my CAC software spawns (I use cac-key). Once I do that, I'm usually able to get my prefs unlocked without rebooting.

     

    Buying and installing something like Thursby's AdmitMac PKI should solve this, since it's designed to support the entire system from login through active directory integration. But it's a bit pricey at $200....

Previous 1 2 3 4 5 Next