Skip navigation

Can't Unlock Preference Panes

43800 Views 106 Replies Latest reply: Jan 28, 2014 8:35 AM by neptune2000 RSS
  • nmt1900 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 4, 2012 5:09 AM (in response to Sean L.)

    I cannot tell, what is going on with Lion as I already upgraded to Mountain Lion, but the problem is still there.

     

    'sudo killall -9 securityd' actually works for this perticular problem, but here's actually one quite unwanted side-effect - it is impossible to eject any removable devices after that from Finder - only way to do it is using hdiutil from command line using sudo. In addition to that using Directory Utility is also not possible in normal way - when Directory Editor is opened by admin user i.e. myself, then user is automatisally authenticated as root, but after this killing of securityd it is impossible to authenticate as root if root user is not enabled i.e. normal operation is not possible.

     

    One more thing caught my eye as I use "Graphite" theme on my user interface (i.e. not the default "Blue" theme) - if these unlock authentication dialogs where appearing with "Graphite" theme before, then after killing securityd they were appearing in "Blue" theme - as if they were launched in context of different user than myself...

     

    This all means, that we can cure the initial problem by killing securityd, but then we are causing new problem, which yet again is needing its' own cure - something else than restart. Maybe enabling the root user might help?

     

    P.S. As someone stated before - I am also using Estonian ID card and the problem appears every time after using it...

  • nmt1900 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 4, 2012 11:24 AM (in response to nmt1900)

    One more observation - this is happening after using ID card with Safari. If card is used in Firefox, then problem does not occur.

  • nmt1900 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 6, 2012 12:32 AM (in response to nmt1900)

    ****! Now it seems after sleep that unlocking "goes south" even when using it with Firefox...

  • stephen.bradley Level 1 Level 1 (20 points)
    Currently Being Moderated
    Aug 6, 2012 5:45 AM (in response to nmt1900)

    I'm curious what middleware you're using to enable your CAC with?

     

    I'm using the PKCard program from Thursby, and I'm still experiencing the problem under ML. Thursby acknowledges the problem, but blames Apple and offers no solution except a reboot. I had rather expected this to be fixed in ML.

     

    I'm going to be giving SCCI from SCB Solutions a try as middleware, and see if it has the same problem or not.

  • stephen.bradley Level 1 Level 1 (20 points)
    Currently Being Moderated
    Aug 6, 2012 7:22 AM (in response to nmt1900)

    I haven't been able to test Firefox since Pkcard doesn't support it, but using PKcard and Chrome, the problem does not seem to occur, at least so far. I've been able to log into CAC sites, close the browser, and still unlock preferences.

  • nmt1900 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 6, 2012 8:55 AM (in response to stephen.bradley)

    It is the software bundle created for this very same Estonian ID card I am using.

     

    http://code.google.com/p/esteid/

     

    However there is another version supported by card issuer itself, but that one has it's own serious usability issues (albeit being newer version than 'esteid') -> https://installer.id.ee/?lang=eng

     

    I will try out this other one and report here.

  • nmt1900 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 6, 2012 11:49 AM (in response to nmt1900)

    Now both are tried out and both are giving the same result - unlocking of preference panes is not possible after using.

  • nmt1900 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 6, 2012 12:54 PM (in response to Sean L.)

    Now I found this link, which leads here to our thread - http://id.ee/index.php?id=34456

     

    It is about this problem and states quite bluntly, that whole thing is a bug in OS X.

  • flaviorodrigo Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 6, 2012 1:26 PM (in response to nmt1900)

    Will Apple ever going to assume it as a known bug ? A simple "we are aware and will fix that on the next 12 months" would really help the enterprise users.

  • nmt1900 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 6, 2012 2:09 PM (in response to flaviorodrigo)

    It would be possible to live with, if it had a workaround other than restarting. Unfortunately killing securityd is not the workaround because of already described side-effects.

     

    Being slightly offtopic - this kind of reminds the problem with Lion when my mac just did not sleep - now after upgrading this thing "magically" got resolved. However automatic brightness control got as unusable, as it was on Snow Leopard (i.e. auto adjustments are too agressive) - when it was perfect on Lion.



  • jaak Calculating status...
    Currently Being Moderated
    Aug 6, 2012 11:55 PM (in response to nmt1900)

    Please file a bug with Apple, this rises probability that it will be addressed.

     

    Also, please do not post offtopic things to unreleated threads and try to combine individual sentences to one post, everyone is really annoyed to get 10 different message notifications about same thing.

  • tissuebox Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 7, 2012 4:49 AM (in response to nmt1900)

    Yeah, this issue is totally ********. I hope Apple gets to it quickly, thanks for looking into it with such depth.

  • stephen.bradley Level 1 Level 1 (20 points)
    Currently Being Moderated
    Aug 7, 2012 5:21 AM (in response to nmt1900)

    For what it's worth, this is already filed as a bug. I filed it during the 10.8 appleseed testing, and I'll re-file in the 10.7.5 appleseed system too. and have the acknowledgement from Apple (automated). Whether or not they'll devote resources to fixing it is another matter.

     

    I'm going to keep looking for a workaround that's more usable than killing securityd; my guess is that there's a way of making it forget about the token authentication (card) without having to kill the process and screw up other things. If I find anything interesting, I'll reply.

  • Raymond Dishman Calculating status...
    Currently Being Moderated
    Aug 14, 2012 3:57 AM (in response to stephen.bradley)

    Stephen:

     

    After upgrading to the new rMBP with 10.8, I noticed this same issue for the first time.  My issue seemed to appear after unplugging my CAC reader, but could occur by simply removing the CAC.

     

    Regardless, please know that I and others are most interested in what you discover, so please do not give up this effort.

     

    R/

    RD

  • stephen.bradley Level 1 Level 1 (20 points)
    Currently Being Moderated
    Aug 18, 2012 7:12 AM (in response to Raymond Dishman)

    So to everyone who's posted with this annoying problem, I just want to say that it appears to be fixed in an upcoming release.

     

    Without going into any further detais about the release itself, so as not to incur the wrath of Apple, I submitted this as a bug to the original 10.8 beta, and to the beta of an upcoming build. A recent build release seems to have fixed it.

     

    I am still using Thursby pkard as my middleware (software to read the CAC), and I can't verify that other middleware products won't continue to have problems. But with pkard at least, I can log into CAC websites, or use my CAC to sign email, and my preference panes can still be locked and unlocked without any problem.

     

    I would be interested in hearing back from anyone who still has a problem after the 10.8.1 release, just to see if the problem is fixed across all middleware. It should be, as the problem was in the OS.

1 ... 3 4 5 6 7 8 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (4)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.