Previous 1 4 5 6 7 8 Next 111 Replies Latest reply: Dec 16, 2014 6:07 PM by Foremost authority Go to original post
  • nmt1900 Level 1 Level 1 (0 points)

    Yes it seems to work with the Estonian ID card, but...


    in addition to need for restarting applications using Keychain there's some more - it looks like Finder has to be relaunched for being able to mount external drives and most unfortunately - drives still cannot be ejected as with plain killing securityd. So it looks like side-effects are still there. One more restart after 26 days uptime...


    This is using 10.8.2...

  • iCerberus Level 1 Level 1 (0 points)

    Ok, spent some more time on this.  So far I haven't found any issues with this, so please let me know if any of you find something.


    got to /etc and make a backup of "authorization"

    Edit authorization (you'll need to do this as root)

    find the <key>system.login.console</key>

    under the mechanisms array add


    find the <key>authenticate</key>

    under the mechanisms array add


    save the file


    next add your reader and card.

    open terminal and type:

    sc_auth hash


    You'll see a line  that looks like this:

    01C2F20D8964BE7701B57B63B0A1795B8F2604C1 Identity Private Key


    use the key from the output and type the following using your current username in the "myuser" spot

    sudo sc_auth accept -u myuser -h 01C2F20D8964BE7701B57B63B0A1795B8F2604C1




    I'm hoping I got the steps correct, as I tried multiple edits on the authorization file, and a few reboots before I go to what appears to be a working setup.  These are the steps I used after restoring the authorization file from backup and trying again.  I did a reboot before testing anything as one of my initial tests appeared to work correctly until I rebooted, at which time nothing worked anymore.


    I have done multiple open/close, lock/unluck of System Preferences both with CAC in and out over the last few days, no reboot, multiple sleep/wake cycles, and it seems to always function.  The only thing I have noticed is that  authentications when CAC is inserted (Sys Pref, return from sleep, possibly others) is a bit slower before the password dialog box pops up than when CAC is removed.... small price to pay for not needing a reboot just to change Prefs after using my CAC.


    Let me know if you experience something out of the ordinary using this setup.



    -- OSX 10.7.5, MacOSforge Smarcard Services 2.0.b2  --




    After 3 days of testing, and then posting, I just pulled my CAC reader and my Sys Prefs are locked up.  It could have something to do with the fact that I pulled the reader with the card still in it, instead of pulling my card first like I always do.  Will do further testing on this to see if it's the case.

  • tjtrent Level 1 Level 1 (0 points)

    I only have this issue on one of my MBPs and both run ML.  In fact, the Thursby PKard software works marvelously on my MBP 13 in.  In truth, my MBP 17 in ran the software fine until I did a complete wipe and reload a few weeks ago.


    This is strange.

  • tjtrent Level 1 Level 1 (0 points)

    Thanks, I am having the issue sporadically and not on all of my MACs.  In fact, it only affects one of them.  The commands fixed the situation.  Thanks.

  • Okinrav Level 1 Level 1 (0 points)

    Havn't tried any solutions in this thread yet, but I want to report, that I have the same problem on OS 10.8.3 using SafeNet Authentication Client + Aladdin eToken.


    I use it often to authenticate to my office remotely. This problem is a bit annoying.

  • Okinrav Level 1 Level 1 (0 points)



    Thanks for the link and command line. It did work for me.


    open terminal and type:

    sudo launchctl unload -w /System/Library/LaunchDaemons/

    sudo launchctl load -w /System/Library/LaunchDaemons/


    Using OS 10.8.3, SafeNet Authentication Client + Aladding eToken

  • Stefan Bracke Level 1 Level 1 (5 points)

    Hi all,


    two things to do or check:

    - Open your Keychain Access application and do a "Keychain First Aid". This might solve some issues.

    - Go into your terminal and type "sudo pkill -HUP securityd" (sort of the same as okinrav posted)


    This problem might be caused by a Smart Card Reader or a keychain related problem.


    Some people have the standard answer "Reinstall your system", but that's only helpfull if your files are corrupted due to disk failure or a rougue application.


    Have fun!


    Stefan Bracke

  • nmt1900 Level 1 Level 1 (0 points)

    Keychain First Aid does not find any errors or problems

  • ademolafromadamawa Level 1 Level 1 (0 points)

    Please how do i get this file:~/Library/Preferences/" so i cant delete it. I have a similar problem, am hoping this will work but i cant even find that file

  • J0nB0t Level 1 Level 1 (0 points)

    I had this problem.


    MBP Retina,  10.8.2


    Lock in network settings was unexpectedly closed and just flashed when clicked. Couldn't change anything.


    I disconnected my HDMI-connected monitor and it resolved instantly.


    I reconnected HDMI in about 10 seconds and the lock was not only still 'clickable' but actually open instead of locked. Go figure.


    This is the first HDMI-related (could be) problem I've had with a Retina MBP. My old non-Retina had conflicts and flakiness with HDMI and many other system functions.




  • nmt1900 Level 1 Level 1 (0 points)

    Was it two years or so?


    "Addresses an issue that prevented a smart card from unlocking preference panes in System Preferences"


    Now we have exactly this statement in OS X 10.8.5 changelog...



    Well... better late than never...

  • wintersnow Level 1 Level 1 (0 points)

    I read and try a lot of suggestions. Nothing to do. I have added a new accompt. Nothing to do. And by hazard when I clicked on padlock I put the user name of the orginal accompt and its PW.... and it was working !?! I could boot on the original accompt and open the padlock with the second user name and it PW. Of course I am to tired to figure  why it' working.


    MBP early 2008, 15 '' 10.7.5 (6 months ago), 500WD Black

  • nmt1900 Level 1 Level 1 (0 points)

    Million $ question - do You have 10.8.5?

  • wintersnow Level 1 Level 1 (0 points)

    No 10.7.5

  • MAC USER1 Level 1 Level 1 (0 points)

    Enter this into terminal:

         defaults write NSGlobalDomain NSUseLeopardWindowValues YES

         defaults write NSUseLeopardWindowValues YES

         defaults write disable-shadow -bool false

         killall SystemUIServer

Previous 1 4 5 6 7 8 Next