Previous 1 2 3 Next 122 Replies Latest reply: Jan 30, 2016 10:55 PM by annie.wylin
aledco Level 1 (0 points)

Hi all, just wondering if anyone else has had this problem. I know there are dozens of posts about SD cards not working with MacBook pros, but mine seems to have started when I installed the latest Lion update.


I have a high-end 13" early 2011 MBP and the cards I'm having trouble with are all Sandisk 4GB SDHC. Two are 'Extreme III's" and one is an Extreme II. The card reader is showing up in System Profiler, and a really old 2GB Sandisk card gets read fine, so there doesn't seem to be anything wrong with the MBP hardware.


Similarly, I can read the cards fine via a USB adapter, so it's not the cards that are causing the problem.


I had successfully imported photos from the cards before upgrading to Lion, and also before installing the 10.7.1 update. So, it looks like the problem may be linked with the update, but this is purely an educated guess.


I've tried resetting the SMC to no avail.


Has anyone else experienced something like this?

MacBook Pro, Mac OS X (10.7), 13" 2011
  • tjk Level 7 (24,220 points)

    Hi a,


    You may want to follow this thread:


    And look over to the right of this where it says "More Like This" >>>>>

  • aledco Level 1 (0 points)

    Hi, thanks for the link. I did search through the forums before posting. My problem is a little different to these though, since it seems to have been caused by the 10.7.1 Lion update.


    If I get it solved I will post the solution here.

  • tjk Level 7 (24,220 points)

    aledco wrote:


    Hi, thanks for the link. I did search through the forums before posting. My problem is a little different to these though, since it seems to have been caused by the 10.7.1 Lion update.


    If I get it solved I will post the solution here.


    That would be great. Thanks a.

  • Baron Sekiya Level 1 (20 points)

    I've got the same problem. I've got a late 2010 MacBook Pro unibody running Mac OS 10.7.1 on it. I installed the 10.7.1 updated most likely on 8/17/11 the day after it was released by Apple. Since then I was able to read SDHC cards as I shot a number of photos and videos to my cards and they worked fine.


    I'm not sure what has changed since then, it wasn't as simple as the 10.7.1 update then it didn't work. This is the problem I'm having below, just started to experience this on 9/2/11. I tested with two 32GB SDHC cards, one 16GB SDHC card and one 2GB SD card. All cards were manufactured by Transcend.



    * SDHC cards (16GB and 32GB) will not mount and isn't recognized by the MBP via the built-in SD card slot


    * SDHC cards (16GB and 32GB) will not mount and isn't recognized by the MBP via SanDisk 2.0 card reader connected via a short USB cable.


    * If I put any SDHC card into a SanDisk USB 2.0 reader that is connected to my USB hub (I gave it a try in case there was a power problem with the MBP USB system) the card is not recognized either.


    * Even Disk Utility will not see the card when inserted via built-in card slot or a reader.



    * SD cards (2GB) mount fine when inserted either in the built-in SD card slot or via my SanDisk USB 2.0 reader.


    * If I leave the SDHC card in my camera (Canon 60D) and connect the camera to my MBP via USB I can import the images via Aperture.


    * If I put the SDHC card into the memory card slot reader of my HP inkjet printer (it has multiple card slots for different types) the card will mount normally like it is supposed to via the two failed methods above.


    I'm also sending this info to Apple but wanted to post here since there are three inconvenient work-arounds.

  • Baron Sekiya Level 1 (20 points)

    Update: Although all the failures above still occur I can get the SDHC card to mount via a super cheap freebie USB SD card reader plugged directly into a USB port. This is one of those readers that is sized like five sticks of gum stacked on each other.


    This same card that I can mount via the freebie reader still will not mount via the built-in reader or via the SanDisk card readers.


    I should also note that I had done both formats and low-level formats on all the cards in the camera and that didn't help anything before doing the above tests.

  • Baron Sekiya Level 1 (20 points)

    Yet another update: I got the SDHC card to be recognized ONCE today. It showed-up on the desktop and I could access it. Then I ejected it, put it back in and it wasn't able to be recognized.


    Note that two of my 32GB SDHC cards were bootable because I had Magic Lantern installed. But the 16GB SDHC card was not bootable. Also I low-level formatted the 32GB SDHC cards in the camera and they still would not read-up in the SD card slot of the MacBook Pro. Restarting the computer did not help.

  • bradenfromcrested butte Level 1 (0 points)

    I have the same problem with a fujifilm 8GB  SDHC.

  • willmow Level 1 (0 points)

    The SD slot in my MPB is also intermittent. However, I've found that if I insert my (Kingston 1GB) card all the way then pull out it a few millimetres, it mounts immediately. I'm sure that never used to be the case. I'm now running Lion, but my problem appears to be mechanical rather than software related....

  • ibejohn818 Level 1 (0 points)

    This is an issue with dust in the card reader.


    Use a can of air, or close your eyes and blow into the card reader.


    You should be all good after that ;-)

  • willywonty Level 1 (0 points)

    Dust in reader? Quite possibly, though reading is intermittent even after blowing Thanks anyway.

  • pfbird Level 1 (0 points)

    Same problem here. I upgraded my mid-2010 MacBook Pro around Thanksgiving to the Lion OS. Tried to download SD cards from two different cameras -- one with 8GB and the other with 4GB. Neither was recognized by the laptop. It's nice to know that a card reader will work, but this is still a big pain compared with simply inserting the card into the slot. Apple needs to fix this.

  • Baron Sekiya Level 1 (20 points)

    Took my MBP to the Apple Store yesterday to investigate the SD card slot. They said the logic board would need to be replaced. It's not dust in the slot, it's not a software issue.


    I can get the SD slot to read memory cards but the cards appear to the MBP to be write-protected. USB and FireWire card readers work fine.


    Wish Apple didn't go so cheap with the SD card reader being on the USB bus, it's so **** slow. Couldn't they have put it on FireWire 800?


    Anyway, MBP will get sent to Apple to get the logic board replaced.

  • Supritha Level 1 (5 points)

    I had the same problem.. My MBP did not recognise my SDHC card after installing lion. It worked after installing an update. Goto Applications --> Utilities --> XQuartz and mac automatically asks for an update installation. Download and install the update. Your memory card slot should work fine now.

  • pfbird Level 1 (0 points)

    Supritha: I tried your solution, and it worked. I will say this one time: YOU ARE A GENIUS. No, I'll say it once more: You are a genius. Thank you.

Previous 1 2 3 Next