Previous 1 2 3 4 Next 51 Replies Latest reply: May 27, 2012 2:58 AM by rick7304 Go to original post
  • sparklellama Level 1 Level 1 (5 points)

    +1.  Same problem.  Just bumping the thread, and will go log a bug as well.

  • cheekyducky Level 1 Level 1 (0 points)

    +1 - iMac with 4 gig of RAM performing poorly b/c of printtool - also using roughly 50% of CPU.

  • Pletchman Level 1 Level 1 (0 points)

    Same here. I have a macbook pro with 8gb of RAM and that stupid printtools creeps up and consistently is using between 4-5gb of my valuable memory.


    Can someone explain exactly what this process does and if there is a way to permanently disable it until Apple gets their act together to fix this HUGE GLITCH!!!

  • pigin Level 1 Level 1 (0 points)

    +1 for me. +1 mb/second, 50,64 % of CP

  • BobHarris Level 6 Level 6 (16,495 points)

    Everyone posting +1, you need to do more than that if you want to get Apple's attendtion to this issue.  The more people that actually communicate with Apple, the higher a priority the issue will get.  This forum does not constitute communicating with Apple.  Rather try the following (everyone with a +1):




    Free ADC (Apple Developer Connection) account needed for BugReporter.

    Anyone can get a free account at:





  • shawn619 Level 1 Level 1 (0 points)

    Thats nice to post a link, but do you think all of us with this problem should have to submit an individual bug report for apple to be aware of this problem and notify us they are working on it.


    It seems pretty easy. It seems a lot of people are having this problem. I just noticed it the last day or so myself and came here looking for a solution.


    We shouldnt have to sign up for another account to submit bugreports. This isnt Windows.


    and I used your link which gave me an error with a dev email to send a report too.


    So much for that avenue.

  • John Strung Level 6 Level 6 (13,440 points)

    I suspect this may be a printer driver problem.  Deleting the files






    seems to stop the problem until the next time you try to print.


    Perhaps previous posters to this thread can chime in with the type of printer they were using so we can see if there is some commonality.


    I am trying to troubleshoot this for a third party and as soon as I find out what printer he was using, I will post back.

  • Arthur Busbey Level 1 Level 1 (65 points)

    I have two Samsung laser printers.

  • CertaintyManagement Level 1 Level 1 (0 points)

    I have a Samsung CLP-320 here! ...

  • indielux Level 1 Level 1 (0 points)

    I have Samsung Laser Printer CLX-3185FW



  • Arthur Busbey Level 1 Level 1 (65 points)

    Looks like we have been barking up the wrong tree. This needs to go to Samsung, not Apple.

  • danbethancourt Level 1 Level 1 (0 points)

    I've got two Samsung printers at the office too, and that's where I encounter the printtool memory leak. On my home Mac, with no printer, I don't encounter the printtool memory leak problem. So I think you may be correct, that the problem lies with Samsung's print drivers.

  • Pletchman Level 1 Level 1 (0 points)

    PROBLEM SOLVED (At least for me...)


    Hope this works for everyone because Apple has not been helpful at all. My misbehaving "printtool" would consistently be eating up over 50% of the processor and between 4-5GB of my 8GB available RAM on my macbook Pro.


    The solution for me was doing what someone recommended for a different problem and that was to repair the user permissions. I've done that and my printtool has remained in the very nice 4mb range now for four days. Here are the instruction on how to do this...


    In Lion, there is an additional Repair Permissions application utility hidden away. This tool is located inside boot Repair Utilities. Here’s how to access it.

    1. Restart Lion and hold down the Command and R keys.
    2. You will boot into the Repair Utilities screen. On top, in the Menu Bar click the Utilities item then select Terminal.
    3. In the Terminal window, type resetpassword and hit Return.
    4. The Password reset utility launches, but DO NOT RESET THE PASSWORD. Instead, click on the icon for your Mac’s hard drive at the top. From the drop-down below it, select the user account where you are having issues. NOTE: I reset them all as I figured it couldn't hurt.
    5. At the bottom of the window, you’ll see an area labeled ‘Reset Home Directory Permissions and ACLs’. Click the Reset button there.


    Hope this solution works for everyone else as it did for me. Good luck...


    P.S. I also have a Samsung (ML-1660) printer so perhaps that is part of the reason this happened. Regardless, it works now and I have a more permanent fix should it happen again.

  • aspik Level 1 Level 1 (10 points)

    I had this issue with Lion and Samsung CLX-3170.

    On a computer, that was using Snow Leopard and was upgraded to Lion. I.e. it had SL driver v2.0.


    I solved it by installing Lion drivers from Samsung v3.01.


    After driver installation it showed the driver version still the same (in Print & Scan Preferences pane > printer > Options & Supplies > Driver Version), I had to manually choose the newly installed driver by going to Driver tab, opening Print Using scroll box and selecting the driver once again by choosing Select Printer Software... and searching the driver in the driver list.


    Hope this helps.

  • John Strung Level 6 Level 6 (13,440 points)

    Definitely sounding like a Samsung driver problem. In the case of the person I am helping out, the printer was a Samsung CLP-325. I have asked him to try updating the driver to ver. 4.01 to see if that solves the problem. Will report back.