Previous 1 2 3 4 Next 51 Replies Latest reply: May 27, 2012 2:58 AM by rick7304 Go to original post
  • bobtea Level 1 Level 1

    Yep, Samsung CLP-310 here. That seemed to solve the issue! Thank you! It's a bit early to tell if it's solved for good, but it looks good for now.

     

    In summary, it seems the problem can be resolved by downloading the updated Samsung driver, installing, and manually re-selecting the driver in the Printer Setup driver section.

  • jacquesvz Level 1 Level 1

    Yes Samsung is the problem CLP-315, thanks for the help in getting my memory back!

    Anything related to patent issues ;-)

  • danbethancourt Level 1 Level 1

    Thanks, your solution was helpful and seems to have worked for me too. I downloaded the new drivers from Samsung for an ML-1865W, deleted the existing printer/drivers from System Preferences>Printers, and then added it again using the new drivers. Problem seems to be solved for now. Crossing my fingers.

  • indielux Level 1 Level 1

    Thanks for the help....

     

    updated Samsung Driver to 4.01 (was still somewher at 1.x),

    choose the driver from list in print preferences

    restarted

     

    no memory leak up to now

  • CertaintyManagement Level 1 Level 1

    Working for me too! ... Thanks guys!

  • dmac786 Level 1 Level 1

    The solution is, I think, easy. The printtool process is part of Smart Panel - I don't really know what Smart Panel is supposed to do, but printing works just fine without it. You can find the app in "\Library\Printers\Samsung\Smart Panel". Quit Smart Panel, uninstall it, be happy.

  • indielux Level 1 Level 1

    I have to report, that after updating drivers from Samsung Homepage, it seemed that everything was ok.

     

    But it isn't!

     

    I found my Mac today running slow with printtool using about 45% of CPU!!

     

    I think I'll give the other solution a try, namely uninstalling Smart Panel.

     

     

  • John Strung Level 6 Level 6

    Indie, did you remember not only to delete the old printer first, but when re-installing to expressly choose the new driver? Otherwise it will revert to the old driver by default. See Pletchman's post of Feb 14, 2012 10:45 AM earlier in this thread.

  • indielux Level 1 Level 1

    @John Strung

     

    I did not delete the old printer, but instead downloaded the new drver from Samsung (Print, Scan and Smart Panel). I did choose manually the new driver and it now shows driver version 4.01.

     

    What I did now:

    - right click in the window with all the printers and faxes installed : "reset printing system" (see Woodmeister50's link above)

    - downloaded the new Lion OS X print drivers over the "software update" panel (released yesterday)

    - reinstalled (by clicking the + sign in the "print and scan" panel) the Samsung Printer

    - the driver was chosen automatically

     

    For the moment, I don't use the "Smart Panel", so that all the Scans are done with the Lion interface.

     

    I haven't reinstalled the fax. It seems stable for the moment. Will report if the problem persists.

  • dmac786 Level 1 Level 1

    It doesn't matter whether you use Smart Panel - if it's installed, it will gobble RAM like a Pac-Man goblin.

  • bobtea Level 1 Level 1

    While the new drivers stabilized the memory usage to around 50mb or so, removing SPanel removed the printtool process entirely when not printing. Also, it got that useless icon off the menu bar. I like this solution!

     

    Furthermore, it looks like Apple just released a Software Update to automatically update the Samsung drivers, so this problem should be solved. Thanks for listening, Apple!

  • KenSW Level 1 Level 1

    Where are people finding 4.01 driver? I just checked Samsung site and the latest version I see is 3.01.

  • CertaintyManagement Level 1 Level 1

    Hi Ken ... I took the advice here and uninstalled the Smart Panel app and everything settled down.

     

    Hope this helps.

  • KenSW Level 1 Level 1

    I will try that. I thought that the 3.01 installation fixed it, but just saw that printtool is using CPU 45%, and memory is growing while I watch it on the activity monitor. Interestingly enough, I didn't print anything all day!!

     

    Thanks and I will post again after deleting Smart Panel.