Previous 1 2 3 4 5 6 Next 112 Replies Latest reply: May 1, 2015 10:17 AM by MKurly Go to original post
  • jlicea Level 1 (5 points)

    Yea I don't know how this simple fix was discovered but thank you, it worked for me as well.. unbelievable how something so simple can resolve something that was so frustrating.

  • monotune Level 1 (5 points)

    I have been having this problem since last night. Sometime this afternoon I could not even get 1/2 way through "Gathering information to send to iTunes" I keep stopping and restarting sometimes it gets 3/4 of the way through and sits idle. So I no longer get the error message because I can not get that far. I tried the Option trick people are not posting but no luck. I believe my other problem to be that my Library is very large. 45K+ Over half are iTunes purchased though. So I should still be able to use the iTunes Match Program.

  • John Trussell Level 1 (10 points)

    THIS is the solution!! Everyone should do this. Fixed my problems on all of my Macs.

  • rtvenge Level 1 (0 points)

    The option click fixed it for me too. I'm wondering if that clears out your old iTunes Match cache when you do this.

  • brandont Level 1 (0 points)

    dumb question, but where exactly do you option-click?? the only button I see is the Start/Stop button under the iTunes Match window when I click on it in the side-bar

  • gbrenik Level 3 (525 points)

    - In iTunes open the 'Store' menu bar item

    - Hold down the 'Option' key and click 'Turn Off iTunes Match'

    - Now reopen the 'Store' menu bar item and normal click 'Turn On iTunes Match'

     

    You're set!

  • Jared Blake Level 1 (5 points)

    Option click worked for me.

  • codyfisher Level 1 (0 points)

    Thanks everybody, I'm glad we can all start using this now!

  • Babasyzygy Level 1 (0 points)

    That's seriously bizarre.  Option key worked for me, too.

  • KMKazie Level 1 (0 points)

    I came from the other thread of the same issue.  Just I wanted to post the other way resolved the issue, for some reason, for me.  I did these:

     

    1. Press Command-J > Check iCloud Status checkbox.

    2. Select one song in 'Music' > Right click the song > Click "Add to iCloud"

     

    And it started the first step in the Match.  And it went through the step 2 without the error!  The process is now in the step 3, uploading songs.  Weird, but this was the way the issue was resolved in my case.

  • The Wireless Wizard Level 1 (0 points)

    I verify this solution.  After repeated attempts using a quit/launch/disconnect/reconnect and other troubleshooting efforts I tried the solution mentioned further up this thread of holding the Option key when disconnecting from iTunes Match.  That didn't work.

     

    Simply put, the solution described here (the post to which I'm replying) did work.  I simply selected a single song in my collection and followed the two steps indicated above.  I've now got 4000+ songs "uploaded" to iCloud and iTunes is actually uploading a number of things (e.g., language instruction programs) that were not available in its library.

     

    For anyone suffering through the reviled "Error 4001" problem I strongly recommend this approach.  It works.

     

    My thanks to KMKazie for figuring it out.  Well done!

  • VeeFourteen Level 1 (5 points)

    Holding down the Option key also worked to correct my 4001 error.

     

    I actually received a follow up email from an Apple Customer Support Tech this morning concerning the 4001 error. They offered the same advice for correcting the issue by holding down the Option key. They've either found that out on their own...or just noticed the answer in this thread!

     

    Not sure of the exact mechanics of this, but it appears that Apple Tech Support is now aware of the answer to this problem too.

  • brandont Level 1 (0 points)

    This is the one that worked for me!!! Thanks so much!!

     

    I tried the option-click a few times and kept getting the error. I did the right click add to iCloud, and it worked!!!!

     

    Thanks again!

  • endaris Level 1 (0 points)

    Option-click worked for me as well. I actually found the fix on this site; glad to see the forums have picked this up as well: www.masteryourmac.net/master-your-mac-blog/itunes-match-error-4001-solution.html

  • RedColes Level 1 (0 points)

    In iTunes go to View  > View options > check both iCloud boxes.(Download and Status)  Worked for me.

Previous 1 2 3 4 5 6 Next