Previous 1 2 Next 23 Replies Latest reply: Aug 21, 2013 9:03 PM by sebazacq
raw-mob Level 1 Level 1

After upgrading to FCPX 10.0.1 I get the message: "The selected SAN location is already in use" and FCPX can't see my Firewire-attached DroboS.

The fine-print in that message tells me that the same user that I am currently logged in on (from the same computer) is already using that drive.  I therefore cannot use that drive for FCPX at all.


The Drobo is accessible through Finder, and when FCPX is starting up it does briefly appear in the list of drives that contain FCPX events.  I have tried deleting the files .fcplock and .fcpuser that appear in the root folder for the Drobo, but this makes no difference.


HELP!!  I need to be able to use my external storage!

Final Cut Pro X, Mac OS X (10.6.8), MacPro4,1
  • Richard Lawler Level 1 Level 1

    I am getting this exact same error. What a nightmare.


    FCPX 10.0.1, iMac 12,1 (2.8 GHz i7) 16 GB. MacOS 10.6.8


    I'm not using a Drobo, I'm just using a Hitachi G-Drive 2000 via FW800.


    I had created dozens of Events on the G-Drive. Now it won't create any more events on G-Drive and like the previous poster they show up initially then they dissappear.

  • julia-fl Level 1 Level 1

    Is there a solution to this yet?  I'm using 2 TB Seagate external hard drives and got the exact same SAN message. Rebooting hasn't helped.  It was working fine for a month - it's a sudden message with no apparent trigger reason!  Help!

    Screen Shot 2012-02-19 at 1.30.08 AM.png

  • Tom Wolsky Level 10 Level 10
    Mac OS X

    Do you have multiple users on the computer? Try rebooting.


    Is fl Florida BTW?

  • julia-fl Level 1 Level 1

    I'm the only single user on the iMac.  Rebooting hasn't helped.  yes FL is Florida

  • Tom Wolsky Level 10 Level 10
    Mac OS X

    Try trashing prefs, repairing permissions in the Disk Utility, and rebooting.


    In Boynton Beach at the mo.

  • giorgio b Level 1 Level 1

    RE : "The selected SAN location is already in use"

    I spent 2 hours with Apple technical support and  even did a remote session as they looked at my desk top live.

    1st the bad news, there is no real solution nor is there an answer as to why this happens. The SAN is supposed to only work through fiber optics and is strictly designed for multiple users accessing the same drives … It should only be activated manually and only through fiber optics . No one at Apple could understand why this is happening, why did my thunderbolt disk appear to be on a SAN and unexplainably unable to be accessed by my computer because it was being accessed by my computer. A conundrum indeed

    The semi good news is that I was able to open the original session eventually.

    Here is the workaround… And it ain't pretty .


    If you can access the disk on the desktop copy the whole content of the disk to another drive , this is because you will have to reformat the drive which is giving you the problems.


    Format the original problematic drive and after you have cleared all of the user preferences for Final Cut X relaunch Final Cut.

    Final Cut should now see the drive without any of the SAN issues.


    Start a new event on the original reformatted drive and give it a somewhat generic name so as not to confuse it with the original event that went bad.


    Reimport into this new fresh event all of the original media ( video/audio/graphic ) files and copy them to the reformatted drive.


    Do not start a new project related to this new event


    Shutdown Final Cut X


    Now go to the drive in which you have copied all of your original files and copy the original problematic Final Cut Projects folder right next to the Final Cut Events folder at the root level of the newly formatted drive.

    The new drive should only have 2 folders in it now, one is the new Final Cut Events folder that you created by copying over all of original media  and the 2nd one should be the Final Cut Projects folder which you just copied back from the backup drive.

    I only had to copy the one project which started giving me problems with the SAN issue, because it was the only FCX on my drive at the time therefore I kept intact the original Final Cut folder hierarchy, theoretically even if you have many different projects inside that Final Cut Projects folder it should work, but if that doesn't work try only copying the problematic Final Cut Project.


    Start Final Cut again and it should read everything except that the media will be off-line ( unlinked ) and you should be able to re-link all of the media if the files had not change names somewhere along the process.


    The one caveat about this is that my edits were off against the music. It almost seems like there was some kind of format issue. Something was lost in translation . My project was only 2 min. long and it had about 50 edits. The 1st three edits were completely off after that it was hard to tell ,some would be on some would be off.

    Now I was going on about 2 hours of sleep so i am a bit blurry but what I am certain is that the 1st few edits were 100% off by at least 60 frames.


    Again this may have just worked in my instance and it may not be applicable every time this problem pops up.

    BTW whenever I connected an older drive everything worked fine there were no SAN issues.


    I am on an iMac 27 inch mid 2011, 3.4 GHz Intel core i7 with 16 GB of RAM

    running Mac OS X version 10.7.4

    and Final Cut X 10.0.4 and

    my drive is a Western Digital my book thunderbolt Duo 4 TB formatted in RAID 0

    as a final note I tried everything I read on every forum before calling Apple.

    Hope this helps someone



    screen shots

    how the reformatted drive should look


    NEW FCX root drive look.jpg

  • gballey Level 1 Level 1

    I'm getting this same error. But on my system, it's complaining about "Time Machine Backup". I use an external LaCie 500GB drive as my scratch disk. My Time Machine Backup is on a 1GB Time Capsule, and I never access that drive other than for Time Machine. I'm using FCPX 10.0.4 with Mac OS X 10.6.8 on a 2008 iMac 24"

  • Tom Wolsky Level 10 Level 10
    Mac OS X

    Sorry, but could you give a little more detail. What exactly does it say about the Time Machine? Perhaps it's something you can ignore.

  • gballey Level 1 Level 1

    The alert popped up again, so here's a transcript. It has a Final Cut Pro X icon. "Time Machine Backups" is the name of the volume on my Time Capsule used by Time Machine.



    The selected SAN location is already in use.


    The storage location "Time Machine Backups" on this computer is already in use by "gordon" on "Gordons-iMac-2008". To access the location, quit Final Cut Pro on "Gordons-iMac-2008" or remove the location.


  • Tom Wolsky Level 10 Level 10
    Mac OS X

    Is this in the user called "gordon" or another user? Probably the easiest thing for you is to unmount the TM drive.

  • gballey Level 1 Level 1

    Yes, the user is "gordon" (the only user logged in).


    I'll try unmounting the TM drive. Of course, it auto-mounts when TM decides to do a backup. In fact, I'm not sure why it is staying mounted while TM is idle. Hmmm.


    I've left FCPX running for a couple of days, so that its background analysis processes can finish on about 85 minutes of HD video. The motion analysis runs particularly slow.



    I've noticed that the motion analysis creates bizarre results when the edges of the frames are mostly dark (I presume that it depends on the video at the frame edges to detect camera motion). One 35-minute video I made in an indoor theater, where my camera exposure was set to not blow out spotlit performers, looks like I'm using a vignette effect - the motion-corrected version is almost unrecognizable, with some of the video actually appearing to be upside-down! Good thing I can turn off the motion correction! I'll probably be more discriminating with my use of motion analysis in the future.

  • giorgio b Level 1 Level 1

    The SAN location issue has not been  resolved by Apple yet.

    There are no solutions, nor are there any leads as to why it happens.

    There is only one workaround which has helped.


    You have to have a newly formatted drive or make a backup of your old drive and format the old drive.


    Somehow what is happening is that Final Cut X  is confused and is listing some drives as SAN  (Storage Area Network) even though they are not. To compound this problem FCX won't let you take the affected drive off of the SAN .

    It becomes schizophrenic thinking there is a SAN Drive but then not seen it to let you unmounted from within FCX . Therefore when you try to manage the drive as a SAN it doesn't show up anywhere. This is why I call it schizophrenic, FCX will give you the error that it cannot use the drive because it is being used already by itself…..


    Here are some steps I used to recover a 30 sec commercial


    WARNING this only worked for me and it is not endorsed by Apple nor by myself for anyone else. It is strictly a guideline to what I did that may or may not work for you.



    1-backup the affected drive completely or replace it with a new drive.( Format the old drive if you have backed it up )

    2-start FCX and start a new event on the newly formatted drive.

    3-From within FCX reload and copy all of the original media  (from the old drive )  to the new drive.

    4-do not start a new project and now quit FCX.

    5-copy  ONLY the original project information from the old drive Final Cut Projects folder to the newly formatted drive in the NEW Final Cut Projects folder which has been created by FCX on the new drive, root level . ( This is the level you see when you 1st open the drive )

    6- start FCX and you should be able to see all of the old projects in the project library window. Open the project which you were working on and it will show a bunch of missing files . You will now have to relink files . Be sure to select the newly formatted drive with the event library window and go to the menu bar ..  - file - relink project files . A window will pop-up asking you to locate all files and you will guide it to the new Final Cut Events folder created on the newly formatted drive where all the files now are. ( This folder is at the root level of the new drive " . This should work perfectly and all the files should be relinked. Unless there had been some strange renaming of the original files after you started editing there should be no problems with the re link.


    This worked for me but again it was only for a short project. You will probably have to let Final Cut go through all the reprocessing it needs to. This is very time-consuming but is better than the alternative which is to lose all the edits and start from scratch.


    I tried every single other solution before  calling Apple and they were the one that told me I had to reformat the drive.

    I even tried loading the  data as it was from the copy I made on a new drive and that did not work.. I had to start a completely new event and have all of the media recopied to the new virgin formatted drive .

    There seems to be something  within the ( old ) event library  folder which is causing FCX  to think that the drive is on a SAN.



    Again let me restate that this SAN issue is completely spurious at the moment and it has no official cause or solution from Apple. Google SAN Drive to get more information on what a SAN is.



  • giorgio b Level 1 Level 1

    A word of warning about the media files.

    Be sure to copy the original media files and not the proxies nor the optimized files unless the optimized files were your original working media files.

    What I'm trying to say is you should be working off your original working files, these could be files which you had optimized and trans-coded before you started your editing process.

    if you were using the original unprocessed files and had FCX do the transcoding and proxies for you.repeat this exact process

  • gballey Level 1 Level 1

    So far the only "problem" I've had is the occasional annoying appearance of the alert. As best I can tell, all my FCPX files are where they should be on my external scratch drive, and a quick look at the content of my Time Capsule's Time Machine Backups volume doesn't show anything unusual there. If I learn anything new, I'll report back here.

Previous 1 2 Next