Previous 1 2 3 4 Next 53 Replies Latest reply: Jul 26, 2014 3:16 PM by spyke60
Matt Wolanski Level 6 Level 6 (10,255 points)

I currently have Lion installed on a 2011 MacBook Pro and a Mac Mini (Core2 Duo) - with a couple other systems waiting for a few upteas to PPC apps.

 

I have had frequent issues in the past couple weeks with downloaded files being corrupt. Including downloads from various places using Safari - and from Apple Software Update - but also from in app update downloads. The files download but the are unuseable - ro fail a checksum on decompress.

 

I did not change anything in my network setup  - and in 20+ years of being a Mac user - do not recall having this sort of trouble. In one case I had to download the same file 4 times before it worked.

 

I was thinking it might justbe this MacBook and something is not right - but just had the same thing on the Mini - so unless it is something screwed up with my ISP - it must be a Lion issue - as I have yet to see it on the Snow Leopard system.


MacBook Pro 2011 17, Mac OS X (10.7), iPhone 4 32GB
  • baltwo Level 9 Level 9 (61,805 points)

    AFAIK, it's just flaky internet connections which corrupt the DLs. Too many people wasting bandwidth streaming music, movies, socializing, and doing other cloudy things. It'll only get worse when iCloud goes public.

  • Matt Wolanski Level 6 Level 6 (10,255 points)

    I've got 50Mbps download cable service. Never had a problem before.

  • Matt Wolanski Level 6 Level 6 (10,255 points)

    I tried turning off wired network and using wifi only on the Mac Mini - 4 attemps now (3 wired and 1 wireless) to get 10.7.2 to install and I get an error message that the download could not be used.

     

    The MacBook Pro did it the first time without issue.

  • Clems-ZRH Level 1 Level 1 (0 points)

    Same issue for me. I don't think it's a network issue.

     

    https://discussions.apple.com/message/16552099#16552099

  • Neil from Oz Level 2 Level 2 (170 points)

    Hmmm, I'm a pretty heavy downloader and have not had one issue downloading a file from anywhere, either directly or through Software Update. I have a reliable IP server, and my Lion OS is completely stable on my older Macbook Pro, and there are only a very few people on these forums with the issue, so I would highly doubt it is Lion. Have you repaired your permissions with DiskUtility?

  • Matt Wolanski Level 6 Level 6 (10,255 points)

    As it turns out not specific to Lion. Have had the same issue on previous versions of Mac OS. Not sure if I hae seen it on windows but I only run one windows system. Which has had some network issues which may have the same root cause but don't show up as corrupt downloads.

  • Clems-ZRH Level 1 Level 1 (0 points)

    Any idea on the root cause?

  • JPH58 Level 1 Level 1 (0 points)

    I too have noted frequent corrupt downloads on both my Mac pro and my MBP over the past few months.  I never had a problem over the past 10+ years.  It occurs with any regular update or iOS5 initial download and update.  The files eventually have downloaded properly after many days and a dozen or so attempts.  I also have TWC 50 Mbps internet connection for the past few months coincident with the problems- related?

  • IPFact Level 1 Level 1 (0 points)

    I have the same issue on my MBP, two Mac Mini Servers and a MacBook, all running the latest Lion version. In my case I can narrow it down to files downloaded by http(s). All other download methods (Usenet, FTP etc.) work just fine.

     

    - ISO's (Linux for instance) download fine until you want to mount them (unknown file system). MD5 check on the files produce the wrong results.

    - Apps from the App store wich are "large", let's say 10MB and up, are corrupt according to iTunes.

    - Software Update doesn't allow me to install Safari or iTunes updates (large)

     

    When I download the same files with a Windows laptop (had it hidden somewhere, hoping I would never have to use it ever again), everything is fine.......

     

    It has nothing to do with my Internet connection, since it can be reproduced on all Macs with a different ISP (UMTS). Wireless, wired, doesn't matter......

     

    I hope someone addresses this issue, it's a real pain in the b***

  • baltwo Level 9 Level 9 (61,805 points)

    Then, file a bug report with Apple via http://www.apple.com/feedback/macosx.html. While your connection might be fine, the Internet isn't. DLs come in packets and if one is mucked up, the DL will fail.

  • IPFact Level 1 Level 1 (0 points)

    Would you agree that it is rather strange that the same dowload works on a XP machine, and fails on 4 Macs running the same OS version?

  • baltwo Level 9 Level 9 (61,805 points)

    Yes, but I don't use any other machines, so don't know if it's OS-related. That's why I suggested filing a bug report. No sense complaining here, since Apple's provided the vehicle to submit BRs. Alternatively, call AppleCare.

  • Clems-ZRH Level 1 Level 1 (0 points)

    Did you try using Chrome/Firefox?

    I have the same issue (see link to my post above).

    Using another browser fixed the problem.

  • tuxthedownloader Level 1 Level 1 (0 points)

    In my case it was an issue of the DSL router (Thomson TWG870U, firmware STBA.01.39).

    When I turn off routing in the router configuration then everything works perfect (set 'switch mode' to disabled, i.e. no LAN, MacBook directly gets a WAN IP address from provider). I downloaded >11GB Mainstage/Logic content and >20 GarageBand exercises without any problem. These downloads kept failing before and occasionally one was ok after the n-th attempt. I was so disappointed with Apple and now I am really glad that the corrupted download problems (that also drove me crazy when doing the iOS 5 update) are 'only' a local router problem.

Previous 1 2 3 4 Next