Previous 1 2 3 Next 68 Replies Latest reply: Sep 18, 2014 7:48 AM by sébastien239
James Ferguson Level 1 (25 points)

One of the advertised features of iOS 5 was the inclusion of S/MIME in the Mail client. So far I can't find any documentation for how to enable or use it. Has anyone successfully done it?

iPhone 4, iOS 5
  • KiltedTim Level 8 (48,620 points)

    Why don't you just wait for iOS 5 to actually be released, then check the documentation that will surely be posted...

  • James Ferguson Level 1 (25 points)

    Unfortunately no new documentation on Apple's site was released. I got it working on iPhone Configuration Utility (poorly) but unfortunately there's scant documentation.

  • willjasen Level 1 (0 points)

    Same here.  I cannot find any documentation referring how to set up S/MIME.  I'm not even going to attempt the iPhone Configuration Utility - I need something that's easier to setup and manage so I can deploy to a few users within the organization.

  • keith.smith Level 1 (10 points)

    You don't have to use the iPhone Configuration Utility (although I would expect that to be an easier way to push out a bunch of certificates in one go), you can just send the certificate to the user in an email.  On the iPhone you can then open the attachment and a profile is created for it. NB: You may need to tap and hold on the attachement to do this, I can't remember.


    To actually use S/MIME you have to turn it on for the email account you want to use it with:

    Settings -> Mail -> [the account] -> Account -> Advanced -> S/MIME


    Seems to work well.

  • ChrisJ4203 Level 8 (44,800 points)

    iOS User Guide page 55 describes how to do this.

  • James Ferguson Level 1 (25 points)

    I followed Chris' link and Kevin's answer. Yes there are several ways to do this.


    1. iPhone configuration utility if you want to install directly over USB and not worry about the unsecure email.


    2. Export it as a .p12 file and email it to yourself or send somehow in iCloud and open it on the device.


    3. Download it directly from the website that issues the private key certificate using mobile Safari.

  • FABU Level 1 (10 points)

    This doesn't work for me.


    I have a free S/MIME certificate from


    I downloaded the CollectCCC.p7s to my laptop, imported to keychain. I can export it to .cer, .pem, and .p7b but not .p12


    I sent the .cer to my email on  my iPhone 4s and installed it.


    When I go to  Settings -> Mail -> [the account] -> Account -> Advanced -> S/MIME

    I enable it and then I try to enable "Sign" it doesn't let me do it.


    It is grayed out. and under Certificates it says no valid certificates found.


    Any suggestions?

  • FABU Level 1 (10 points)

    I found the solution


    When exporting the certificate from keychain. Look at the left hand side under category and select "My Certificates" first then right click and export to .p12


    Then everything should work as advertised!

  • markmaus Level 1 (5 points)

    I was able to install my personal certificate via iphone configuration utility and its shown under "profiles" now. Unfortunately I couldn't select the certificate in the  SMIME configuration  of the coresponding mail account at my iPhone. If I try to switch on either signing or encrypting, the iPhone only shows "No valid certificates found"

    My certificate is valid for email encryption and the email adress in this certificate is the same as the account uses.


    If I also configure the whole emailaccount settings via the iPhone configuration utility everything works fine, but I'm not able to deactivate/activate the SMIME usage at the iPhone for this account.


    Anyone who can help me?

  • jasonheiss Level 1 (0 points)

    I'm in the same boat.  I've added my certificate to the phone via both the iPhone Configuration Utility and by emailing the PKCS12 file to myself and installing it out of the email on the phone.  I still get "No valid certificate found" in the S/MIME preferences.  The "profile" added via the configuration utility shows as "Verified", the one added via email shows as "Not Trusted".  I've tried both configurations separately, and with both variants installed at the same time.


    In case it matters my cert was issued by CAcert.  I added CAcert's root certificate via the iPhone Configuration Utility as well.

  • markmaus Level 1 (5 points)

    I'm also using certificates issued by CACert. I've allready  tried the whole evening to get SMIME working and I think in the meanwhile I've tried almost every possible way to fix this problem. Unfortunately still without success.

    The only way is still to set up the whole email account by the iPhone configuration utility.

    Even renewing my certificate, which originally contained 2 email-adresses to one with only one email-adress didn't help.

  • keith.smith Level 1 (10 points)

    Guys, whilst it is actually possible to use self-signed and community certificates (like CAcert certificates) with S/MIME (you need to make sure you have a good full chain available) I feel I should advise against it.


    Two reasons:

    1) Unless _everyone_ you send email to also has your self-signed root or the community certificate's hierarchy they will not be able to validate your email or send you encrypted mail.  In which case, what is the point?

    2) You can get a free and publicly valid personal certificates (home use only) from a number of CAs, e.g.


    If you must persist with CAcert then I recommend that you get things going on a desktop mail client (e.g. first, then when you know that you have a good certificate (+ root and/or + hierarchy) you can transfer them to the iPhone.

  • jasonheiss Level 1 (0 points)

    It's a fair point that some (probably most) of my recipients won't be able to validate the signature, but I persist anyway to encourage them to go get the CAcert root.  I don't really do it for the security, but more to promote CAcert just because I like the idea.


    I've been using S/MIME in with my cert from CAcert for years.  I know the cert is fine.

  • FABU Level 1 (10 points)

    Since you area using this same Cert with on your Mac, try this:


    Start Keychain, on the left hand menu under categories, select my certificates, then export your cert as .p12 and send it to your email.


    Open the email in your iphone and import it.


    Go to S/MIME settings and check if it appears there.

Previous 1 2 3 Next