Previous 1 3 4 5 6 7 Next 188 Replies Latest reply: Jun 19, 2012 6:37 AM by linsD Go to original post
  • Morat Level 1 Level 1 (0 points)

    Nope, not just MM migration. My issue, shared with a few here seems only related to those who have a '' Apple ID (some of which may be MM migration, but not me). Everything works perfectly for me except for the fact I can't send iCloud emails from my devices (iCloud web sends fine) as 'The sender address was rejected by the server'. Anyone else have a fix for this specific problem?

  • sksfreund Level 1 Level 1 (0 points)

    I'm having a similar problem.  I can occassionally get email to work on some of my apple devices (iMac, macbook, ipad, 2 iphones) but more often than not I get the "incorrect password" error.  For now I just have mail sync turned off.  My iCloud web email seems to work alright with no errors popping up.  But even that can be glitchy at times.  I don't think my issues are because of a mobileme migration.  I did use mobileme about 2 years ago, but I stopped using it.  I don't remember what apple ID it was associated with though (I seem to have quite a few, for some apparent reason).  I'm wondering if my apple ID just being associated with a mobileme account could have caused some of these issues.  I really hope apple acknowledges this issue.

  • Bruce Ciccone Level 2 Level 2 (215 points)



    After spending some quality time with a Senior Apple Tech we have found a solution.  I would mention his name, but I am not sure if that is allowed.  However, thanks a lot!


    The solution was something I tried earlier.  Why it did not work then, I do not know.  Perhaps the server was just not playing nice.


    So, on your iPhone/iPad.........

    1) Goto Settings>iCloud

    2) Delete account.  When asked "What would you like to do with iCloud calendars....", click "Keep on My iPhone".

    3) Goto Settings>iCloud

    4) Re-add iCloud -BUT- delete the "" that is listed by default in the "Apple ID" field

    5) Type in the new iCloud "" email address that you were assigned in the "Apple ID" field

    6) Type in the password you normally use

    7) Click "Sign In"

    8) After it goes through the verification process, merge what you want to merge


    The Senior Apple Tech recreated the process on my ipad and iphone.  All test emails back and forth to worked.  I just recreated the process again on my wifes phone and it worked.


    Thanks again Senior Apple Tech


  • Morat Level 1 Level 1 (0 points)

    Bruce, you the man! Everything works fine for me now, although I expect I'm in the minority.

    I owe you a pint:)

  • sydavis Level 1 Level 1 (0 points)

    OK, when yous say "blahblah", are you saying use your same .mac address but use the .me version?  Example, if my address has always been, am I to use

  • Bruce Ciccone Level 2 Level 2 (215 points)

    I had a "" Apple ID from a long time ago that I have only been using for APP Store and iTunes purchases.  When icloud was released, I signed up using my Apple ID and then had to pick a new iCloud "" email address.  I did this on my mac.


    When I signed up for iCloud on my iOS devices, the iOS devices would use my Apple ID in the "Apple ID" field by default.  So, instead of using the Apple ID, I typed in my newly chosen email address.  Use the same password as before.  After the verification process, the iOS device, automatically changes the "Apple ID" field back to your Apple ID and then sets your new email address in the mail settings under "advanced".

  • hurlsp Level 1 Level 1 (0 points)

    This is exactly my situation (former .mac user...using that email address for my apple id). Unfortunately this procedure didn't work, even though I am now seeing my email address in advanced, as you mention....

  • luc Verhelle Level 1 Level 1 (0 points)

    Bruce, my hero. It works again!!! Thanks!



    Very weird, I did what you told me and the accountname on my iPad just changed automatically back to my previous mac adress. But still, in the end it helped. All is up and running now. I have also created an alias (as was advised in other posts) and that also works fine.

    So, in the end, you had the sollution thanks to a real Genius at Apple.

    Very weird that Apple doesn't inform its other advisers about this, I had one on the line and he could not solve my problem....looks like many of us tried the express help but no one ever came up with this sollution.


    Glad it all works now and let's hope it stays like this!



  • daveyh Level 1 Level 1 (40 points)

    I tried this a couple of times and unfortunately it still didn't work for me.

    I still cannot access mail from either.


    Spent 1.5 hours on the phone with Express support for iCloud, and a senior support person as well, they supposedly escalated this to engineering. That was a week ago.

  • Consumer Informed Level 1 Level 1 (0 points)

    Only iCloud mail is not working for me...

    Calender, Contacts ...etc work fine ....


    If I login from Safari, I click the Mail icon and a popup says…. 




    So I go to the iCloud preferences on the Macbook Pro and see that Mail is unchecked. I check it … a popup appears that asks me to choose an email address. It does not let me use the address that I have with my primary account. It suggest a name with only 2 letters then says you can't use a 2 letter password after entering … pick a longer password and it says .........




    Agian let me say that when I login online with my primary password, Calender, Contacts ...etc work fine .... Only MAIL does not..


    any one else have this issue? 

  • mussi1975 Level 1 Level 1 (0 points)

    what a ******* service from apple!!!



  • christian162 Level 1 Level 1 (0 points)

    I cannot get icloud to send email on any of my devices. I have an iphone, ipad, and macbook and cant send from any of them. I can recieve mail just fine. I dont know what the heck is going on. When i try to send  through icloud from mail i get the following message: Connections to the server “” on the default ports timed out. I have also recieved messages about my password being wrong. This is extremely frustrating. Can anyone help?

  • Bruce Ciccone Level 2 Level 2 (215 points)



    "Very weird, I did what you told me and the accountname on my iPad just changed automatically back to my previous mac adress".


    That is exactly what should happen.  However, if you goto Settings>iCloud>Select your iCloud account ""


    You will notice that your email address is listed under "Advanced".


    The Senior Apple Tech said he was going to forward the solution up the chain.  Hopefully, something will be posted.


    Glad it worked.

  • Bruce Ciccone Level 2 Level 2 (215 points)



    Sorry it did not work for you.  I was able yo repeat the process three times with success.  This leads me to believe there may be something else going on with your account or the server.  It did not work for me at first just a day prior to it finally working.  I would definitely call apple support.

  • hurlsp Level 1 Level 1 (0 points)

    Thanks @bruce... I've got a phone appointment with them for this evening, hopefully that will clear it up... though I'll give it one more try again before then.  

Previous 1 3 4 5 6 7 Next