Previous 1 7 8 9 10 11 Next 202 Replies Latest reply: Aug 3, 2014 8:15 AM by Mmjma Go to original post
  • Sean1504 Level 1 Level 1 (0 points)

    The problem I was having is that the messages sent to my phone number would come through on my iPhone but not my iPad.  I fixed this by changing my contact card phone number from 077... +4477... Basically, if you're having the same problem make sure that the number in your message settings on iPhone matches exactly with the number on your contact card including the country prefix.  You can associate your contact card under the mail, contacts, calendar settings.

  • Sean1504 Level 1 Level 1 (0 points)

    As a quick follow up on this, looks like your friends numbers in your contacts also have to be in international format e.g. +4477.... Rather than 077.... For UK.

  • benboyd5 Level 1 Level 1 (0 points)

    Here's a list of 10 fixes for iMessage not working issues:

     

     

    http://www.sinatranetwork.com/wordpress/2012/03/27/ios-problem-fix-imessage-not- delivered/

  • SABruce1 Level 1 Level 1 (0 points)

    Mine iPad had the same problem.  However once I turned on the celluer connection it worked fine.

  • @Sk23design Level 1 Level 1 (0 points)

    Was unable to sign in to iMessage iOn my iPad  with my apple id but could connect to itunes etc with the same id. Changing the DNS settings fixed it for me. Using googles dns of 8.8.8.8 worked little strange that other dns cannot resolve the address.

  • Berbyq Level 1 Level 1 (0 points)

    I have 2 iPad 2's both WiFi only.  When I try to send an iMessage, I can enter text but the send button is greyed out. 

    If I take a photo I can send this AND any text that I enter.  I have sent iMessages in the past (admittedly a few months ago) that worked.  I  am running iOS 5.1 (99B176)

    Same situation applies to both pads.  

    I have tried:

    - turning iMessage off on both devices and reconnecting.

    -powering down both devices.

     

    If I couldn't send anything, I would have considered changing the DNS setting but since I can send, I didn't think that this was the problem.

    I didn't reset my Network settings because everything else works fine.

  • Picnicmetoo Level 1 Level 1 (15 points)

    You have to have a subject typed in to have the send button not greyed out.  Alternatively you can set Imessaging to have "subject off" in settings and then you don't have to bother with it.

     

    I had the same thing--it would send with pics but not otherwise so I did some digging and found this.  Hope it helps

     

    Diane

  • Berbyq Level 1 Level 1 (0 points)

    Thank you very much Diane:

     

    I feel so stupid.  After reading your post it all made sense.  I didn't see the "subject" heading because I just opened iMessage and started typing.

    Again, thanks and have a great day.

     

    Bob

  • Lawrzz Level 1 Level 1 (0 points)

    Solution for new users like me. Register for a @me account and add it to your message account.

  • Jprmoore Level 1 Level 1 (0 points)

    Brilliant! Trawled everywhere to find a solution and this worked immediately for FaceTime and iMessage in iPad, will try on same iMac issue later

     

    Thanks

  • Calebee Level 1 Level 1 (0 points)

    Awesome, straight forward easy to follow instructions worked for me so Thanks a heap

  • Ladywendy Level 1 Level 1 (0 points)

    I am still having the issue of the send button being greyed out. One day it works fine, then the next day it doesnt work at all. People can send me messages but I can NEVER reply half the time. I have powered it off, forced the app to close. And still have these issues. Apple needs to fix the bugs in this its getting irritating when I want to use it and it doesnt work.

  • agtgtown Level 1 Level 1 (0 points)

    Well, I have iPad 2 wi-fi, and after I downloaded iOS 6 I can only send iMessage from my iPad if I also include a photo!!! Just typing message in the Subject line does not help. The Send button is grayed out! It definitely is a bug, is Apple fixing it? Very annoying. I tried resetting etc, nothing works.

  • SKGaquin Level 1 Level 1 (0 points)

    iMessage worked fine on my ipad3....until I updated iOS 6 to IOS 6.1 or whatever the most recent upgrade is numbered.  Now when i send an imessage, it looks like its going to send, but a red exclamation mark appears and the words "message not delivered".   Ideas?

  • Chris CA Level 9 Level 9 (77,025 points)

    agtgtown wrote:

     

    Well, I have iPad 2 wi-fi, and after I downloaded iOS 6 I can only send iMessage from my iPad if I also include a photo!!! Just typing message in the Subject line does not help.

    You need to type in the Text Message line at bottom.

     

    The Subject line is just that. It's a header for a message (which you really don't need). You can turn off the Subject filed in Settings > Messages > Show Subject Field to Off.

Previous 1 7 8 9 10 11 Next