Previous 1 2 3 4 Next 54 Replies Latest reply: Oct 23, 2011 11:08 AM by goegele
arrrrrrgh Level 1 (15 points)

I am having trouble with my bluetooth mouse after upgrading to 10.7.2 and the associated iOS 5 upgrades.  The mouse keeps losing its connection.  I've turned bluetooth off, trashed the preferences, rebooted and repaired both the keyboard and mouse but the mouse keeping dropping out.  Keyboard seems ok.  Anyone have any ideas?


Regards Len

Apple TV2 iMac, iPad1 IPod4 iPhone4
  • arrrrrrgh Level 1 (15 points)

    Answered my own question I think.  After searching the BB I came across a suggestion as follows:


    1) SHUTDOWN the computer

    2) power off keyboard & mouse (hold power for 5 seconds)

    3) power on computer

    4) allow computer to come up and say there is no keyboard & mouse connected. at this point, power ON the keyboard. this should put it into pairing mode. re-pair it when prompted, and yes hit the enter key.  Then do the same for the mouse.


    I tried it and it seems to work now (1 hour) after having the mouse lose it's connection every 10-15 seconds since my software updates.


    Good luck to all.


    Regards Len

  • arrrrrrgh Level 1 (15 points)

    I spoke too soon.  Still having drop outs only not as frequently - the above steps did improve the situation markedly though.  I also reset the PRAM but the problem persists.  Its got to be software, as I've been using the same hardware (batteries as well - battery level is 88%) for two years without a hitch.  Problems started with 10.7.  Still unfortunately digging.


    Regards Len

  • Dave Z Level 1 (60 points)

    I'm having the same issue with my late 2009 iMac. Woke the computer from sleep and it would not find the Apple Bluetooth keyboard or Magic Trackpad. I had to use VNC to restart the computer but even that didn't work. I eventually shut it down and powered it back up and it recognized the devices.


    When the iMac was not recognizing the devices, using VNC I fired up System Profiler and it seems my Bluetooth controller was completely absent.


    This issue began after installing the 10.7.2 update. Until then I had no issues.

  • m1234 Level 1 (0 points)

    I have had the same issue with 10.7.2, but since resetting the SMC about an hour ago, it seems fixed. Fingers crossed.



    Good luck.

  • goegele Level 1 (0 points)

    unfortunately your advice did not work in my case

    I have an MS IntelliMouse Explorer for Bluetooth and I still get the same error message in the console:


    kernel: [SendHCIRequestFormatted] ### ERROR: [0x0411] (Authentication Requested) -- Send request failed (err = 0x0010 (kBluetoothHCIErrorHostTimeout))

  • arrrrrrgh Level 1 (15 points)

    still having the same issues unfortunately as are others.  Tried all the suggestions I could find including resetting the SMC to no avail.

  • Caltain Level 1 (30 points)

    First, I gotta say that's an absolutely great choice of username!



    If you just want a solution quickly, skim down until you reach the paragraph that starts with “SOLUTION:” to get up and running immediately.



    Okay, onto the topic at hand.  Like all of you, I've had problems with the 10.7.2 upgrade.  To be honest, most of your getting off light.  When my MacBook Air booted up after the install, my Magic Trackpad immediately began to cycle between connected and losing the connection.  Of course, I did what anyone would do.  I shut off the trackpad.  To my great surprise, this immediately produced a kernel panic.  Honestly, I didn't even bother to check the console log.  I just booted up and give it another shot.  I'm pretty sure you guys know what happened next.  Since I had forgotten to switch off the trackpad before booting my MBA, it was one of those lather, rinse, repeat moments.



    I learned my lesson.  I turned off the trackpad and then booted my Mac.  I also have access to a Logitech mouse as well as a mouse pad on my Logitech Bluetooth keyboard.  None of these were experiencing any difficulties at all, to my even greater surprise.  From this I determined that the problem exists somewhere in the Bluetooth stack that is native to OS X 10.7.2.



    SOLUTION: The problem appears to be an incompatibility between mouse/trackpad setups and the new Bluetooth stack code that was implemented in OS X 10.7.2.  To fix the problem:



    • Go to System Preferences->Bluetooth.
    • In the left-hand pane, click on the problem device.
    • Click on the minus sign at the bottom of that pane.
    • Verify that the problem device itself is switched off.
    • Reboot your machine.
    • Once your system has completely restarted, return to System Preferences->Bluetooth.
    • Click the plus sign at the bottom of the left-hand pane and pair the problem device as if it had never been connected.



    NOTE: During this process, you may receive errors that indicate that the device is already paired and other such nonsense.  Dismiss any such error notices in any way you like and continue pairing the device.



    You should now be up and running again.  This worked for both my Magic Trackpad and my Magic Mouse.  Everything continues to function normally after rebooting and entering/exiting sleep mode.


    Message was edited by: Caltain to correct spelling.

  • Anant Sundaram Level 1 (0 points)

    I tried as you suggest. Unfortunately, despite the fact that both my mouse and my trackpad show as 'Connected' (i.e., green light in Bluetooth under Preferences against each device),  neither will move the cursor! It won't budge.


    Very frustrating.....

  • Caltain Level 1 (30 points)

    Anant Sundaram -- Unfortunately, despite the fact that both my mouse and my trackpad show as 'Connected' (i.e., green light in Bluetooth under Preferences against each device),  neither will move the cursor! It won't budge.

    Anant-  Unless you are using a second account, and are the same person as one of those above, we haven't heard from you yet.  It's great that you are joining in! (Sorry you have the need, but welcome, anyway!)  If you are on a laptop, then try the builtin trackpad. I found at one point that I had exactly the same situation as you. The external Bluetooth mouse & trackpad would not work.  Turns out I had a bigger problem and Finder was semi-hung and was starting to take the window server down with it.


    My solution relies on the fact that Bluetooth mice/trackpads use every layer of the OS, from basic hardware I/O to "in your face."  Therefore, you may have to address the problem at more than one point.  You will see similar threads where the advice has people doing firmware resets and deleting files.  I doubt that the firmware is contributing to the problem, and the files that they are deleting are just preference files. In this case, these would be the lowest and highest levels of the system.  We need to "reset" the middle stuff, which has cached settings and information that it now cannot read or use.  The basic idea is to get the Bluetooth system to clean it's own house and start over.  We are relying that the new code is internally consistent; that is, it can read what it has written.


    It is ABSOLUTELY mandatory that you reboot at least once after removing the mouse or trackpad from the list of BT devices.  In fact, I would say that you should check to make sure that the removal "took" the first time by checking the list.  In any event, it is a cycle:


    • Remove the devices from System Preferences->Bluetooth.
    • Reboot with devices powered off.
    • Return to System Preferences->Bluetooth and click the +
    • Power up the devices and pair them.
    • Reboot again.
    • See if they work. If not, power the devices off and repeat.


    If you have done this to your best ability for at least 3 cycles, then come back here and report it.  I will try to schedule some real-time method that we can communicate to get this fixed and give you back your iLife and iToys.

  • Anant Sundaram Level 1 (0 points)

    Will do that (tomorrow) and report. Sincere thanks!

  • Caltain Level 1 (30 points)

    Glad to help!  Please make sure and report back here if it worked, so that others can see what works.




  • Anant Sundaram Level 1 (0 points)

    Worked like magic!


    Have no idea why it happened today, but not yesterday -- perhaps, as you suggested, the solution was to keep trying until one got lucky!


    Thank you so very much, Cal.

  • Pulikutz Level 1 (0 points)

    Dear Caltain,


       I am also having the same problem with bluetooth after the 10.7.2 upgrade. I am having a bluetooth headset and its not getting connected anymore. Went to the system preferencess-> bluetooth and "-" removed the device (Philips shb6110) But after tat the computer is not even finding the device search shows no results!!!

  • papaspoof Level 1 (0 points)

    Ah, yes that did the trick.

    The SMC reset that is...

Previous 1 2 3 4 Next