Previous 1 2 3 Next 42 Replies Latest reply: Jan 23, 2014 4:04 AM by Jonathaneflores
ncz Level 1 (0 points)

Everything appears to be installed correctly -- calendars and contacts are syncing back and forth between iCloud just fine. Within the iCloud settings, Documents & Data is set to "On".


Under Keynote settings, there is a toggle simply labeled "iCloud". When I turn that on, leave the settings app, and then return, it is turned off. This happens on both the iPad and my iPhone.


I've checked the settings under Keynote, iCloud and Mail, Contacts and Calendar several times, and there is nothing glaringly wrong there.


Has anyone else had this problem and determined a fix?

Keynote for iOS, Other OS
  • louisbernard Level 1 (5 points)

    I have EXACLTY the same problem. Only, it actually works on my iPhone, but not on the iPad. Also this problem of the slider reverting back to OFF if you leave the Settings.


    PLEASE reply if you get answer/fix?

  • louisbernard Level 1 (5 points)

    I managed to get this fixed - hope it works for you as well!


    1. DELETE Keynote from your device(s)

    2. On your computer, update the version of Keynote in iTunes (I had not done this yesterday)

    3. Sync the device with iTunes


    After doing this, the welcome screen for Keynote on my iPad asked me for the first time if I wanted to use iCloud. Earlier today, after just deleting and reinstalling Keynote from the App Store, this question never came up.


    Now it seems to work well and is syncing correctly.

  • ncz Level 1 (0 points)

    Thanks for the tip. It didn't work for me, but I'm syncing wirelessly. Maybe I'll delete all the files and try again.

  • frank73 Level 1 (0 points)

    There is another slider allowing to sync documents in icloud settings, if this slider is turned on I have these problems: turn on slider in numbers (pages, keynote), open numbers, go back to settings an it is turned off


    If I turn off the slider in icloud settings, settings for all iwork apps work correcly.

  • Mzmacky Level 1 (0 points)

    It's seems strange, but on my iPhone, I need to have the documents and data slider OFF in the iCloud setting but ON for the iWork apps for the sharing to work.  On the ipad, however, I need to have both the document and data slider ON for icloud settings as well as the slider ON the iWork apps.  This just doesn't make sense.

  • TGN1908 Level 1 (0 points)



    I am having exactly the same issues but with pages and numbers as well as Keynote.  I have followed the steps mentioned in all of the posts above, and I have tried all combinations of sliders for the icloud on and off in both the master icloud setting and the individual app settings.  I have deleted and updated (no update available) and re installed the apps but always with the same result...


    iPad works perfectly with documents syncing with iCloud

    iPhone refuses to even offer the iCloud option and always turns off the app iCloud slider.


    If anyone could help I would be most grateful.


    Many Thanks


  • darktooth Level 1 (10 points)

    Had the same problem but got it fixed.

    Here is what I did.


    • On all devices - iCloud/Documents & Data/ Off
    • Close Keynote and restart (home button twice, long tap on keynote, close with - )
    • Restart Keynote (now Keynote will give a warning that iCloud is disabled)


    Now one device after the other:

    • Close Keynote (home button twice, long tap on keynote, close with - )
    • Now reactivate iCloud - iCloud/Documents & Data/ Off
    • Now reactivate iCloud for Keynote - Keynote / Use iCloud
    • Start Keynote


    After a few seconds the iCloud documents should show up and start downloading.


    Hope that helps... for me it solved the problem (at least for now )

  • TGN1908 Level 1 (0 points)

    Hi Again and thanks for trying to help.


    I have just tried all in darktooth's post and sadly for me its not worked for pages, numbers or keynote.  Am at a complete loss!!





  • Judith Farber Level 1 (0 points)

    Same problem here. Don't have a fix and the suggested fixes above have all failed for me. Just want to add myself to the list of complainers so that Apple sees this is a fairly wide-spread problem. In other threads, people have noted that a Restore solved the problem for them, but I don't want to resort to that solution just yet unless Apple officially announces it as a sure-fire fix.

  • mandhanda Level 1 (0 points)

    Had this same problem, but got it working this way:


    • Make sure you have a WiFi connection established and you're plugged into AC or USB power.
    • On all devices - iCloud/Documents & Data/ Off
    • Close Keynote (and all other iWork apps) and restart (home button twice, long tap on keynote, close with - )
    • Under Settings (iPhone and/or iPad), scroll past General & iCloud section to the App Section (the last section) and tap Keynote. Slide "Use iCloud" to On. Repeat for other iWork apps on each device.
    • Restart Keynote. You should notice the boot time of the app is longer, then the docs start uploading.
    • Repeat for other iWork apps on the same device before moving on to your other iOS5 devices


    Hope this works for you as well!

  • ramfangzauva Level 1 (0 points)

    The solutions offered here sound a bit like: Shut down all your devices, switch off the light and then walk around the block - with your right index finger in your left ear. When back it works ...


    Here's my solution - in iCloud settings on the iPad switch off Documents and Data Sync, thanks @frank73 for pointing this out - who would have thought of this weird solution.


    Quite frankly, with the iCloud we are nowhere near getting the features that were presented. First let-down was the non-existing sync on the Mac, now we can't even trust the most essential apps with our data.


    Apple needs to understand that they have to CONTINOUSLY work hard to maintain the level of customer satisfaction they have achieved! For my part iOS5/iCloud introduction has been a MAJOR disappointment.

  • dmason84 Level 1 (0 points)

    I've been having a similiar issue with Numbers.


    The iCloud syncing works pefectly in my iPad, but refused to work on the iPhone. I managed to get this working by doing the following (thanks to the numerous tips above):


    1. Settings -> iCould -> Documents & Data -> Off
    2. Restart Numbers
    3. When Numbers loads it will say I'm not using iCloud, and ask me if I wish to do
    4. Saying Yes will then cause documents to sync


    If I then go back to iCloud settings and turns Documents & Data on, I then lose all my iCloud docs (just on the iPhone, not permanently).


    This is even more confusing because on the iPad it works properly (e.g. with iCould Documents & Data set to on).


    Seems like the iOS guys have confused On and Off when it comes to iPhones!

  • SunshineKid Level 1 (0 points)

    Big thanks to Darktooth et al for their solutions.


    You all have similar answers which is:


    1. Shut down the apps (home button twice, long tap on relevant app, press -)

    2. Turn off Documents & Data (in iCloud Settings)

    3. Relaunch the apps & select "Use iCloud"


    Worked a treat for me but I do agree that someone in Apple has got their ONs and OFFs mixed up and needs a serious kick up the a**e.



  • michaelfromglen ellyn Level 1 (0 points)

    Yes, very odd. On the new iPhone 4S, the iCLoud doucuments must be turned off in order for the documents to show up. Everyone seems to be having same problem

Previous 1 2 3 Next