Previous 1 2 3 Next 36 Replies Latest reply: Oct 16, 2013 11:44 AM by Orreo Branched to a new discussion.
Zeemo Level 1 Level 1 (0 points)

So I installed IOS5 and switched iMessages to on. I am able to receive iMessages, but not able to send them?

When I am trying to send an iMessage to another IOS5 user I get the error "Not Delivered"

I have tried all settings / restore..over WIFI over 3G nothing....

How can I fix this?


iPhone 3GS, Other OS
  • mrlee121 Level 1 Level 1 (0 points)

    I'm having the very same problem mate, i'm able to imessage myself but no other imessage i send is being delivered!

  • jf from carrick on shannon Level 1 Level 1 (0 points)

    have the same problem too....

  • paul from Au coast Level 1 Level 1 (0 points)

    I have similar problem. Upgraded to ios5 this morning. Get message not delivered when I try to send to friend who also has ios5. Can,t even send to myself ... Get non delivered when sending to myself. All setting look ok! Very frustrating!!!

     

    Paul

  • rockintosh Level 1 Level 1 (0 points)

    I have the same problem. I can't send an iMessage from iPhone to iTouch or vice versa. All the settins look fine and I get the iMessage blue bubble instead of green. But each time I try to send, it says "Not Delivered." Had a friend from Thailand send me an iMessage and I was able to receive it. It's so frustrating.

  • Chris.L.H Level 1 Level 1 (0 points)

    You might try changing you DNS server. This worked for me. I switched to Google's Public DNS. 8.8.8.8 or 8.8.4.4

     

    http://code.google.com/speed/public-dns/docs/using.html

  • paul from Au coast Level 1 Level 1 (0 points)

    Thanks Chris,

     

    Changing DNS to 8.8.8.8 worked for me!! 

     

     

    Paul

  • rockintosh Level 1 Level 1 (0 points)

    It worked!!! Thanks a lot man!

  • veronicalovesapple Level 1 Level 1 (0 points)

    Hey, could you specify how you did this?

  • Chris.L.H Level 1 Level 1 (0 points)

    Sure. You can either change the DNS servers in your router, or if you don't have access to or familiarity with changing router settings you can make the change in the settings of your iPad.

     

    Settings > Wi-fi >

     

    Under Choose a Network, the blue button next to your network with the white arrow in it

     

    Then under DNS put Googles numbers 8.8.8.8 or 8.8.4.4

     

    You may also want to write down the old numbers for safe keeping. My guess is that after a while your old numbers will work fine with iMessage, but for right now Google's name servers are better up to date.

  • matt_tee Level 1 Level 1 (0 points)

    changing DNS did not work for me....

     

    still getting 'not delivered' HELPPPPP!!!!!

  • belall Level 1 Level 1 (0 points)

    same problem with me as well changing dns didnt wrk at all...still getting the same error any help...!!!

  • Andy Murphy1 Level 2 Level 2 (175 points)

    I'm having general hassles with iMessage:

     

    - imessages not being delivered.  Only way I know is when I go back into the message thread and notice the exclamation marks.  There's no pop up to say it's failed (some of them look to be sent, so I go back to the home screen only to find they've not gone later).

     

    - imessages noted as "delivered" not actually showing up.

     

    - occasionally it notes the message was "Sent as Text Message" and marks it green (even though it was blue when typed).  Only hassle is, these message aren't being received either.

     

     

    I've turned imessage off for now.  More hassle than it's worth for me - I get far more texts in my mobile plan than I need each month, and they are at least reliable!

     

    Have been an Apple convert for 12yrs now, but this latest round of updates has dented confidence

     

    - iOS5 took an age to get sorted, and left my phone inoperable during the process having trashed it before downloadig the update files, which it then couldn't get without a ton of re-tries (change your process Apple!)

     

    - iTunes is playing up, stalling with "accessing iTunes store"

     

    - iMessage is (for me and my other half) flakier than a box of cornflakes.

  • Craig220180 Level 1 Level 1 (0 points)

    saw this on macrumors forum and it seemed to work for some people:

     

     

    Some WiFi networks mess with the activation process used and the phone does not retry. To get your iMessages working,

     

    1) Turn off WiFi
    2) Turn ON Cellular Data
    3) Turn off iMessage
    4) Turn phone off
    5) Turn phone on
    6) Turn iMessage on
    7) Test iMessages
    8) Turn WiFi on.

     

    If you do it in that order and allow it to activate over 3G, it works without fail.

    be interesting to see if that works for any one?

     

    http://forums.macrumors.com/showthread.php?t=1249657

  • belall Level 1 Level 1 (0 points)

    i tried it...it didnt work for me ...did it step by step still no luck any more bright ideas ppl ...m kinda desperate for this...!!!

Previous 1 2 3 Next