1 2 Previous Next 28 Replies Latest reply: May 5, 2012 3:34 PM by rossfromuniversity place
jr378 Level 1 Level 1 (0 points)

None of my appointments in iCal show up in my iCloud Calendar. In fact my iCloud Calendar has no appointments in it. I am sure I screwed something up in the coversion and trying to remove all the duplicate entries. In any event, how do I go about syncing forcing the appointments in iCal to show up in iCloud Calendar.

  • 1. Re: Sync iCal with iCloud Calendar
    jcram13 Level 1 Level 1 (0 points)

    Same issue here.  I transferred from mobile me to the cloud and everything is still in iCal on my computer, but there is nothing in the iCloud ical.

  • 2. Re: Sync iCal with iCloud Calendar
    jr378 Level 1 Level 1 (0 points)

    PS:  The Calendar on my iPhone is now also blank.

  • 3. Re: Sync iCal with iCloud Calendar
    MaxGuru Level 1 Level 1 (35 points)

    I had this issue on my iMac and fixed it by:

    1. Import my calendars into iCal from my backup .ics files

    2. Go to System Preferences>iCloud and deleted my iCloud account

    3. Added my iCloud account back in the iCloud Prefs pane

    4. Select Merge when asked what to do with calendars

    5. Calendars will now be back on iCal and in the iCloud

  • 4. Re: Sync iCal with iCloud Calendar
    MichaelTree Level 1 Level 1 (10 points)

    You say Go to System Preferences>iCloud and deleted my iCloud account? Do you find this when ICal is open? I went to SP and could not find an I-Cloud Icon, only the old Mobile Me icon?

  • 5. Re: Sync iCal with iCloud Calendar
    MaxGuru Level 1 Level 1 (35 points)

    You probably need to run Software Update under the Apple menu. Upgrade to 10.7.2 and you will get the iCloud control panel. Once you go to iCloud you will see that most of the MobileMe options will have been transferred to iCloud.

     

    I hope you backed up your iCal calendars using the iCal Export feature before deleting anything.

  • 6. Re: Sync iCal with iCloud Calendar
    jr378 Level 1 Level 1 (0 points)

    MaxGuru, you say

    "2. Go to System Preferences>iCloud and deleted my iCloud account"

    but there is no option in the iCloud window from within System Preference to delete the iCloud account. You can uncheck the Calendars option and then check it again to add the iCloud Calendars function back and you can uncheck all the options and then do that again, etc. I have tried doing both of these and have not been given an option to Merge.

     

    Also, in System Preferences there is the Mail, Contacts & Calendars option next to the iCloud option. If you click this you can remove the iCloud account, which I also did. Upon setting the iCloud account back up I still was not given the option to merge the calendars.

     

    I am still at a loss as to what to do. I do not have the contents of my iCal on my MBP on either my iPhone or online in iCloud.

  • 7. Re: Sync iCal with iCloud Calendar
    jr378 Level 1 Level 1 (0 points)

    Why is it that I can only see the first 4 replies in this thread? I know there are additional replies as I have received email notifictions of the replies and Ihave made a reply, but I can not see them in this thread. I resolved my problem and wanted to review the additional replies so I could provide the information I that was helpful to me in resolving the problem in case others were interested. However, if I can not see any replies other than the first 4 perhaps others can not either so what use is it to post a reply after the first 4 have been posted?

  • 8. Re: Sync iCal with iCloud Calendar
    jr378 Level 1 Level 1 (0 points)

    Problem resolved, and I can now see the other replies, strange.

     

    Anyway, make sure you have a back up copy of your address book and iCal. Use the Export feature to make a back up.

     

    This is what I did to finally resolve the problem.

     

    Go into System Preferences and open "Mail, Contacts & Calendars". Remove all accounts, use the - box.

     

    Go into System Preferences and open "iCloud". Make sure that you have the screen that asks you to sign up for an account. DO not do this yet.

     

    Open Mac Mail and Preferences and remove any accouts that are still showing up so your Mail is completely empty.

     

    Reboot your Mac. Check all the above to see if any accounts have been automatically reinstalled or set up. If they have remove them again.

     

    Reboot again and do the same thing. Once no accounts are showing open you iCal and import the file you exported earlier. This will restore all your appointments in iCal on your Mac.

     

    Reboot your Mac. Make sure that all the iCloud and email accounts are not there. I had to do this 3 times, for what ever reason my old MobileMe account continue to be added back to "Mail, Contacts & Calendars". Once everything is clean and you have all your appointments in iCal, reboot again.

     

    Open Preferences and open "iCloud". Add your primary iCloud account and just wait for everything to finish installing. You should see 2 sets of appointments in iCal. Click on the Calendars button in the upper left and uncheck the box under the heading that does not say iCloud. This does not remove any of the appointments it just hides the ones that are on your Mac and then shows the ones that are on the iCloud Calendar.

     

    One last thing. In iCal open Preferences form the iCal dromdown menue. Under the "Default Calendar" option make sure that you have the default calendar related to the iCloud Calendar checked. If you do not when ever you create a new appointment on your Mac you will be creating it in iCal and two things will happen. First all your iCal appointments on your Mac will show up again and secondl, that appointment will not show up in iCloud Calendars so it will not migrate to your other devices.

     

    Apple should give some thought to having the iCal and iCloud Calendars merged so there are not seperate sets of appointments. I know there must be some reason for doing it the way they did but if someone is going to be using iCloud what would be the purpose of having a seperate set of appointments on your Mac that you have to hide and then worry about entering a new appointment that may not migrate to iCloud if you happend to se that appointment up in the iCal list instead of the iCloud list.

  • 9. Re: Sync iCal with iCloud Calendar
    thanos206 Level 1 Level 1 (0 points)

    I had the same problem and this is how i got through: I just connected my i Phone to my mac and sync the calendar... (my iphone's calendar was left blank after the ios5 update...). Then I just turned icloud syncing off and on again from iPhones preferences panel. After that all the events showed up in my iCloud's calendar and now it syncs great in every apple device!

     

    thantas

  • 10. Re: Sync iCal with iCloud Calendar
    MaxGuru Level 1 Level 1 (35 points)

    Sorry, I used the wrong phrase there. I should have said Sign Out of iCloud.

     

    The other thing you can do after signing out is go to iCal>Preferences>Accounts and delete the iCloud account there.

     

    Doing both the sign out of the iCloud account and the deletion from iCal seems to cause a "reboot" of iCloud when you sign back in and check Calendars on the iCloud pref pane. Just be sure you have a backup of all your calendars BEFORE doing any of this.

  • 11. Re: Sync iCal with iCloud Calendar
    travellingrvt Level 1 Level 1 (0 points)

    My problem was duplicate items in iCal on my Mac but iPhone was fine.

     

    To fix:

     

    System preferences>>>iCloud>>>unchecked Calendars>>>rechecked the Calendars box>>>pop up asking if I wanted to merge calendars>>>clicked yes and voila, no more duplicates :-)

  • 12. Re: Sync iCal with iCloud Calendar
    marcia s Level 1 Level 1 (5 points)

    I got mine to work...I did not have duplicates, but creating duplicates allowed my fix.

     

    Try this:

     

    1. System preferences>>>iCloud>>>unchecked Calendars>>>rechecked the Calendars box>>>pop up asking if I want to merge calendars>>>clicked yes   You will then have duplicate entries BUT the new set is from iCloud!

     

    2. iCal>>>Preferences>>>Accounts>>>deselect (ie uncheck the enable this account box) the NON-iCloud CalDAV account>>>you now have the iCloud info on your MacBookPro iCal screen!

     

    :)

  • 13. Re: Sync iCal with iCloud Calendar
    svejk1969 Level 1 Level 1 (0 points)

    First of all I did what was recommended above and deleted and then added back my iCloud account.

     

    I exported the calendars I didn't want, then imported them into my iCloud calendar when prompted.

     

    That seems to have done the trick thankfully - possibly not the most elegant way though...

  • 14. Re: Sync iCal with iCloud Calendar
    da remix Level 1 Level 1 (15 points)

    The simplest way is to go to System Preferences > Mail, Contacts>Calendars >> icloud - untick calendars (prompt that there will be changes) - the tick the calendar box (merge info) and voila!

1 2 Previous Next