1 2 3 Previous Next 35 Replies Latest reply: Apr 1, 2014 1:53 AM by David Wilkinson6
LossAngeles Level 1 Level 1 (0 points)

I've checked out everything and the service for Windows is handling iOs 4x devices fine. The iOs 5 devices can't find my printer now.

Thx for any tips or solutions.

-Greg

 

 

 


iPhone 4, iOS 5
  • 1. Re: AirPrint Activator to work with iOs 5?
    Groverwood Level 1 Level 1 (0 points)

    I ran into the same problem. I was using Airprint.exe to print from my Ipad and Iphone, and IOS5 just plain broke it. I found a new utility called "Fingerprint" and this solved the problem quickly and easily...  I'm not affiliated with this company at all, just a satisfied user wanting to spread the word.

     

    http://www.collobos.com/

  • 2. Re: AirPrint Activator to work with iOs 5?
    paulfromhere Level 1 Level 1 (0 points)

    It's possible to use free software (Virtualbox and Ubuntu) to fix the broken iOS 5 Airprint printing with non supported printers.  Here's a fix that works on my imac, but should also work on even a windows pc.

    My setup is a lion imac with 2 non-airprint supported usb printers attached, a belkin wifi router that provides network connectivity for my imac, ipad, and iphone.

    Install ubuntu 11.10 in a virtualbox vm.  Specify to use the "Bridged Adapter" with "en1: WiFi (AirPort)" for the network hardware.  Make sure the imac's usb printers are setup with sharing.  On ubuntu, select System Settings > Printers and add your imac's shared printers to the list.  Then start ubuntu's firefox and set "localhost:631" in the address. On the administration tab, under the Server section, check "Share printers connected to this system" and hit Change Settings button to activate it.  Go back to ubuntu's printer setup, and right click on each printer and check that the properties Policies tab does not have any messages about it being unshared. If so, then go back to firefox and make sure the Server sharing checkbox is enabled. It may help to reboot.

    Fire up virtualbox to be able to use AirPort printing to your imac's usb printers, when you want to print from the iphone or ipad. This also works on iOS 5.

    Only problem is error message from iphone to check the printer for errors, even though it actually prints ok.

     

  • 3. Re: AirPrint Activator to work with iOs 5?
    Guimon Level 1 Level 1 (10 points)

    I was able to make Airprint work with IOS 5 !!! here is what you need to do :

    First , if you had installed Airprint before and if the Airprint Service is still in your Service list ( you can check by running the command: services.msc ) you need to unregister it .

    to do so type at the command Prompt  ( Make sure your run the command line as an administrator ) :

     

    sc.exe delete Airprint

     

    Now we are going to re-register the Airprint service but with a slight different Command option:

    At the command line type the following 2 commands:

     

    sc.exe create AirPrint binPath= "C:\Program Files\AirPrint\airprint.exe -R _ipp._tcp,_universal -s" depend= "Bonjour Service" start= auto

     

    sc.exe start Airprint

     

    at this point , you should now be able to see a list of your shared printers from your IOS 5 Device !

     

    If you don't see your Printer, make sure your firewall is not blocking port 631.

     

    If you don't see any lock icon next to your printer name, then you're good to go !

    If you see a lock icon next to the printer name, make sure you enable the guest account in windows

    Once you enable the guest account , restart the Airprint service and Voila ! you now can print from your IOS 5 Device !

     

    Want to thank Takelei for finding the solution to this issue !

     

    Guimon

  • 4. Re: AirPrint Activator to work with iOs 5?
    jordi girona Level 1 Level 1 (0 points)

    Thanks!

     

    This solve the print problem on my ipad 2.

  • 5. Re: AirPrint Activator to work with iOs 5?
    Newstech Level 1 Level 1 (5 points)

    This was exciting to read but it's not happening for me on an iPad 1. Has anyone else made it work on a 1? I've tried various log-on settings, restarted Bonjour, rebooted iPad, etc.

  • 6. Re: AirPrint Activator to work with iOs 5?
    Newstech Level 1 Level 1 (5 points)

    Update: I'm playing peek-a-boo with my printer. After a PC reboot I saw it available on the iPad briefly, with the lock. I reenabled my guest account. After that, it was there, but didn't print. When I clicked again, it had gone away. I'm on Windows 7 Home Premium. Looking for tips on permissions, etc. Should I run the Airprint service under my own (administrative) logon, or Local System? This is nuts -- so near, but yet so far.

  • 7. Re: AirPrint Activator to work with iOs 5?
    Peter Gillespie Level 6 Level 6 (11,740 points)

    Excellent now working again on iPad and iP4 thanks for posting solution

  • 8. Re: AirPrint Activator to work with iOs 5?
    LossAngeles Level 1 Level 1 (0 points)

    Way to go. Too bad Apple couldn't provide this information before they effectively shut down printing for thousands of it's users without notice.

  • 9. Re: AirPrint Activator to work with iOs 5?
    LossAngeles Level 1 Level 1 (0 points)

    Update: While I can see the printer and lock, it's not prompting me for a password , and thus no output to printer. Windows 7 professional.

  • 10. Re: AirPrint Activator to work with iOs 5?
    Newstech Level 1 Level 1 (5 points)

    This has changed from previous functionality. It will not prompt for the password. That's why you need to enable the guest account.

  • 11. Re: AirPrint Activator to work with iOs 5?
    Newstech Level 1 Level 1 (5 points)

    Update 2: Still playing peek-a-boo. Had it working like a champ for a while, but printer then goes invisible and restarting services doesn't bring it back. Would love to find a method short of rebooting PC.

  • 12. Re: AirPrint Activator to work with iOs 5?
    LossAngeles Level 1 Level 1 (0 points)

    No, something else is going on (or not). The guest account is enabled however the printer share on the iPhone still shows a lock which tells me the device is looking to authenticate to the print share host. I'm hoping a Win 7 user who actually has this working will join this conversation.

  • 13. Re: AirPrint Activator to work with iOs 5?
    Newstech Level 1 Level 1 (5 points)

    For what it's worth, I just went through three cycles where my Canon shared printer was not visible via Airprint, and I reset my router, and the printer immediately popped up on the iPad as the router restart finished. I have a Rosewill RNX-EasyN400, which I think is still only draft-n compliant. Dang! Looking for possibly relevant settings in the router, but this might be my incentive to buy an n-compliant router. Again, Windows 7 Home Premium 64-bit, Canon i860 printer, iPad 1, airprint.exe with the new startup commands.

  • 14. Re: AirPrint Activator to work with iOs 5?
    LossAngeles Level 1 Level 1 (0 points)

    Everything is working for me except the actual output to the printer. I still think the authentication scheme issue might be affecting that.

     

    I'm opening the Win7 printer queue and any output sent via the iPhone doesn't appear there. A local pc print does appear and works fine tho.

1 2 3 Previous Next