Previous 1 2 3 Next 37 Replies Latest reply: Jul 28, 2013 4:41 PM by ebravo06
medicommrob Level 1 Level 1 (0 points)

I have a complete duplicate set of contacts on address book on my Mac because there are two lists — iCloud and On my Mac. Is there a way to get rid of the duplicates. As a result of the duplicate entries, I get duplicate birthdays in iCal as well. I've tried the "look for duplicates" function in Address Book but that was useless.


MacBook Pro, Mac OS X (10.7.2)
  • Carolyn Samit Level 10 Level 10 (98,305 points)
  • andreas-kalt Level 1 Level 1 (0 points)

    In the document you linked to, there's no mention of the problem with duplicate contacts.

  • medicommrob Level 1 Level 1 (0 points)

    The document pointed me in the right direction. I turned iCloud contacts off in System Preferences. Then I deleted all of the contacts in my address book on iCloud.  I turned Contacts back on in iCloud under System Preferences. It then merged the contacts on my Mac to the empty Address Book on iCloud and that eliminated the duplicates.

  • Gadget Doctor Level 1 Level 1 (5 points)

    I noticed the same thing: after iCloud my contacts were all duplicated but Address book listed two distinct sets:

     

    • On the Mac
    • On iCloud

     

    After taking a backup of the entire address book I just deleted the entire set that were on the mac and the iCloud ones are now working fine.

     

    I'm still not sure what to do with Spanning Sync which I've turned off for now. That was keeping my contacts on google synced but I'm not sure whether that is looking at the contacts that were only in the Address book and not at the iCloud ones.

  • medicommrob Level 1 Level 1 (0 points)

    I spoke too soon. The solution I outlined above was only a temporary one. The issue has returned. I again have a two sets of contacts — one listed as "on my mac" and the other listed as "icloud".  It might be time for a call to Applecare.

  • wompedy Level 1 Level 1 (0 points)

    I'm having exactly the same problem. Right down to the "yay! it's fixed" solution of turning off and back on, only to have the problem return again. Ug. I wish there was an fix here.

     

    Most annoying of all is that it's managed to lose my photos associated with people's contact cards, and re-adding these is extremely time consuming.

  • nalley Level 1 Level 1 (0 points)

    I went to preferences, turned off the Cloud updates to my Contacts and had it remove all Cloud Contacts from my computer.  Then, I manually deleted all the contacts on my computer (open up Contacts, hit command+a, then delete).  Turned the Cloud updates back on in preferences, and no more duplicates!

  • andreas-kalt Level 1 Level 1 (0 points)

    @medicommrob

    Do you have Google- or Yahoo Sync enabled? I found that enabling that made the duplicate copies return. Disabling it (after going through the solution steps outlined in this thread) kept the problem away.     

  • medicommrob Level 1 Level 1 (0 points)

    @andreas-kalt. No, I don't use either service.

  • leon-geyer Level 1 Level 1 (10 points)

    Found this http://forums.macrumors.com/showthread.php?p=13649312

     

    Go to System Pref on your Mac
    Click iCloud
    Untick Address Book, selected Delete from Mac
    Then tick Address Book again, then select Merge

     

    Duplicates will be removed and if you are using Birthdays in your Calendar, you'll notice that the Birthday events are back to single entries as well.

     

     

    Another solution I figured out:

    go in Addressbook to Edit: Distribution List, and unchecked iCloud.
    That made it for me, but will iCloud actualize?

    Also deactivating accounts in preferences both of addressbook and iCal, but the mess in iCal is that I now have a lot of "Birthdays" without name (as many as people WITH name have that day...)

    s..t, buggy stuff

  • medicommrob Level 1 Level 1 (0 points)

    That is what I did initially and that worked but the next morning when I powered I had all of the duplicates back again. Got a call scheduled with Applecare tomorrow.  I'll see where that goes.

  • medicommrob Level 1 Level 1 (0 points)

    The duplicate contacts issue was being caused by Outlook and Sync Services. It seems Outlook has no way of seeing the iCloud content so it basically creates the "on my Mac" version of the contacts thereby creating a complete set of duplicates. As usual Microsoft has no solution for this so I've decided to migrate over to Mail. Contact sync was the last useful feature Outlook could provide. I had abandoned its calendar function when the new Mobile Me came out. I like the integrated functions of Outlook (mail, calendar, and addresses) and Entourage before that but there are too many issues now to make it a useful app.

  • ChuckInNJ Level 1 Level 1 (15 points)

    Thank you for sharing this. I had the same problem, saw your post, and confirmed that Microsoft was to blame for my duplicates too. Entourage's Sync was the culprit.

  • berlinbass Level 1 Level 1 (0 points)

    Leon - your suggestion saved the day! I was going crazy with a constantly maxed out cpu when the address book was open. Your "untick and tick" address book (and deleting the "on my mac" data) did the trick! Thanks a million!

Previous 1 2 3 Next