Skip navigation

iMessage sent from email address rather than phone number...

645449 Views 194 Replies Latest reply: Apr 2, 2014 5:09 AM by ross646 RSS
  • alaweap Level 1 Level 1 (0 points)

    I had the exact same problem. I looked everywhere on the Internet and even asked my friends. My imessaging wouldnt come up under my number only my email and it was fairly annoying. BUT I figured it out somewhat.. For me Turning off my iphone fixed the problem. I went back into messaging and my email wasnt under the reciepitents only m phone number was. wala! I hoped that helped

  • frankfrommadera Level 1 Level 1 (0 points)

    So here's the über answer for all this nonsense that is Apple iMessage

     

     

    When you sign into iMessage (on an iphone) using your apple ID. It does 2 things.

     

    It not only registers your phone number as an iMessage device but also the email address as well.

     

    Good? Ok. 

     

    So under Settings>Messages>Receive At

    You should have your phone # AND your Apple ID email.   These are all of the address (so far) that iMessage will use as your device address (so to speak). So if your friend, neighbor, boyfriend, cousin, baby-mama or whoever uses an iDevice to send a message to this address "ding" you get a message. 

     

    Settings>Messages>Receive At>Caller ID

    Is where when you send an I message to an iDevice and they dont yet have you programmed into their phone as a contact THIS WILL BE YOUR CALLER ID. so change it accordingly. iPhone users will probably want to make this their phone number.  Other iDevice users will have a choice between different emails not a number if it's a pod or pad or Mac.

     

    If you send an iMessage to a non iPhone iDevice your email will be used as caller ID instead (because they dont have a wireless number associated)

     

    IF YOU LOSE DATA SERVICE EVERY NOW AND THEN, THEN THIS PART WILL MAKE LOTS OF SENSE

     

    If you originally start an iMessage using an iPhone users email and not phone number, then for whatever reason if you don't have data at the time of your message it will send it as an email NOT A TEXT. It does not revert back to their default number even if it's stored into your contacts.

    So if you are in the mountains or under a bridge and you have crap for service aka no data only cellular and you send an iMessage it will go to that persons email address that you originally used to start the conversation from something like 5595551234@mms.att.net NOT THEIR WIRELESS NUMBER AND WILL NOT SHOW UP IN IMESSAGE.

     

    It's dumb but I figured it out this while AppleCare was scratching their head last night.

     

    Settings>Messages>Send As SMS

    This is the exact opposite of the conundrum from above and is more straight forward. If you don't have data when you send a message to an iMessage users phone number then it will send as a text message and cost u money if it isn't unlimited or whatever. So unclick if you are a text fiend with a low text plan.

     

    hope that covers 99% of the questions about iMessage. 

     

    GOOD LUCK!

  • Redd3305 Level 1 Level 1 (0 points)

    I had this problem for 3 months now.  And I finally figured it out.  If what has been posted does not work, you probably had the same problem I had.  If you shut log out of your apple ID and that doesnt work for you and it still seems to be sending from your email address you need to go into your apple ID account and make sure you have verified your cell phone number!!!!! Mine was not listed under mobile number.  Once I added my mobile number to my apple ID account Tada magic I started getting imessage with my number not my email.  You can still have your email address listed you will not have to delete it.  Hope this helps I know it did for me !!!!

  • Nazrul Apple Level 1 Level 1 (0 points)

    How to solve iMessage sent as an email address rather than phone number:

     

    Found a fix by .Gru that worked for me:

     

    Goto Settings, Messages, Receive at, sign out of your apple ID

     

    Thats it!

     

    If you are signed in, it will use your email by default rather than your phone number.

    Signing out refers it back onto your number instead. Now all messages are from the one sender.

     

    Problem solved! Hope this helps

  • zhepps Level 1 Level 1 (0 points)

    I did all of these things and im pretty sure signing out of my apple id worked. However, know i cannot receive face times and when someone sends one to me it says sending to "my name or my email"

  • weeta2000 Level 1 Level 1 (0 points)

    many thanks this solved the problem.  Hooray!

  • bfullner Level 1 Level 1 (0 points)

    You are a life saver, my friends were so confused when they kept getting e-mails from me instead of iMessages. This fixed it rigth away.

  • john 171 Level 1 Level 1 (0 points)

    Are you connected to Wifi or using 3G?

  • Jono85jsy Level 1 Level 1 (0 points)

    "THIS IS THE SOLUTION" ..As you stated turn imessager off then back on .... it will then ask for u to sign into your email by asking for your personal email address password.. i just dismissed it and then it readjusted the recieved at option to my mobile number.....

     

    very annoying apple for setting that up in the first place i dunno how many messages ive sent and not got a reply simply cause the recipiant had no idea whos email address it was...

     

    hope this helps.

  • LaurieLou Level 1 Level 1 (0 points)

    I have a new iphone 4S. My iMessage seems to work asit does come up in blue yet my messages are received from my apple id email, not my phone number. Also, when I go into message settings, iMessage is on but says "waiting for activation". After a while, it says "activation unsuccessful". My number is not even available to select under "Receive At", I only have the option of adding another email and do not have caller ID option. Can anyone help?!

  • moza16 Level 1 Level 1 (0 points)

    Aye guys,

     

    Well, at first it was an issue for me; trying to get my number verifyied in both, but after sometime I got it all figured out.

     

    To activate iMessage with you phone number: Sign out of your apple ID, make sure you have sufficient airtime in your iPhone (as iMessage will need to access your carrier to verify your cell phone number), both FaceTime and iMessage should be OFF.

     

    Turn iMessage ON first then you'll be prompted with a pop-up message requiring you to either Accept (OK) or Cancel iMessage's activation through your carrier. Accept, or, in other human language, press OK. You should see it activating ...

     

    Back off from iMessage to FaceTime. Do the same procedure as the one we did for iMessage and you will have both activated and both using your cell phone number.

     

    *You can add your email afterwards in the "Receive at" for iMessage and "Add email" for FaceTime.

     

    Cheers.

  • LaurieLou Level 1 Level 1 (0 points)

    Mine still says 'waiting for activation' and eventually it says that activation was unsuccessful...

  • sorangameel Level 1 Level 1 (0 points)

    I have tried to sign out of imessage on the phone and on my computer. If I send a message from my computer it sends from my email. And if I get an iMessage on my phone it dosent show up on my computer. Any solution to this?

    I have the same appleid on my phone and my computer! Looks like this on my mac.

     

    http://fotodag.se/soran/imessage.jpg

  • cit1974 Level 1 Level 1 (0 points)

    if the other person is receiving an imessage that says its coming from your email address and not your contact name - the easy solution is have the other person make sure that your email address is listed in their contacts - in the same contact that has your phone number.  also make sure the caller ID in your imessage is set to your phone number.  this solved the issue where when I texted our daughter they would initially come up as from my email address - the above switch helped solve that.  Also all of the house phones were under/using same apple ID - if this is the case then you need to make sure everyone has a different email address under  the received at option in imessage - initially they all had mine - and when i used imessage they would go to our daughters email and not as a text.  changing the email addresses so that they were all different on each phone - solved that second issue (which was actually the first problem that I had to solve - to get the texts to her first).

  • Randall2point0 Level 1 Level 1 (0 points)

    I have this problem also with my iPad. In settings there is no option for caller id. Is someone else able to see a caller id option on their iPad?

1 ... 5 6 7 8 9 ... 13 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (8)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.