Previous 1 2 3 4 5 6 Next 109 Replies Latest reply: Jan 15, 2014 4:18 PM by Time Fades Away Go to original post Branched to a new discussion.
  • Goldie81 Level 1 (0 points)

    Okay...I'm a new iphone lemming.  So how do you do a backup before doing a restore?    I am sick of having phone numbers show up in conversation threads and not the name of my contact!!  I can get the name to once in a while show up but it will not stay!

  • Bruce Crocker Level 1 (0 points)

    I had the same problem and, with help from Apple, just solved it.  I don't know that this works for everyone, but it completely solved the issiue for me.  I went to Settings, General, International, Language.  There I switched from English to another language (anything other than English) and pressed "Done."  After a brief "pinwheel" the phone appeared in the new language.  Next, I went through the same process and switched back to English.  NOTE: if you have switched to a language you don't understand, make sure you rememeber where the options are as you go through the "Settings, General, International and Language" sequence because all of those options will appear in the new language!  Switch back to English and press "done" again.  For me, that worked.

  • DFA42 Level 1 (0 points)

    Verizon tech gave this to me for a Verizon iPhone 4S with iOS 5.01.


    1.Settings/General/Reset/Reset Network Settings

    .... wait for bars (not necessarily WiFi)

    2. Call    *228    option 1 

         Wait for programming to complete

    3. Shutoff iPhone, then Restart

    4 . In Settings, reset WiFi service (need you local network password)



    ... should return  Caller Id function

  • skibutte Level 1 (0 points)

    ********SOLUTION FOUND*****


    I just off the phone with Apple Support SeniorEengineer. It took me an hour to get to this level, but he then fixed my issue in 2 minutes and now everything shows up correctly.


    To give you the background: I upgraded from a 3GS to a 4S and moved my service from AT&T to Verizon. The phone numbers were not showing up correctly [4589658965 vs. (458) 965-8965]. This also affected the caller id when calls came in and the text message id. It also prevented Siri from being able to call anyone in my contacts list.


    Here is the Fix from Senior Engineer Shawn:


    1. Dial *22899 to get the latest software update from Verizon.

    2. You will get confirmation of your update. It will show up on your screen as "Update Successful"

    3. Go to the home screen and then double-click the home button so your taskbar appears.

    4. Hold the contacts button (On the taskbar) for about 2 seconds until the icons start to shake and a little minus sign in a red circle shows up in the upper left of the icon.

    5. Turn off (by clicking the minus sign) all applications that may be using your address book. You can scroll left to right to make sure you get them all.

    6. Once they are all turned off, reboot your phone by powering it off and then back on again.

    7. Tadaaa!!! Everything should be working correctly.


    I really hoped this helped.



  • phqnkmj Level 1 (0 points)

    Well, so far I've tried everything in this thread.  The *228 does work initially, but if you power off your phone and/or reboot it for any reason, then it will revert back to continual # format.  Also, for me some numbers still aren't recognized.  Depending on who is calling or messaging me I get numbers send in all sorts of formats.  Some with the +1 some with just the 1 and the area code and some with just the area code.  If I don't have the number entered exactly as it is sent then it will not show up with the persons name that is associated with. 


    So, for those of you that have tried the *228 trick, power your phones off and then back on and see what happens. I am curious to see if it's just me that it doesnt work for.

  • Bruce Crocker Level 1 (0 points)

    The 228 fix did not work for me. Apple had me reset the phone to a diode rent language - anything other than English - then reset it back to English. That completely solved the problem.

  • Bruce Crocker Level 1 (0 points)

    Sorry - that should have been "different language" !

  • phqnkmj Level 1 (0 points)

    All right everybody.  Here's the skinny.  Like I mentioned before, I tried everything.  Restore from backup, complete reset, *228, change language, all of it.  It all worked temporarily.  I'm gonna bet that that those of you that have "fixed" the problem, only need to power on/off or reset it and it will be back to the way it was. 


    Now.  With that said I think I have the permanent solution.  After playing with it myself for a while I finally took it to the Apple store (Verizon support is useless).  The "genius" and I stumbled upon what was causing my issue. Although I have Verizon service, I have always enabled my PIN on the SIM card that comes with the phone.  Why?  I dunno.  Just because I can.  Well that apparently is what is messing with way numbers are displayed/recieved.  After I disabled the SIM PIN and did a power on/off the numbers were back to the

    (123) 456-7890 format, and they staid that way after several reboot/resets.  We turned the SIM PIN back on and the phone numbers went back to 1234567890 format, and nothing incoming would be recognized unless it was entered in whatever format it was recieved at, which for me was a combination of all sorts of formats. 


    So I see that alot of people are AT&T customers coming over to Verizon, so maybe those of you have enabled your PIN because thats what you were used to doing with AT&T.  If you have your PIN enabled, disable it and do a power off/on or reset it, and everything should be back to normal.  If you don't have your PIN enabled and are still having this problem then I'm sorry this won't help. 

  • jd2020 Level 1 (15 points)

    Several "solutions" have been detailed in this thread (*228, International Dial Assist, and now SIM PIN).  This is the first time I've seen the connection to the SIM and a Verizon phone.  This problem first popped up for me after returning from Germany with a German SIM in my iPhone 4S on Verizon. *228 method solved for me.


    It makes sense that these are all connected to inernational vs US dialing and Caller ID.  Since the SIM in a Vzw iPhone is intended for international use, this might make sense.


    Is anyone having this caller ID problem with an AT&T 4S?

  • ianrip Level 1 (0 points)


    I'm not in the US, and I've had the same problem, I'm in work in Yemen (MTN) and reside in Thailand (AIS), some contacts have the international prefix + code, some only with the 0 for the local number, I've tried the change language fix, and so far its working.

    Let's wait and see what happens when I swap SIM and reach Thailand in 7 days time.

  • StarryRudy Level 1 (0 points)


    I live in Yemen and I have sabafon, I have a problem with numbers and messages since I updated my iPhone to ios 5 then to ios 5.0.1, the problem is that when I receive SMS, only numbers with prefix +967 are shown not the contacts

    name, I have tried to change the language to Arabic and also I changed the format of the numbers but nothing worked.

    I also reset the settings but nothing worked

    You said that you fixed the problem, would you tell me how?

  • paulettefromvalencia Level 1 (0 points)

    I have never responded to any of these "help" threads before, but after an hour of getting nowhere with Apple, wanted to say THANK YOU TO SKIBUTTE (posted 11/25).   I have a Verizon IPhone 4S iOS 5.0.1, and suddenly lost my Caller ID capability and all of my phone numbers had no dashes or parenthesis.  If you are a Verizon customer with an IPhone 4S, and are experiencing this same problem see post and follow the directions:

    *******************SOLUTION FOUND******************

    and THANK YOU again, skibutte!!!!!!

  • anacolorado1 Level 1 (0 points)

    So here is my delima:


    I bought the Iphone 4S with the Verizon carrier, and after the first week of buying it it does the whole problem that everyone else has been complaining about having to add the +1 to every contact in order to recognize the number and name, although in my case incoming calls will appear as a different number so I have to add TWO of the same numbers to my contact; one with the +1 for outgoing text and calls and the regular number for incoming calls. With this being very fraustrating, I did the system restore on my computer, which did not do any good. Then I went to the Apple store for a consulation where they do a "deeper system restore" and that still didn't work. So then I went online to find any other solutions and came across the method of dialing *228, pressing 1 or 2 (which I tried both), then going to the task manager and wiping out messages, contacts, and phone apps. Then waited about 5 minutes as instructed and went back to my messages to check to see if all my names appeared in my messages. Still I am not having any success to this and its literally driving me up the wall. What else is there to do?

  • Bruce Crocker Level 1 (0 points)

    It seems that not all fixes work for all people.  Apple solved the problem for me by having me change my phone from English to another language (any language other than English) and then change back to English. I have no idea why it worked, but it completely solved the problem for me.  You do this by going to Settings - General - International - Language.  One tip: remember where the menu items are visually because after you reset your phone to the new language all menu items will be in the new language.  I had trouble getting back to Settings - General - International - Language in the new language!  Hope thjis helps.

  • danielfromzapopan Level 1 (0 points)

    believe it or not... mi iphone got fixed chaging the lenguage to spanish and back to english

Previous 1 2 3 4 5 6 Next